aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer-plugins
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-02-25 10:58:42 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-02-25 10:58:42 +0000
commitf63874893a6024630cc10e9d615503f5adccf3a1 (patch)
tree3de2e40a79b45604e01437ff197c0a106c8c00d6 /multimedia/gstreamer-plugins
parentb3c3c64ce01964e06220ab70fb4e325dd328d956 (diff)
downloadports-f63874893a6024630cc10e9d615503f5adccf3a1.tar.gz
ports-f63874893a6024630cc10e9d615503f5adccf3a1.zip
Update Gstreamer-plugins-base to 0.10.32
Update Gstreamer-plugins-good to 0.10.27 Update Gstreamer-plugins-bad to 0.10.21 Update Gstreamer-plugins-ugly to 0.10.17 Add flite plugin. plugin for the flite Speech synthesis engine. Add opencv plugin. plugin for opencv Computer vision library. Move vdpau plugin to a beter category. Remove LOCAL master sites that haven't been updated for ages. Check if Gstreamer (core) is recent enough. Remove 6.x BROKEN line for the bad plugin.
Notes
Notes: svn path=/head/; revision=269675
Diffstat (limited to 'multimedia/gstreamer-plugins')
-rw-r--r--multimedia/gstreamer-plugins/Makefile18
-rw-r--r--multimedia/gstreamer-plugins/Makefile.common11
-rw-r--r--multimedia/gstreamer-plugins/distinfo18
-rw-r--r--multimedia/gstreamer-plugins/files/patch-configure11
-rw-r--r--multimedia/gstreamer-plugins/pkg-plist4
5 files changed, 28 insertions, 34 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index 98422797e6af..2c8e03bf0ac1 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -14,33 +14,30 @@ CATEGORIES?= multimedia audio
MASTER_SITES= http://gstreamer.freedesktop.org/src/gst-plugins-base/:base \
http://gstreamer.freedesktop.org/src/gst-plugins-bad/:bad \
http://gstreamer.freedesktop.org/src/gst-plugins-good/:good \
- http://gstreamer.freedesktop.org/src/gst-plugins-ugly/:ugly \
- ${MASTER_SITE_LOCAL:S|$|ahze/:base|} \
- ${MASTER_SITE_LOCAL:S|$|ahze/:good|} \
- ${MASTER_SITE_LOCAL:S|$|ahze/:bad|} \
- ${MASTER_SITE_LOCAL:S|$|ahze/:ugly|}
+ http://gstreamer.freedesktop.org/src/gst-plugins-ugly/:ugly
PKGNAMESUFFIX?= -plugins${GST_PLUGIN_SUFFIX}
MAINTAINER= multimedia@FreeBSD.org
COMMENT?= GStreamer written collection of plugins handling several media types
BUILD_DEPENDS+= v4l_compat>=1.0.20100321:${PORTSDIR}/multimedia/v4l_compat \
+ gstreamer>=0.10.32:${PORTSDIR}/multimedia/gstreamer \
orc>=0.4.11:${PORTSDIR}/devel/orc
LIB_DEPENDS+= gstreamer-0.10.0:${PORTSDIR}/multimedia/gstreamer \
orc-0.4.0:${PORTSDIR}/devel/orc
CFLAGS:= ${CFLAGS} -O2 -Wno-format
-BASE_PORTVERSION= 0.10.31
+BASE_PORTVERSION= 0.10.32
BASE_DISTNAME= gst-plugins-base-${BASE_PORTVERSION}
BASE_DISTFILE= ${BASE_DISTNAME}${EXTRACT_SUFX}
-BAD_PORTVERSION= 0.10.20
+BAD_PORTVERSION= 0.10.21
BAD_DISTNAME= gst-plugins-bad-${BAD_PORTVERSION}
BAD_DISTFILE= ${BAD_DISTNAME}${EXTRACT_SUFX}
-GOOD_PORTVERSION= 0.10.26
+GOOD_PORTVERSION= 0.10.27
GOOD_DISTNAME= gst-plugins-good-${GOOD_PORTVERSION}
GOOD_DISTFILE= ${GOOD_DISTNAME}${EXTRACT_SUFX}
-UGLY_PORTVERSION= 0.10.16
+UGLY_PORTVERSION= 0.10.17
UGLY_DISTNAME= gst-plugins-ugly-${UGLY_PORTVERSION}
UGLY_DISTFILE= ${UGLY_DISTNAME}${EXTRACT_SUFX}
DIST?= good
@@ -96,9 +93,6 @@ WRKSRC=${WRKDIR}/${BAD_DISTNAME}
PORTVERSION= ${BAD_PORTVERSION}
DISTFILES+= ${BAD_DISTFILE}:bad
PATCHDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins-bad/files
-.if ${OSVERSION} < 700000
-BROKEN= does not configure properly on 6.X (shm plugin)
-.endif
.elif ${DIST}=="ugly"
EXTRACT_ONLY=${UGLY_DISTFILE}
WRKSRC=${WRKDIR}/${UGLY_DISTNAME}
diff --git a/multimedia/gstreamer-plugins/Makefile.common b/multimedia/gstreamer-plugins/Makefile.common
index 8f2a038a2fdc..f9bc7528fd02 100644
--- a/multimedia/gstreamer-plugins/Makefile.common
+++ b/multimedia/gstreamer-plugins/Makefile.common
@@ -49,6 +49,7 @@ BAD_GST_ALL_PLUGINS+= \
nas \
neon \
ofa \
+ opencv \
resindvd \
rsvg \
schro \
@@ -336,7 +337,7 @@ gst_hal_PLIST_FILES= ${GST_LIB_DIR}/libgsthalelements.la \
gst_jack_LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
gst_jack_PLIST_FILES= ${GST_LIB_DIR}/libgstjack.la \
${GST_LIB_DIR}/libgstjack.so
-gst_jack_DIST= bad
+gst_jack_DIST= good
# jpeg
gst_jpeg_LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
@@ -429,6 +430,14 @@ gst_ogg_PLIST_FILES= ${GST_LIB_DIR}/libgstogg.la \
${GST_LIB_DIR}/libgstogg.so
gst_ogg_DIST= base
+# opencv
+gst_opencv_BUILD_DEPENDS+=opencv<=2.1:${PORTSDIR}/graphics/opencv
+gst_opencv_RUN_DEPENDS+=opencv<=2.1:${PORTSDIR}/graphics/opencv
+gst_opencv_PLIST_FILES= ${GST_LIB_DIR}/libgstopencv.la \
+ ${GST_LIB_DIR}/libgstopencv.a \
+ ${GST_LIB_DIR}/libgstopencv.so
+gst_opencv_DIST= bad
+
# pango
gst_pango_USE_GNOME+= pango
gst_pango_PLIST_FILES= ${GST_LIB_DIR}/libgstpango.la \
diff --git a/multimedia/gstreamer-plugins/distinfo b/multimedia/gstreamer-plugins/distinfo
index fb6ead000936..6dd702478bd3 100644
--- a/multimedia/gstreamer-plugins/distinfo
+++ b/multimedia/gstreamer-plugins/distinfo
@@ -1,10 +1,8 @@
-SHA256 (gst-plugins-base-0.10.31.tar.bz2) = abb006c78222cfb69d31e983268d1d5219e9d4e0da24c6c4cd687968af7a33bd
-SIZE (gst-plugins-base-0.10.31.tar.bz2) = 2644897
-SHA256 (gst-plugins-base-0.10.30.tar.bz2) = 63938641380be9935c804ae8d55acdcfd93920ed2deb72dcf70f027a78b085d7
-SIZE (gst-plugins-base-0.10.30.tar.bz2) = 2455042
-SHA256 (gst-plugins-bad-0.10.20.tar.bz2) = 1031dff866df976a957f34039addbab4c0753406299a275f4cf1780e1dbe2a90
-SIZE (gst-plugins-bad-0.10.20.tar.bz2) = 3209622
-SHA256 (gst-plugins-ugly-0.10.16.tar.bz2) = d7fc7636001e78736540c628ad889888cb85ea722f08d1c6813b16682dd9c09c
-SIZE (gst-plugins-ugly-0.10.16.tar.bz2) = 1041297
-SHA256 (gst-plugins-good-0.10.26.tar.bz2) = ceb3bbea5ce18463b8fe470d34786bc846469e800305c436d799af9fe22bdcc4
-SIZE (gst-plugins-good-0.10.26.tar.bz2) = 3011746
+SHA256 (gst-plugins-base-0.10.32.tar.bz2) = e9aabfac83f6480896da0686e9c911989f896fbad634821b7771ed84a446172b
+SIZE (gst-plugins-base-0.10.32.tar.bz2) = 2720103
+SHA256 (gst-plugins-bad-0.10.21.tar.bz2) = 422badacbda37ac33cb446c6751dabcd0b223c308dbb01024a34ded682fa47e3
+SIZE (gst-plugins-bad-0.10.21.tar.bz2) = 3429224
+SHA256 (gst-plugins-ugly-0.10.17.tar.bz2) = 0cbd4aa8dceafea21ddd547dfde686a8836f68ba547afa5575a52b64cfa0b369
+SIZE (gst-plugins-ugly-0.10.17.tar.bz2) = 1050400
+SHA256 (gst-plugins-good-0.10.27.tar.bz2) = a9d801c3d42b456a6ebc0b95f68c44f153f756ec0fbd4877197c469cc67771fa
+SIZE (gst-plugins-good-0.10.27.tar.bz2) = 3096221
diff --git a/multimedia/gstreamer-plugins/files/patch-configure b/multimedia/gstreamer-plugins/files/patch-configure
index b5956d04069a..e69de29bb2d1 100644
--- a/multimedia/gstreamer-plugins/files/patch-configure
+++ b/multimedia/gstreamer-plugins/files/patch-configure
@@ -1,11 +0,0 @@
---- configure.orig 2010-12-02 10:39:38.000000000 +0100
-+++ configure 2010-12-02 10:40:28.000000000 +0100
-@@ -23508,7 +23508,7 @@
- if ( echo yes | grep -e '^201-90-9-0-10-9-0-30-9' >/dev/null ) ; then
- GST_PACKAGE_RELEASE_DATETIME=yes
- else
-- YYYY_MM_DD=`. "${srcdir}/common/extract-release-date-from-doap-file" $PACKAGE_VERSION_MAJOR.$PACKAGE_VERSION_MINOR.$PACKAGE_VERSION_MICRO "${srcdir}/gst-plugins-base.doap" `;
-+ YYYY_MM_DD=`./"${srcdir}/common/extract-release-date-from-doap-file" $PACKAGE_VERSION_MAJOR.$PACKAGE_VERSION_MINOR.$PACKAGE_VERSION_MICRO "${srcdir}/gst-plugins-base.doap" `;
- if test "x$YYYY_MM_DD" != "x"; then
- GST_PACKAGE_RELEASE_DATETIME=$YYYY_MM_DD
- else
diff --git a/multimedia/gstreamer-plugins/pkg-plist b/multimedia/gstreamer-plugins/pkg-plist
index d1cfc9c1f3af..444dc999c3ba 100644
--- a/multimedia/gstreamer-plugins/pkg-plist
+++ b/multimedia/gstreamer-plugins/pkg-plist
@@ -38,6 +38,8 @@ include/gstreamer-%%VERSION%%/gst/interfaces/xoverlay.h
include/gstreamer-%%VERSION%%/gst/netbuffer/gstnetbuffer.h
include/gstreamer-%%VERSION%%/gst/pbutils/codec-utils.h
include/gstreamer-%%VERSION%%/gst/pbutils/descriptions.h
+include/gstreamer-%%VERSION%%/gst/pbutils/encoding-profile.h
+include/gstreamer-%%VERSION%%/gst/pbutils/encoding-target.h
include/gstreamer-%%VERSION%%/gst/pbutils/gstdiscoverer.h
include/gstreamer-%%VERSION%%/gst/pbutils/gstpluginsbaseversion.h
include/gstreamer-%%VERSION%%/gst/pbutils/install-plugins.h
@@ -98,6 +100,8 @@ lib/gstreamer-%%VERSION%%/libgstdecodebin.la
lib/gstreamer-%%VERSION%%/libgstdecodebin.so
lib/gstreamer-%%VERSION%%/libgstdecodebin2.la
lib/gstreamer-%%VERSION%%/libgstdecodebin2.so
+lib/gstreamer-%%VERSION%%/libgstencodebin.la
+lib/gstreamer-%%VERSION%%/libgstencodebin.so
lib/gstreamer-%%VERSION%%/libgstffmpegcolorspace.la
lib/gstreamer-%%VERSION%%/libgstffmpegcolorspace.so
lib/gstreamer-%%VERSION%%/libgstgdp.la