aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer1-plugins-all/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2016-01-08 10:28:27 +0000
committerKoop Mast <kwm@FreeBSD.org>2016-01-08 10:28:27 +0000
commit3491b54d8a3291d8b30c2bced24fae3974604564 (patch)
tree76a8f4f0c5eef08fd569cc164694c9344bd1f6af /multimedia/gstreamer1-plugins-all/Makefile
parent4b8caa6b8ff01bd2dd177c82716004e2163ed4c4 (diff)
downloadports-3491b54d8a3291d8b30c2bced24fae3974604564.tar.gz
ports-3491b54d8a3291d8b30c2bced24fae3974604564.zip
Update gstreamer-plugins-all and gstreamer1-plugins-all
* Filter out "unwanted" plugins before building the OPTIONS * Sync both Makefiles so they only have gstreamer version specifics * Bump portrevision for option changes. Now all bsd.gstreamer.mk elements where listed before. Submitted by: marino@
Notes
Notes: svn path=/head/; revision=405541
Diffstat (limited to 'multimedia/gstreamer1-plugins-all/Makefile')
-rw-r--r--multimedia/gstreamer1-plugins-all/Makefile38
1 files changed, 20 insertions, 18 deletions
diff --git a/multimedia/gstreamer1-plugins-all/Makefile b/multimedia/gstreamer1-plugins-all/Makefile
index a7eb29f45020..12bc007cf8d7 100644
--- a/multimedia/gstreamer1-plugins-all/Makefile
+++ b/multimedia/gstreamer1-plugins-all/Makefile
@@ -3,39 +3,41 @@
PORTNAME= gstreamer1-plugins-all
PORTVERSION= ${GST1_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia
MAINTAINER= multimedia@FreeBSD.org
COMMENT= Meta-port of all GStreamer 1.x plugins with options
USES= metaport
-
USE_GSTREAMER1= yes
.include "${.CURDIR}/../../Mk/bsd.gstreamer.mk"
-.for all in ${_GSTREAMER_PLUGINS}
-OPTIONS_DEFINE+= ${all:tu}
+ALL_PLUGINS:= ${_GSTREAMER_PLUGINS}
+# Weed out gst-plugins that can not be packaged. or are broken.
+.if defined(PACKAGE_BUILDING)
+# FAAC: Mp4 Dolby license , no package
+# LAME: MP3 License , no package
+# VDPAU: Needs to be build agains running kernel
+DEF_PLUGINS:= ${_GSTREAMER_PLUGINS:Nfaac:Nlame:Nvdpau}
+.else
+DEF_PLUGINS:= ${_GSTREAMER_PLUGINS}
+.endif
+
+.for all in ${ALL_PLUGINS}
${all:tu}_DESC= ${all} plugin
-OPTIONS_DEFAULT+= ${all:tu}
+${all:tu}_USE= GSTREAMER1=${all}
.endfor
-.include <bsd.port.options.mk>
+# Pull out i386-only plugins, add back conditionally
+ALL_PLUGINS:= ${ALL_PLUGINS:Nspc}
+DEF_PLUGINS:= ${DEF_PLUGINS:Nspc}
-# Weed out gst-plugins that can not be packaged. or are broken.
-.if defined(PACKAGE_BUILDING)
-PORT_OPTIONS:= ${PORT_OPTIONS:NFAAC} # Mp4 Dolby license , no package
-PORT_OPTIONS:= ${PORT_OPTIONS:NLAME} # MP3 License , no package
-PORT_OPTIONS:= ${PORT_OPTIONS:NVDPAU} # Needs to be build agains running kernel
-.endif
+OPTIONS_DEFINE= ${ALL_PLUGINS:tu}
+OPTIONS_DEFAULT= ${DEF_PLUGINS:tu}
OPTIONS_DEFINE_i386= SPC
-
-.for f in ${OPTIONS_DEFINE}
-.if ${PORT_OPTIONS:M${f:tu}}
-USE_GSTREAMER1+=${f:tl}
-.endif
-.endfor
+OPTIONS_DEFAULT_i386= SPC
.include <bsd.port.mk>