aboutsummaryrefslogtreecommitdiff
path: root/multimedia/handbrake
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-14 11:58:53 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-14 11:58:53 +0000
commit3296a59e74e161cc6b8a4e952a96dcd4684b1261 (patch)
treec5a7eca202a16968ab8cd4beef8a7b663ef8304f /multimedia/handbrake
parentc17dedd527a9469df04c893b54103f6a5123fd1b (diff)
downloadports-3296a59e74e161cc6b8a4e952a96dcd4684b1261.tar.gz
ports-3296a59e74e161cc6b8a4e952a96dcd4684b1261.zip
Unbreak the build after r324037:
1) `devel/libnotify' no longer pulls gtk20; we must depend explicitly; 2) `x11-toolkits/pango' now depends on `print/harfbuzz', which installs header file ($localbase/include/harfbuzz/hb.h) that in turn confuses bundled libass' configure script and conflicts with HandBrake's own internal header. NB: supposedly it should have been caught by exp-run for r324037, but it was not for some reason. Reported by: Sergey V. Dyatko
Notes
Notes: svn path=/head/; revision=324705
Diffstat (limited to 'multimedia/handbrake')
-rw-r--r--multimedia/handbrake/Makefile14
-rw-r--r--multimedia/handbrake/files/patch-contrib_libass_module.defs8
2 files changed, 15 insertions, 7 deletions
diff --git a/multimedia/handbrake/Makefile b/multimedia/handbrake/Makefile
index e0ff071fc019..d2495c365781 100644
--- a/multimedia/handbrake/Makefile
+++ b/multimedia/handbrake/Makefile
@@ -37,12 +37,12 @@ COMMENT= Versatile DVD ripper and video transcoder
LICENSE= GPLv2
BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm
-LIB_DEPENDS= fribidi:${PORTSDIR}/converters/fribidi
+LIB_DEPENDS= libfribidi.so:${PORTSDIR}/converters/fribidi
RUN_DEPENDS= ${LOCALBASE}/lib/libdvdcss.so:${PORTSDIR}/multimedia/libdvdcss
+USES= gmake
USE_AUTOTOOLS= libtool aclocal
LIBTOOLFILES= configure
-USE_GMAKE= yes
USE_PYTHON_BUILD= yes
WANT_GNOME= yes
@@ -76,9 +76,9 @@ MAKE_ENV= COMPILER_PATH=${LOCALBASE}/bin
.if ${PORT_OPTIONS:MX11}
CONFIGURE_ARGS+= --disable-gtk-update-checks --disable-gst
-LIB_DEPENDS+= dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
- notify:${PORTSDIR}/devel/libnotify
-USE_GNOME= intltool
+LIB_DEPENDS+= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
+ libnotify.so:${PORTSDIR}/devel/libnotify
+USE_GNOME= gtk20
PLIST_FILES+= bin/HandBrake
.else
CONFIGURE_ARGS+= --disable-gtk
@@ -116,6 +116,8 @@ post-extract: .SILENT
${MV} ${WRKDIR}/mp4v2-trunk-r355 ${BUILD_WRKSRC}/contrib/mp4v2
# Remove one patch file that does not apply cleanly
${RM} ${WRKSRC}/contrib/fontconfig/A00-config.patch
+# Avoid conflict with `print/harfbuzz' (also installs "hb.h")
+ ${MV} ${WRKSRC}/libhb/hb.h ${WRKSRC}/libhb/hb-of-handbrake.h
post-patch:
@${REINPLACE_CMD} -e 's|machine/soundcard|sys/soundcard|' \
@@ -128,6 +130,8 @@ post-patch:
${WRKSRC}/libhb/module.defs ${WRKSRC}/test/module.defs
@${REINPLACE_CMD} -e 's|libdvdcss\.so\.2|libdvdcss.so|' \
${BUILD_WRKSRC}/contrib/libdvdread/libdvdread/src/dvd_input.c
+ @${FIND} ${WRKSRC} -type f -name '*.[ch]' -print0 | ${XARGS} -0 \
+ ${REINPLACE_CMD} -e '/#include/s|hb\.h|hb-of-handbrake.h|'
do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/HandBrakeCLI ${PREFIX}/bin
diff --git a/multimedia/handbrake/files/patch-contrib_libass_module.defs b/multimedia/handbrake/files/patch-contrib_libass_module.defs
index 0f270f8062a8..b29f633b495b 100644
--- a/multimedia/handbrake/files/patch-contrib_libass_module.defs
+++ b/multimedia/handbrake/files/patch-contrib_libass_module.defs
@@ -1,10 +1,14 @@
--- ./contrib/libass/module.defs.orig 2010-09-28 18:10:49.000000000 -0400
+++ ./contrib/libass/module.defs 2011-05-24 05:50:46.096807667 -0400
-@@ -10,6 +10,6 @@
+@@ -7,9 +7,9 @@
+ # Disable as many external dependencies as I can get away with
+ # and tell configure where to find our version of freetype
LIBASS.CONFIGURE.extra = \
- --disable-png --disable-enca \
+- --disable-png --disable-enca \
++ --disable-png --disable-enca --disable-harfbuzz \
FREETYPE_LIBS="-L$(call fn.ABSOLUTE,$(CONTRIB.build/))lib -lfreetype" \
- FREETYPE_CFLAGS="-I$(call fn.ABSOLUTE,$(CONTRIB.build/))include/freetype2" \
+ FREETYPE_CFLAGS="-I$(call fn.ABSOLUTE,$(CONTRIB.build/))include/freetype2 -I/usr/local/include" \
FONTCONFIG_LIBS="-L$(call fn.ABSOLUTE,$(CONTRIB.build/))lib -lfontconfig" \
FONTCONFIG_CFLAGS="-I$(call fn.ABSOLUTE,$(CONTRIB.build/))include"
+