aboutsummaryrefslogtreecommitdiff
path: root/multimedia/k9copy-kde4
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-06-04 21:20:31 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-06-04 21:20:31 +0000
commit0438119053db59dd23450d287ecf9986c0a8911a (patch)
tree4bf4ac6dc7fc99504f486cfa6a2d8c116179f0f1 /multimedia/k9copy-kde4
parent263743ae18517c186feb5d1f74e65885eb0749dd (diff)
downloadports-0438119053db59dd23450d287ecf9986c0a8911a.tar.gz
ports-0438119053db59dd23450d287ecf9986c0a8911a.zip
- adoption of optionsNG
Approved by: portmgr (bapt)
Notes
Notes: svn path=/head/; revision=319909
Diffstat (limited to 'multimedia/k9copy-kde4')
-rw-r--r--multimedia/k9copy-kde4/Makefile22
1 files changed, 10 insertions, 12 deletions
diff --git a/multimedia/k9copy-kde4/Makefile b/multimedia/k9copy-kde4/Makefile
index abc30b486fdb..0a8eb4da4ab1 100644
--- a/multimedia/k9copy-kde4/Makefile
+++ b/multimedia/k9copy-kde4/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: k9copy
-# Date created: 19 Dec 2005
-# Whom: Alexander V. Ribchansky <triosoft@triosoft.com.ua>
-#
+# Created by: Alexander V. Ribchansky <triosoft@triosoft.com.ua>
# $FreeBSD$
PORTNAME= k9copy
@@ -12,34 +9,35 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-kde4/${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}-Source
MAINTAINER= egoliveira@gmail.com
-COMMENT= A DVD-9 to DVD-5 shrinking application for KDE
+COMMENT= DVD-9 to DVD-5 shrinking application for KDE
LIB_DEPENDS= xine:${PORTSDIR}/multimedia/libxine \
mpeg2:${PORTSDIR}/multimedia/libmpeg2 \
avcodec:${PORTSDIR}/multimedia/ffmpeg
-USES= cmake
+USES= cmake gettext
USE_KDE4= kdeprefix kdelibs automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
MAKE_JOBS_SAFE= yes
LATEST_LINK= ${PORTNAME}-kde4
-OPTIONS= MENCODER "Install MEncoder (requires MPlayer)" Off \
- MPLAYER "Install MPlayer" Off \
- DVDAUTHOR "Install DVD Author" Off
+OPTIONS_DEFINE= MENCODER MPLAYER DVDAUTHOR
+MENCODER_DESC= MEncoder support
+MPLAYER_DESC= MPlayer support
+DVDAUTHOR_DESC= DVD Author support
.include <bsd.port.options.mk>
-.if defined(WITH_MENCODER)
+.if ${PORT_OPTIONS:MMENCODER}
RUN_DEPENDS+= mencoder:${PORTSDIR}/multimedia/mencoder
.endif
-.if defined(WITH_MPLAYER)
+.if ${PORT_OPTIONS:MMPLAYER}
RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
.endif
-.if defined(WITH_DVDAUTHOR)
+.if ${PORT_OPTIONS:MDVDAUTHOR}
RUN_DEPENDS+= dvdauthor:${PORTSDIR}/multimedia/dvdauthor
.endif