aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libbluray
diff options
context:
space:
mode:
authorDominic Fandrey <kami@FreeBSD.org>2015-02-21 21:08:48 +0000
committerDominic Fandrey <kami@FreeBSD.org>2015-02-21 21:08:48 +0000
commitb9c99def9688952b40e3bf6e4f7db2c78479e745 (patch)
treedaaad1889bef17ddf702d40747089e6e22e9086b /multimedia/libbluray
parentbe2f72d0228ce2efc05d3457311bec143af78887 (diff)
downloadports-b9c99def9688952b40e3bf6e4f7db2c78479e745.tar.gz
ports-b9c99def9688952b40e3bf6e4f7db2c78479e745.zip
Update libbluray 0.5.0 -> 0.7.0
- Add fontconfig dependency - Add libbdplus dependency - Add plist target, because mkplist does not handle options PR: 190958 Differential Revision: https://reviews.freebsd.org/D1754 Reviewed by: Carlo Strub <cs@freebsd.org> Approved by: Carlo Strub <cs@freebsd.org>
Notes
Notes: svn path=/head/; revision=379552
Diffstat (limited to 'multimedia/libbluray')
-rw-r--r--multimedia/libbluray/Makefile52
-rw-r--r--multimedia/libbluray/distinfo4
-rw-r--r--multimedia/libbluray/files/patch-src-Makefile.am7
-rw-r--r--multimedia/libbluray/files/patch-util-refcnt.h11
-rw-r--r--multimedia/libbluray/pkg-plist5
5 files changed, 54 insertions, 25 deletions
diff --git a/multimedia/libbluray/Makefile b/multimedia/libbluray/Makefile
index bd95917da278..0c113f7e6712 100644
--- a/multimedia/libbluray/Makefile
+++ b/multimedia/libbluray/Makefile
@@ -2,29 +2,31 @@
# $FreeBSD$
PORTNAME= libbluray
-PORTVERSION= 0.5.0
-PORTREVISION= 1
+PORTVERSION= 0.7.0
PORTEPOCH= 1
CATEGORIES= multimedia
MASTER_SITES= ftp://ftp.videolan.org/pub/videolan/${PORTNAME}/${PORTVERSION}/ \
http://blu.opsec.eu/
-MAINTAINER= kamikaze@bsdforen.de
+MAINTAINER= kami@freebsd.org
COMMENT= Blu-Ray discs playback library for media players
LICENSE= LGPL21
-LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
-# dlopen dependencies, libbdplus not yet available
-LIB_DEPENDS+= libaacs.so:${PORTSDIR}/multimedia/libaacs
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
+# dlopen dependencies
+LIB_DEPENDS+= libaacs.so:${PORTSDIR}/multimedia/libaacs \
+ libbdplus.so:${PORTSDIR}/multimedia/libbdplus
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-debug
INSTALL_TARGET= install-strip
+USE_AUTOTOOLS= autoconf aclocal automake
USES= iconv libtool pathfix pkgconfig tar:bzip2
USE_LDCONFIG= yes
USE_GNOME= libxml2
+.include "Makefile.include"
+
OPTIONS_DEFINE= JAVA
OPTIONS_SUB= yes
JAVA_DESC= Enable Blu-Ray Java support
@@ -42,7 +44,37 @@ CONFIGURE_ARGS+= --enable-bdjava --with-bdj-type=j2se
CONFIGURE_ENV+= JDK_HOME="${JAVA_HOME}"
.endif
-post-patch:
- @${REINPLACE_CMD} '/^SET_FEATURES =/d' ${WRKSRC}/src/Makefile.in
+#
+# NOTE:
+# makeplist has no support for options, leave this in place
+#
+
+# Create PLIST_SUB definitions for options
+.for _option in ${OPTIONS_DEFINE}
+.if ${PORT_OPTIONS:M${_option}}
+PLIST_SUB+= ${_option}=""
+.else
+PLIST_SUB+= ${_option}="@comment "
+.endif
+.endfor
+
+plist:
+ @${ECHO} "===> Rebuilding PLIST."
+.for _option in "" ${OPTIONS_DEFINE}
+ @${MAKE} clean stage OPTIONS_EXCLUDE="${OPTIONS_DEFINE:N${_option}}" \
+ WITH=${_option}
+ @${MTREE_CMD} -cp "${STAGEDIR}${PREFIX}/" > "${WRKDIR}/mtree.${_option}"
+ @${MTREE_CMD} -Sf "${WRKDIR}/mtree.${_option}" -f "${MTREE_FILE}" \
+ | ${SED} -e '/share\/licenses/d' -e '/ dir /d' -e 's/ .*//' \
+ > "plist.${_option}"
+.endfor
+.for _option in ${OPTIONS_DEFINE}
+ @${GREP} -vFx "$$(${CAT} "plist.")" "plist.${_option}" \
+ | ${SED} 's/^/%%${_option}%%/' > "plist.add.${_option}"
+ @${RM} "plist.${_option}"
+.endfor
+ @${CAT} plist. ${OPTIONS_DEFINE:C/^/plist.add./} \
+ | ${SED} "${PLIST_SUB_SED}" > ${PLIST}
+ @${RM} plist. ${OPTIONS_DEFINE:C/^/plist.add./}
.include <bsd.port.mk>
diff --git a/multimedia/libbluray/distinfo b/multimedia/libbluray/distinfo
index 8eb5a1550463..62b267af1348 100644
--- a/multimedia/libbluray/distinfo
+++ b/multimedia/libbluray/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libbluray-0.5.0.tar.bz2) = 19213e193e1abc5ed2de65edfb539deda1dbf6cc64dfef03e405524c9c6f7216
-SIZE (libbluray-0.5.0.tar.bz2) = 559639
+SHA256 (libbluray-0.7.0.tar.bz2) = f79beb9fbb24117cbb1264c919e686ae9e6349c0ad08b48c4b6233b2887eb68d
+SIZE (libbluray-0.7.0.tar.bz2) = 597266
diff --git a/multimedia/libbluray/files/patch-src-Makefile.am b/multimedia/libbluray/files/patch-src-Makefile.am
new file mode 100644
index 000000000000..bfb1eaa4aac0
--- /dev/null
+++ b/multimedia/libbluray/files/patch-src-Makefile.am
@@ -0,0 +1,7 @@
+--- src/Makefile.am.orig 2015-01-26 10:44:55.000000000 +0100
++++ src/Makefile.am 2015-01-29 13:10:02.000000000 +0100
+@@ -1,4 +1,3 @@
+-SET_FEATURES = -D_ISOC99_SOURCE -D_POSIX_C_SOURCE=200112L -D_REENTRANT
+ SET_INCLUDES = -I$(top_srcdir) -Ifile -Ilibbluray -Ilibbluray/bdnav $(BDJAVA_CFLAGS)
+
+ AM_CFLAGS = -std=c99 $(SET_FEATURES) $(SET_INCLUDES) $(LIBXML2_CFLAGS) $(FT2_CFLAGS) $(FONTCONFIG_CFLAGS)
diff --git a/multimedia/libbluray/files/patch-util-refcnt.h b/multimedia/libbluray/files/patch-util-refcnt.h
deleted file mode 100644
index a99e7295ec6d..000000000000
--- a/multimedia/libbluray/files/patch-util-refcnt.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/util/refcnt.h.orig 2014-04-13 17:52:33.000000000 +0200
-+++ src/util/refcnt.h 2014-04-13 17:52:43.000000000 +0200
-@@ -18,7 +18,7 @@
- */
-
- #ifndef BD_REFCNT_H_
--#define BD_FEFCNT_H_
-+#define BD_REFCNT_H_
-
- #include "attributes.h"
-
diff --git a/multimedia/libbluray/pkg-plist b/multimedia/libbluray/pkg-plist
index 52a29177b9e2..fc3d162bca24 100644
--- a/multimedia/libbluray/pkg-plist
+++ b/multimedia/libbluray/pkg-plist
@@ -7,9 +7,10 @@ include/libbluray/keys.h
include/libbluray/log_control.h
include/libbluray/meta_data.h
include/libbluray/overlay.h
+include/libbluray/player_settings.h
lib/libbluray.a
lib/libbluray.so
lib/libbluray.so.1
-lib/libbluray.so.1.5.0
+lib/libbluray.so.1.7.0
libdata/pkgconfig/libbluray.pc
-%%JAVA%%lib/libbluray/libbluray.jar
+%%JAVA%%%%JAVASHAREDIR%%/libbluray-j2se-0.7.0.jar