aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libhdhomerun
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2016-01-20 03:04:34 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2016-01-20 03:04:34 +0000
commit6418c819fc0e20f2220301dca66a720282cc2f58 (patch)
tree9edee02c8e5caab8d4169ac8102e24b4ee609330 /multimedia/libhdhomerun
parent7d7a48919662ce3090bc633ecb45c70041e6a191 (diff)
downloadports-6418c819fc0e20f2220301dca66a720282cc2f58.tar.gz
ports-6418c819fc0e20f2220301dca66a720282cc2f58.zip
Add libhdhomerun 20150826, library and command line utility for
interfacing with HDHomeRun device. PR: 206409 Submitted by: sam@middling.me.uk
Notes
Notes: svn path=/head/; revision=406728
Diffstat (limited to 'multimedia/libhdhomerun')
-rw-r--r--multimedia/libhdhomerun/Makefile25
-rw-r--r--multimedia/libhdhomerun/distinfo2
-rw-r--r--multimedia/libhdhomerun/files/patch-Makefile11
-rw-r--r--multimedia/libhdhomerun/pkg-descr12
-rw-r--r--multimedia/libhdhomerun/pkg-plist17
5 files changed, 67 insertions, 0 deletions
diff --git a/multimedia/libhdhomerun/Makefile b/multimedia/libhdhomerun/Makefile
new file mode 100644
index 000000000000..c5139909c1a6
--- /dev/null
+++ b/multimedia/libhdhomerun/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= libhdhomerun
+PORTVERSION= 20150826
+CATEGORIES= multimedia
+MASTER_SITES= http://download.silicondust.com/hdhomerun/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= sam@middling.me.uk
+COMMENT= Library and command line utility for interfacing with HDHomeRun device
+
+LICENSE= LGPL21
+
+USES= gmake tar:tgz
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/libhdhomerun
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/include/libhdhomerun
+ ${INSTALL_PROGRAM} ${WRKSRC}/hdhomerun_config ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_LIB} ${WRKSRC}/libhdhomerun.so ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/*.h ${STAGEDIR}${PREFIX}/include/libhdhomerun
+
+.include <bsd.port.mk>
diff --git a/multimedia/libhdhomerun/distinfo b/multimedia/libhdhomerun/distinfo
new file mode 100644
index 000000000000..556f9286c497
--- /dev/null
+++ b/multimedia/libhdhomerun/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libhdhomerun_20150826.tgz) = 907dfbd1eb82aebd8b09e7c00c21a02433e6baaacf4a4f99aa2511b1d5244baf
+SIZE (libhdhomerun_20150826.tgz) = 49169
diff --git a/multimedia/libhdhomerun/files/patch-Makefile b/multimedia/libhdhomerun/files/patch-Makefile
new file mode 100644
index 000000000000..b54a0641d18a
--- /dev/null
+++ b/multimedia/libhdhomerun/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2016-01-20 02:55:42 UTC
++++ Makefile
+@@ -11,7 +11,7 @@ LIBSRCS += hdhomerun_pkt.c
+ LIBSRCS += hdhomerun_sock_posix.c
+ LIBSRCS += hdhomerun_video.c
+
+-CC := $(CROSS_COMPILE)gcc
++#CC := $(CROSS_COMPILE)gcc
+ STRIP := $(CROSS_COMPILE)strip
+
+ CFLAGS += -Wall -O2 -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wpointer-arith
diff --git a/multimedia/libhdhomerun/pkg-descr b/multimedia/libhdhomerun/pkg-descr
new file mode 100644
index 000000000000..aafa96bc50c5
--- /dev/null
+++ b/multimedia/libhdhomerun/pkg-descr
@@ -0,0 +1,12 @@
+This package supports the Silicon Dust HDHomeRun,
+a networked digital TV tuner compatible with VLC and Tvheadend.
+
+This utility can be used for:
+
+ * Discovering your tuner location and name
+ * Gathering tuner settings
+ * Modifying tuner settings
+ * Performing scans
+ * Performing firmware upgrades
+
+WWW: http://www.silicondust.com/support/downloads/linux/
diff --git a/multimedia/libhdhomerun/pkg-plist b/multimedia/libhdhomerun/pkg-plist
new file mode 100644
index 000000000000..cdbfbc8b27b9
--- /dev/null
+++ b/multimedia/libhdhomerun/pkg-plist
@@ -0,0 +1,17 @@
+bin/hdhomerun_config
+include/libhdhomerun/hdhomerun.h
+include/libhdhomerun/hdhomerun_channels.h
+include/libhdhomerun/hdhomerun_channelscan.h
+include/libhdhomerun/hdhomerun_control.h
+include/libhdhomerun/hdhomerun_debug.h
+include/libhdhomerun/hdhomerun_device.h
+include/libhdhomerun/hdhomerun_device_selector.h
+include/libhdhomerun/hdhomerun_discover.h
+include/libhdhomerun/hdhomerun_os.h
+include/libhdhomerun/hdhomerun_os_posix.h
+include/libhdhomerun/hdhomerun_os_windows.h
+include/libhdhomerun/hdhomerun_pkt.h
+include/libhdhomerun/hdhomerun_sock.h
+include/libhdhomerun/hdhomerun_types.h
+include/libhdhomerun/hdhomerun_video.h
+lib/libhdhomerun.so