aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libopenshot
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-14 16:22:48 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-14 17:03:07 +0000
commit8ab79171c59b509d0c9adab31144c02a0d5f2041 (patch)
treee5602ae0c19cd4b53b66539cca01357c2bb78add /multimedia/libopenshot
parent19998317be411820e5d183725a39bead3480de7f (diff)
downloadports-8ab79171c59b509d0c9adab31144c02a0d5f2041.tar.gz
ports-8ab79171c59b509d0c9adab31144c02a0d5f2041.zip
multimedia/libopenshot: Fix build with protobuf 22+
Diffstat (limited to 'multimedia/libopenshot')
-rw-r--r--multimedia/libopenshot/Makefile5
-rw-r--r--multimedia/libopenshot/files/patch-CMakeLists.txt11
2 files changed, 13 insertions, 3 deletions
diff --git a/multimedia/libopenshot/Makefile b/multimedia/libopenshot/Makefile
index 2423d6f4645e..0ca8b1edf710 100644
--- a/multimedia/libopenshot/Makefile
+++ b/multimedia/libopenshot/Makefile
@@ -33,6 +33,7 @@ CMAKE_ON= USE_SYSTEM_JSONCPP DISABLE_BUNDLED_JSONCPP\
CMAKE_DISABLE_FIND_PACKAGE_Catch2
CMAKE_OFF= ENABLE_PARALLEL_CTEST VERBOSE_TESTS ENABLE_COVERAGE\
APPIMAGE_BUILD BUILD_TESTING ENABLE_TESTS
+USE_CXXSTD= c++17
OPTIONS_DEFINE= DOCS IMAGEMAGICK OPENCV RESVG RUBY
OPTIONS_DEFAULT= IMAGEMAGICK OPENCV
@@ -61,9 +62,9 @@ RUBY_CMAKE_BOOL= ENABLE_RUBY
RUBY_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Ruby
.if !exists(/usr/include/omp.h)
-USES+= compiler:gcc-c++11-lib
+USES+= compiler:gcc-c++17-lib
.else
-USES+= compiler:c++14-lang
+USES+= compiler:c++17-lang
.endif
.include <bsd.port.mk>
diff --git a/multimedia/libopenshot/files/patch-CMakeLists.txt b/multimedia/libopenshot/files/patch-CMakeLists.txt
index fbb39ea66cf8..89ecc6dc4437 100644
--- a/multimedia/libopenshot/files/patch-CMakeLists.txt
+++ b/multimedia/libopenshot/files/patch-CMakeLists.txt
@@ -1,5 +1,14 @@
---- CMakeLists.txt.orig 2022-12-01 22:04:03 UTC
+--- CMakeLists.txt.orig 2023-04-19 22:01:02 UTC
+++ CMakeLists.txt
+@@ -102,7 +102,7 @@ if ((${CMAKE_CXX_COMPILER_ID} STREQUAL "GNU") AND
+ endif()
+
+ #### Set C++ standard level
+-set(CMAKE_CXX_STANDARD 14)
++set(CMAKE_CXX_STANDARD 17)
+ set(CMAKE_CXX_STANDARD_REQUIRED ON)
+ set(CMAKE_CXX_EXTENSIONS OFF)
+
@@ -135,7 +135,7 @@ endif()
### Process subdirectories
###