aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libquvi/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-21 23:12:23 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-21 23:12:23 +0000
commit122c8fb6b6d3b611a73a06c0ae4eb64a3fbfaf36 (patch)
treea127d84db10b1ad2fa64818ace8726c6a0d12211 /multimedia/libquvi/Makefile
parent6b38babedce07b66fc0e58a943c086e8bca46d33 (diff)
downloadports-122c8fb6b6d3b611a73a06c0ae4eb64a3fbfaf36.tar.gz
ports-122c8fb6b6d3b611a73a06c0ae4eb64a3fbfaf36.zip
- Convert to new LIB_DEPENDS format
- Sort USES - Move PORTSCOUT upward - Support STAGEDIR
Notes
Notes: svn path=/head/; revision=334535
Diffstat (limited to 'multimedia/libquvi/Makefile')
-rw-r--r--multimedia/libquvi/Makefile19
1 files changed, 6 insertions, 13 deletions
diff --git a/multimedia/libquvi/Makefile b/multimedia/libquvi/Makefile
index 7cf9a6e1e0cb..f4a7f19c7ea8 100644
--- a/multimedia/libquvi/Makefile
+++ b/multimedia/libquvi/Makefile
@@ -15,31 +15,24 @@ LICENSE= LGPL21 LGPL3
LICENSE_COMB= dual
BUILD_DEPENDS= libquvi-scripts>=0.4.0:${PORTSDIR}/multimedia/libquvi-scripts
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
RUN_DEPENDS:= ${BUILD_DEPENDS}
OPTIONS_DEFINE= DOCS
+PORTSCOUT= limit:0.4.[0-9]*
+
CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_LUA= yes
USE_XZ= yes
-USES= pathfix pkgconfig iconv
-
-MAN3= libquvi.3
+USES= iconv pathfix pkgconfig
PROJECTHOST= quvi
-PORTSCOUT= limit:0.4.[0-9]*
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}/
- cd ${WRKSRC}/doc/nd/ && ${COPYTREE_SHARE} . ${DOCSDIR}/
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/
+ cd ${WRKSRC}/doc/nd/ && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}/
.include <bsd.port.mk>