aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libxine
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2013-07-21 11:27:17 +0000
committerJuergen Lock <nox@FreeBSD.org>2013-07-21 11:27:17 +0000
commitdf7db5cedb7147603f1ec157e208128bfe38f327 (patch)
tree266668f8f6f99dc14a22d1e49282582e2fcbba83 /multimedia/libxine
parent0692f40e985d0bb75ed36b9686659a0c410e1998 (diff)
downloadports-df7db5cedb7147603f1ec157e208128bfe38f327.tar.gz
ports-df7db5cedb7147603f1ec157e208128bfe38f327.zip
Set USE_GCC= any on i386 as clang there doesn't like
src/post/deinterlace/plugins/greedy2frame_template_sse2.c . Submitted by: pointyhat via miwi
Notes
Notes: svn path=/head/; revision=323375
Diffstat (limited to 'multimedia/libxine')
-rw-r--r--multimedia/libxine/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index 9dcc304086b5..8896a721fb0e 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -83,6 +83,20 @@ PATCH_DIST_ARGS= -d ${WRKSRC} -p1 --forward --quiet
.include <bsd.port.options.mk>
+# clang/i386 doesn't like
+# src/post/deinterlace/plugins/greedy2frame_template_sse2.c :
+# [...]
+# ./greedy2frame_template_sse2.c:175:38: error: register %rax is only available in 64-bit mode
+# "movdqa (%3), %%xmm0 \n\t" /* xmm0 = T0 */
+# ^
+#<inline asm>:3:11: note: instantiated into assembly here
+# movdqa (%rax,%esi), %xmm3
+# ^~~~
+# [...]
+.if ${ARCH} == "i386"
+USE_GCC= any
+.endif
+
# Fix build WITH_DEBUG
.if defined(WITH_DEBUG)
DEBUG_FLAGS= -g -O1