aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mjpegtools
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-26 00:44:22 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-26 00:48:20 +0000
commit95274bf4f99c71fc056013d966aec239161dfd74 (patch)
treebc1e95977678cb5b6b00b33e333b28161885e706 /multimedia/mjpegtools
parentdbe06d2da8c38d9d058f7939a7c6af36a2c0f1c7 (diff)
downloadports-95274bf4f99c71fc056013d966aec239161dfd74.tar.gz
ports-95274bf4f99c71fc056013d966aec239161dfd74.zip
*/*: Fix build with llvm16 on 13.2-STABLE
As like as HEAD(14.0-RELEASE) llvm16 was merged in base for 13.2-STABLE with the OSVERSION 1302507. - Utilize USE_CXXSTD=c++14 or similar solution where applicable - Update conditionals to addtionally check for OSVERSION greater than 1302507 and less than 1400000 Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'multimedia/mjpegtools')
-rw-r--r--multimedia/mjpegtools/Makefile11
1 files changed, 1 insertions, 10 deletions
diff --git a/multimedia/mjpegtools/Makefile b/multimedia/mjpegtools/Makefile
index f90dba836a4f..ad5165c9a301 100644
--- a/multimedia/mjpegtools/Makefile
+++ b/multimedia/mjpegtools/Makefile
@@ -17,6 +17,7 @@ CONFLICTS= mplex
USES= compiler:c++11-lang gmake gnome jpeg libtool localbase pathfix \
pkgconfig
+USE_CXXSTD= c++14
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -39,20 +40,10 @@ SDL_USES= sdl
SDL_USE= SDL=gfx,sdl
SDL_CONFIGURE_OFF= --without-libsdl --without-sdlgfx
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
-CPPFLAGS+= -Dregister=
-.endif
-
post-patch:
@${REINPLACE_CMD} \
-e 's| \*-\*-linux\*)| *-*-*)|' \
-e '/ARCHFLAGS=/d' ${WRKSRC}/configure
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
- @${REINPLACE_CMD} -e 's|auto_ptr|unique_ptr|' \
- ${WRKSRC}/mplex/main.cpp
-.endif
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}