aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mkvalidator
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-09-28 15:39:16 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-09-28 15:39:16 +0000
commit47b84b95f49660abe66b70fcab71b4b02b01be0a (patch)
treee3c4f5ebac6ad5124c9bb10ece410a9c63a984e2 /multimedia/mkvalidator
parent0749bf7e2e0f1242b042934a5e1e8ee95dedc827 (diff)
downloadports-47b84b95f49660abe66b70fcab71b4b02b01be0a.tar.gz
ports-47b84b95f49660abe66b70fcab71b4b02b01be0a.zip
mkvalidator is a simple command line tool to verify Matroska and WebM files for
spec conformance. It checks the various bogus or missing key elements against the EBML DocType version of the file and reports the errors/warnings in the command line. http://www.matroska.org/downloads/mkvalidator.html
Notes
Notes: svn path=/head/; revision=282567
Diffstat (limited to 'multimedia/mkvalidator')
-rw-r--r--multimedia/mkvalidator/Makefile37
-rw-r--r--multimedia/mkvalidator/distinfo2
-rw-r--r--multimedia/mkvalidator/files/patch-corec__corec__helpers__file__file_libc.c11
-rw-r--r--multimedia/mkvalidator/files/patch-corec__corec__portab.h12
-rw-r--r--multimedia/mkvalidator/pkg-descr6
5 files changed, 68 insertions, 0 deletions
diff --git a/multimedia/mkvalidator/Makefile b/multimedia/mkvalidator/Makefile
new file mode 100644
index 000000000000..212ec16ca696
--- /dev/null
+++ b/multimedia/mkvalidator/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: mkvalidator
+# Date created: 2011-09-28
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mkvalidator
+PORTVERSION= 0.3.7
+CATEGORIES= multimedia
+MASTER_SITES= SF/matroska/${PORTNAME}/
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Command line tool to verify Matroska and WebM files
+
+LICENSE= BSD
+
+USE_BZIP2= yes
+HAS_CONFIGURE= yes
+
+USE_GMAKE= yes
+USE_ICONV= yes
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -liconv
+
+MAKE_ENV+= "LFLAGS=${LDFLAGS}"
+MAKEFILE= GNUmakefile
+BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+
+PLIST_FILES= bin/mkvalidator
+
+post-extract:
+ @${REINPLACE_CMD} -e "s,/usr/local,${PREFIX},g" ${WRKSRC}/corec/tools/coremake/gcc_mak.inc
+ @${RM} ${WRKSRC}/libmatroska2/test/test.proj
+
+.include <bsd.port.mk>
diff --git a/multimedia/mkvalidator/distinfo b/multimedia/mkvalidator/distinfo
new file mode 100644
index 000000000000..cf15556ba6e5
--- /dev/null
+++ b/multimedia/mkvalidator/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mkvalidator-0.3.7.tar.bz2) = 236247098052022757243a3c7ae5939b4ca34e07c573e3344346c4ca66c66ba1
+SIZE (mkvalidator-0.3.7.tar.bz2) = 579174
diff --git a/multimedia/mkvalidator/files/patch-corec__corec__helpers__file__file_libc.c b/multimedia/mkvalidator/files/patch-corec__corec__helpers__file__file_libc.c
new file mode 100644
index 000000000000..b726b7608e2b
--- /dev/null
+++ b/multimedia/mkvalidator/files/patch-corec__corec__helpers__file__file_libc.c
@@ -0,0 +1,11 @@
+--- ./corec/corec/helpers/file/file_libc.c.orig 2011-09-25 11:25:46.000000000 +0200
++++ ./corec/corec/helpers/file/file_libc.c 2011-09-28 16:25:02.262950715 +0200
+@@ -40,7 +40,7 @@
+ #include <unistd.h>
+ #include <dirent.h>
+ #include <errno.h>
+-#if defined(TARGET_OSX)
++#if defined(TARGET_OSX) || defined(TARGET_FREEBSD)
+ #include <sys/mount.h>
+ #else
+ #include <sys/vfs.h>
diff --git a/multimedia/mkvalidator/files/patch-corec__corec__portab.h b/multimedia/mkvalidator/files/patch-corec__corec__portab.h
new file mode 100644
index 000000000000..8a1147a35f23
--- /dev/null
+++ b/multimedia/mkvalidator/files/patch-corec__corec__portab.h
@@ -0,0 +1,12 @@
+--- ./corec/corec/portab.h.orig 2011-09-25 11:25:46.000000000 +0200
++++ ./corec/corec/portab.h 2011-09-28 16:25:47.730826509 +0200
+@@ -159,6 +159,9 @@
+
+ #elif defined(__linux__) || defined(__CYGWIN__) || defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__)
+
++#if defined(__FreeBSD__)
++#define TARGET_FREEBSD
++#endif
+ #define TARGET_LINUX
+
+ #ifndef TARGET_QTOPIA // qtopia defines desktop manually
diff --git a/multimedia/mkvalidator/pkg-descr b/multimedia/mkvalidator/pkg-descr
new file mode 100644
index 000000000000..80849f602571
--- /dev/null
+++ b/multimedia/mkvalidator/pkg-descr
@@ -0,0 +1,6 @@
+mkvalidator is a simple command line tool to verify Matroska and WebM files for
+spec conformance. It checks the various bogus or missing key elements against
+the EBML DocType version of the file and reports the errors/warnings in the
+command line.
+
+WWW: http://www.matroska.org/downloads/mkvalidator.html