aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mlt
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2012-10-05 04:12:04 +0000
committerAlberto Villa <avilla@FreeBSD.org>2012-10-05 04:12:04 +0000
commit41aaef0cd2dd2ad3a0044e6f6c50baddbfb553ad (patch)
tree5aa63645c34d2690be3756476e61fbe76a9ce968 /multimedia/mlt
parentf83603143712d18c1efd050b02c3aad8bdc232d0 (diff)
downloadports-41aaef0cd2dd2ad3a0044e6f6c50baddbfb553ad.tar.gz
ports-41aaef0cd2dd2ad3a0044e6f6c50baddbfb553ad.zip
- Backport my commits to support depending on non-default FFmpeg.
- Switch dependency from multimedia/ffmpeg to multimedia/ffmpeg-011, as my tests revealed that MLT isn't working anymore with 0.7.x. - Drop option --linsys-with-jpeg as per upstream suggestion. - Update OPTIONS descriptions to be consistent with recent changes. - Bump PORTREVISION.
Notes
Notes: svn path=/head/; revision=305293
Diffstat (limited to 'multimedia/mlt')
-rw-r--r--multimedia/mlt/Makefile18
-rw-r--r--multimedia/mlt/files/patch-src__modules__avformat__configure56
-rw-r--r--multimedia/mlt/files/patch-src__modules__frei0r__configure6
-rw-r--r--multimedia/mlt/files/patch-src__modules__linsys__Makefile11
4 files changed, 63 insertions, 28 deletions
diff --git a/multimedia/mlt/Makefile b/multimedia/mlt/Makefile
index 87f2796c3ad6..56669fdd927c 100644
--- a/multimedia/mlt/Makefile
+++ b/multimedia/mlt/Makefile
@@ -2,6 +2,7 @@
PORTNAME= mlt
PORTVERSION= 0.8.2
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
@@ -11,8 +12,6 @@ COMMENT= Multimedia framework for TV broadcasting
LICENSE= GPLv2 GPLv3 LGPL21
LICENSE_COMB= multi
-LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
-
# They both install bin/melt.
CONFLICTS_INSTALL= freeze-[0-9]*
@@ -20,9 +19,8 @@ USE_GNOME= gnomehack libxml2
USE_PKGCONFIG= build
USE_SDL= image
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-gpl --enable-gpl3 --linsys-with-jpeg
+CONFIGURE_ARGS= --enable-gpl --enable-gpl3
USE_GMAKE= yes
-CFLAGS+= -I${LOCALBASE}/include # Frei0r detection.
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
@@ -44,9 +42,9 @@ OPTIONS_DEFINE= DV FFMPEG FREI0R GTK2 JACK QT4 QUICKTIME \
OPTIONS_DEFAULT=DV FFMPEG FREI0R GTK2 QT4 \
SAMPLERATE SOX SWFDEC VORBIS
-GTK2_DESC= GTK+ 2 support (images, text rendering...)
-QT4_DESC= QImage support (Kdenlive titles, images...)
-SOX_DESC= SoX audio effects support
+GTK2_DESC= Images, text rendering, etc. via GTK+ 2
+QT4_DESC= Kdenlive titles, images, etc. via QImage
+SOX_DESC= SoX audio effects
.include <bsd.port.options.mk>
@@ -64,8 +62,10 @@ PLIST_SUB+= DV="@comment "
.endif
.if ${PORT_OPTIONS:MFFMPEG} || ${PORT_OPTIONS:MVDPAU}
-LIB_DEPENDS+= avformat:${PORTSDIR}/multimedia/ffmpeg
-CONFIGURE_ARGS+= --enable-avformat --avformat-swscale
+FFMPEG_SUFFIX= -011
+LIB_DEPENDS+= avformat${FFMPEG_SUFFIX}:${PORTSDIR}/multimedia/ffmpeg${FFMPEG_SUFFIX}
+CONFIGURE_ARGS+= --enable-avformat --avformat-swscale \
+ --avformat-suffix="${FFMPEG_SUFFIX}"
PLIST_SUB+= FFMPEG=""
.else
CONFIGURE_ARGS+= --disable-avformat
diff --git a/multimedia/mlt/files/patch-src__modules__avformat__configure b/multimedia/mlt/files/patch-src__modules__avformat__configure
index cf6742262a9b..07457313d229 100644
--- a/multimedia/mlt/files/patch-src__modules__avformat__configure
+++ b/multimedia/mlt/files/patch-src__modules__avformat__configure
@@ -1,6 +1,24 @@
---- ./src/modules/avformat/configure.orig 2012-09-04 00:55:19.926196170 +0200
-+++ ./src/modules/avformat/configure 2012-09-04 00:43:04.696053595 +0200
-@@ -105,7 +105,7 @@
+--- ./src/modules/avformat/configure.orig 2012-10-02 05:23:05.066523985 +0200
++++ ./src/modules/avformat/configure 2012-10-02 05:27:15.848135787 +0200
+@@ -54,7 +54,7 @@
+ echo > config.mak
+
+ export static_ffmpeg=
+- export shared_ffmpeg=$(pkg-config --variable=prefix libavformat)
++ export shared_ffmpeg=
+ export extra_libs=
+ export avformat_suffix=
+ export swscale=
+@@ -82,6 +82,8 @@
+ esac
+ done
+
++ : ${shared_ffmpeg:=$(pkg-config --variable=prefix libavformat${avformat_suffix})}
++
+ if [ "$static_ffmpeg" != "" ]
+ then
+ if [ -d "$static_ffmpeg" ]
+@@ -105,7 +107,7 @@
if [ "$vdpau" = "true" ]
then
@@ -9,12 +27,40 @@
[ "$x11" = "0" -a "$?" = "0" ] && echo "VDPAU=1" >> config.mak
fi
else
-@@ -141,7 +141,7 @@
+@@ -121,27 +123,27 @@
+ echo "CFLAGS+=-DAVDATADIR=\\\"share/ffmpeg/\\\"" >> config.mak
+ ;;
+ *)
+- echo "CFLAGS+=-DAVDATADIR=\\\"${shared_ffmpeg}/share/ffmpeg/\\\"" >> config.mak
++ echo "CFLAGS+=-DAVDATADIR=\\\"${shared_ffmpeg}/share/ffmpeg${avformat_suffix}/\\\"" >> config.mak
+ ;;
+ esac
+- echo "CFLAGS+=$(pkg-config --cflags libavformat)" >> config.mak
+- echo "LDFLAGS+=$(pkg-config --libs-only-L libavformat)" >> config.mak
++ echo "CFLAGS+=$(pkg-config --cflags libavformat${avformat_suffix})" >> config.mak
++ echo "LDFLAGS+=$(pkg-config --libs-only-L libavformat${avformat_suffix})" >> config.mak
+ if [ "$devices" = "true" ]
+ then
+- echo "CFLAGS+=$(pkg-config --cflags libavdevice)" >> config.mak
+- echo "LDFLAGS+=$(pkg-config --libs-only-L libavdevice)" >> config.mak
++ echo "CFLAGS+=$(pkg-config --cflags libavdevice${avformat_suffix})" >> config.mak
++ echo "LDFLAGS+=$(pkg-config --libs-only-L libavdevice${avformat_suffix})" >> config.mak
+ fi
+- avcodec_version=$(pkg-config --modversion libavcodec)
++ avcodec_version=$(pkg-config --modversion libavcodec${avformat_suffix})
+ if [ "$swscale" != "" ] || [ $(echo $avcodec_version | cut -d. -f1) -gt 52 ] || ( [ $(echo $avcodec_version | cut -d. -f1) -ge 52 ] && [ $(echo $avcodec_version | cut -d. -f2) -ge 21 ] )
+ then
+- echo "CFLAGS+=$(pkg-config --cflags libswscale)" >> config.mak
+- echo "LDFLAGS+=$(pkg-config --libs-only-L libswscale)" >> config.mak
++ echo "CFLAGS+=$(pkg-config --cflags libswscale${avformat_suffix})" >> config.mak
++ echo "LDFLAGS+=$(pkg-config --libs-only-L libswscale${avformat_suffix})" >> config.mak
+ echo "SWSCALE=1" >> config.mak
+ fi
if [ "$vdpau" = "true" ]
then
- printf "#include <libavcodec/vdpau.h>\n int main(){ VdpBitstreamBuffer test; test.struct_version; return 0;}" | gcc -I"$(pkg-config --cflags libavformat)" -I"$shared_ffmpeg/include" $CFLAGS -c -x c - >/dev/null 2>&1
-+ printf "#include <libavcodec/vdpau.h>\n int main(){ VdpBitstreamBuffer test; test.struct_version; return 0;}" | $CC -I"$(pkg-config --cflags libavformat)" -I"$shared_ffmpeg/include" $CFLAGS -c -x c - >/dev/null 2>&1
++ printf "#include <libavcodec/vdpau.h>\n int main(){ VdpBitstreamBuffer test; test.struct_version; return 0;}" | $CC $(pkg-config --cflags libavformat${avformat_suffix}) -I"$shared_ffmpeg/include" $CFLAGS -c -x c - >/dev/null 2>&1
[ "$x11" = "0" -a "$?" = "0" ] && echo "VDPAU=1" >> config.mak
fi
else
diff --git a/multimedia/mlt/files/patch-src__modules__frei0r__configure b/multimedia/mlt/files/patch-src__modules__frei0r__configure
index 720f82dea44d..ccd5af457856 100644
--- a/multimedia/mlt/files/patch-src__modules__frei0r__configure
+++ b/multimedia/mlt/files/patch-src__modules__frei0r__configure
@@ -1,11 +1,11 @@
---- ./src/modules/frei0r/configure.orig 2012-09-04 00:21:50.609711766 +0200
-+++ ./src/modules/frei0r/configure 2012-09-04 00:47:23.666167132 +0200
+--- ./src/modules/frei0r/configure.orig 2012-10-02 05:23:05.066523985 +0200
++++ ./src/modules/frei0r/configure 2012-10-02 05:25:52.436629939 +0200
@@ -3,7 +3,7 @@
if [ "$help" != "1" ]
then
- echo "#include <frei0r.h> int main(){ f0r_plugin_info_t test; test.name;return 0;}"| gcc $CFLAGS -c -x c - >/dev/null 2>&1
-+ echo "#include <frei0r.h> int main(){ f0r_plugin_info_t test; test.name;return 0;}"| $CC $CFLAGS -c -x c - >/dev/null 2>&1
++ echo "#include <frei0r.h> int main(){ f0r_plugin_info_t test; test.name;return 0;}"| $CC $(pkg-config --cflags frei0r) $CFLAGS -c -x c - >/dev/null 2>&1
if [ "$?" = "1" ]
then
diff --git a/multimedia/mlt/files/patch-src__modules__linsys__Makefile b/multimedia/mlt/files/patch-src__modules__linsys__Makefile
deleted file mode 100644
index f7d3da97a359..000000000000
--- a/multimedia/mlt/files/patch-src__modules__linsys__Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/modules/linsys/Makefile.orig 2011-11-02 17:34:58.740000641 +0100
-+++ ./src/modules/linsys/Makefile 2011-11-02 17:35:07.133393857 +0100
-@@ -12,7 +12,7 @@
-
- ifdef WITH_JPEG
- CFLAGS += -DWITH_JPEG
--LDFLAGS += -ljpeg
-+LDFLAGS += -ljpeg -L/usr/local/lib
- endif
-
- SRCS := $(OBJS:.o=.c)