aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mplayer2
diff options
context:
space:
mode:
authorGrzegorz Blach <gblach@FreeBSD.org>2012-12-31 17:32:16 +0000
committerGrzegorz Blach <gblach@FreeBSD.org>2012-12-31 17:32:16 +0000
commit0f7ffd5814a8e311fb5f4dc2e4eac6c5a6990e6e (patch)
treea53ac7f81ff43a3769fa85be23e1fa6180cf56d8 /multimedia/mplayer2
parent1c1456fc4adb85c12c0f0aa78c9368e3cba61f45 (diff)
downloadports-0f7ffd5814a8e311fb5f4dc2e4eac6c5a6990e6e.tar.gz
ports-0f7ffd5814a8e311fb5f4dc2e4eac6c5a6990e6e.zip
- Fix linking with giflib
- Fix linking with libbluray PR: ports/174842 Approved by: crees (mentor)
Notes
Notes: svn path=/head/; revision=309768
Diffstat (limited to 'multimedia/mplayer2')
-rw-r--r--multimedia/mplayer2/Makefile1
-rw-r--r--multimedia/mplayer2/files/patch-libmpdemux-demux_gif.c19
2 files changed, 19 insertions, 1 deletions
diff --git a/multimedia/mplayer2/Makefile b/multimedia/mplayer2/Makefile
index 1c85c7b41698..87062ccfce5f 100644
--- a/multimedia/mplayer2/Makefile
+++ b/multimedia/mplayer2/Makefile
@@ -166,7 +166,6 @@ CONFIGURE_ARGS+= --disable-portaudio
.if ${PORT_OPTIONS:MLIBBLURAY}
LIB_DEPENDS+= bluray:${PORTSDIR}/multimedia/libbluray
-CONFIGURE_ARGS+= --enable-bluray
.else
CONFIGURE_ARGS+= --disable-bluray
.endif
diff --git a/multimedia/mplayer2/files/patch-libmpdemux-demux_gif.c b/multimedia/mplayer2/files/patch-libmpdemux-demux_gif.c
new file mode 100644
index 000000000000..49944180d6c6
--- /dev/null
+++ b/multimedia/mplayer2/files/patch-libmpdemux-demux_gif.c
@@ -0,0 +1,19 @@
+--- libmpdemux/demux_gif.c.orig 2012-12-31 00:26:50.000000000 +0100
++++ libmpdemux/demux_gif.c 2012-12-31 00:30:54.000000000 +0100
+@@ -44,6 +44,16 @@
+
+ #define GIF_SIGNATURE (('G' << 16) | ('I' << 8) | 'F')
+
++static void PrintGifError(void)
++{
++ char *Err = GifErrorString();
++
++ if (Err != NULL)
++ fprintf(stderr, "\nGIF-LIB error: %s.\n", Err);
++ else
++ fprintf(stderr, "\nGIF-LIB undefined error %d.\n", GifError());
++}
++
+ #ifndef CONFIG_GIF_TVT_HACK
+ // not supported by certain versions of the library
+ static int my_read_gif(GifFileType *gif, uint8_t *buf, int len)