aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mplayer
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /multimedia/mplayer
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'multimedia/mplayer')
-rw-r--r--multimedia/mplayer/Makefile6
-rw-r--r--multimedia/mplayer/Makefile.options4
2 files changed, 5 insertions, 5 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 665137d74bba..2acb914a056f 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mplayer
PORTVERSION= ${MPLAYER_PORT_VERSION}
-PORTREVISION= 3
+PORTREVISION= 4
COMMENT= High performance media player supporting many formats
@@ -118,7 +118,7 @@ CONFIGURE_ARGS+= --disable-freetype
.endif
.if !defined(WITHOUT_X11)
-USE_XLIB= yes
+USE_XORG= x11
.else
WITHOUT_GUI= yes
CONFIGURE_ARGS+=--disable-x11 \
@@ -229,7 +229,7 @@ post-patch:
-e 's|[[:space:]]gcc[-[:digit:]\.]+| ${CC}|' \
-e 's|[[:space:]]gcc| ${CC}|' \
-e 's|\$$\(CC\)|${CC}|' \
- -e 's|/usr/X11R6|${X11BASE}|'
+ -e 's|/usr/X11R6|${LOCALBASE}|'
@${FIND} ${WRKSRC}/DOCS/man -name "mplayer.1" | ${XARGS} ${REINPLACE_CMD} -E -e \
's|/usr/\\:local/\\:etc/\\:mplayer|${DATADIR:S/\//\/\\\:/g}|g ; \
s|/dev/\\:(dvd[[:alnum:]]*[[:>:]])|${DEFAULT_DVD_DEVICE:S/dev\//dev\/\\\:/}|g ; \
diff --git a/multimedia/mplayer/Makefile.options b/multimedia/mplayer/Makefile.options
index 80cdedc60ecb..19e20b0b7934 100644
--- a/multimedia/mplayer/Makefile.options
+++ b/multimedia/mplayer/Makefile.options
@@ -147,7 +147,7 @@ CONFIGURE_ARGS+= --disable-speex
.if defined(WITH_XANIM)
BUILD_DEPENDS+= xanim:${PORTSDIR}/multimedia/xanim
-CONFIGURE_ARGS+=--enable-xanim --with-xanimlibdir=${X11BASE}/lib/X11/xanim
+CONFIGURE_ARGS+=--enable-xanim --with-xanimlibdir=${LOCALBASE}/lib/X11/xanim
.else
CONFIGURE_ARGS+=--disable-xanim
.endif
@@ -272,7 +272,7 @@ CONFIGURE_ARGS+= --disable-win32dll \
.if defined(WITH_REALPLAYER)
CONFIGURE_ARGS+= --enable-real \
- --realcodecsdir=${X11BASE}/lib/RealPlayer/codecs
+ --realcodecsdir=${LOCALBASE}/lib/RealPlayer/codecs
RUN_DEPENDS+= realplay:${PORTSDIR}/multimedia/linux-realplayer
BUILD_DEPENDS+= realplay:${PORTSDIR}/multimedia/linux-realplayer
.else