aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mps-youtube
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2014-04-09 00:28:07 +0000
committerNicola Vitale <nivit@FreeBSD.org>2014-04-09 00:28:07 +0000
commitcfe59693042eb34d83b0027b593c713b8eb5a658 (patch)
tree39e4844dab909b35e461aa9099e86d56166a5569 /multimedia/mps-youtube
parent4718aab97329da8c818e1e5a94a6f48eea01941e (diff)
downloadports-cfe59693042eb34d83b0027b593c713b8eb5a658.tar.gz
ports-cfe59693042eb34d83b0027b593c713b8eb5a658.zip
Terminal based YouTube jukebox with playlist management.
Main features: - Search and play audio/video from YouTube - Search and import YouTube playlists - Create and save local playlists - Download audio/video - Works with Python 2.7+ and 3.x - Works with Windows, Linux and Mac OS X - Requires mplayer or mpv WWW: http://github.com/np1/mps-youtube
Notes
Notes: svn path=/head/; revision=350653
Diffstat (limited to 'multimedia/mps-youtube')
-rw-r--r--multimedia/mps-youtube/Makefile38
-rw-r--r--multimedia/mps-youtube/distinfo2
-rw-r--r--multimedia/mps-youtube/pkg-descr13
-rw-r--r--multimedia/mps-youtube/pkg-message7
4 files changed, 60 insertions, 0 deletions
diff --git a/multimedia/mps-youtube/Makefile b/multimedia/mps-youtube/Makefile
new file mode 100644
index 000000000000..dcd85d5721bd
--- /dev/null
+++ b/multimedia/mps-youtube/Makefile
@@ -0,0 +1,38 @@
+# Created by: Nicola Vitale <nivit@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mps-youtube
+PORTVERSION= 0.01.44
+#PORTREVISION= 0
+CATEGORIES= multimedia
+MASTER_SITES= CHEESESHOP
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Terminal based YouTube jukebox with playlist management
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pafy>=0.3.41:${PORTSDIR}/www/py-pafy
+
+OPTIONS_DEFAULT= MPLAYER
+OPTIONS_RADIO= PLAYER
+OPTIONS_RADIO_PLAYER= MPLAYER MPV
+
+MPV_DESC= Mpv media player support
+
+# This port installs the following files in shared dirs
+# PLIST_FILES= bin/mpsyt
+PYDISTUTILS_AUTOPLIST= yes
+
+USE_PYDISTUTILS= yes
+USE_PYTHON= yes
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MMPLAYER}
+RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
+.elif ${PORT_OPTIONS:MMPV}
+RUN_DEPENDS+= mpv:${PORTSDIR}/multimedia/mpv
+.endif
+
+.include <bsd.port.mk>
diff --git a/multimedia/mps-youtube/distinfo b/multimedia/mps-youtube/distinfo
new file mode 100644
index 000000000000..58cea107fabc
--- /dev/null
+++ b/multimedia/mps-youtube/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mps-youtube-0.01.44.tar.gz) = c1d15b81a64c3ad9e4609efb7b37be4815cd36f2ad321cac0e1276ec4f873e87
+SIZE (mps-youtube-0.01.44.tar.gz) = 32753
diff --git a/multimedia/mps-youtube/pkg-descr b/multimedia/mps-youtube/pkg-descr
new file mode 100644
index 000000000000..52ba75f00703
--- /dev/null
+++ b/multimedia/mps-youtube/pkg-descr
@@ -0,0 +1,13 @@
+Terminal based YouTube jukebox with playlist management.
+
+Main features:
+
+ - Search and play audio/video from YouTube
+ - Search and import YouTube playlists
+ - Create and save local playlists
+ - Download audio/video
+ - Works with Python 2.7+ and 3.x
+ - Works with Windows, Linux and Mac OS X
+ - Requires mplayer or mpv
+
+WWW: http://github.com/np1/mps-youtube
diff --git a/multimedia/mps-youtube/pkg-message b/multimedia/mps-youtube/pkg-message
new file mode 100644
index 000000000000..522bf4ef929a
--- /dev/null
+++ b/multimedia/mps-youtube/pkg-message
@@ -0,0 +1,7 @@
+********************************************************************************
+
+ Note that to see videos you have to enable the relative option in the program
+
+ set video_option True
+
+********************************************************************************