aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mythtv
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2012-08-04 08:10:48 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2012-08-04 08:10:48 +0000
commit988408a7e62c51d245e466f5b4340f52a3131f90 (patch)
treef5a5dc1c8e953f650487aff1ba2cc3d5c2ec8c5b /multimedia/mythtv
parent9eaf125b0421b3ad549c4a807e1493a3accd8076 (diff)
downloadports-988408a7e62c51d245e466f5b4340f52a3131f90.tar.gz
ports-988408a7e62c51d245e466f5b4340f52a3131f90.zip
- Update to 0.25.2
- Fix Perl and Python bindings and enable per default - Fix PHP bindings for PHP 5.4
Notes
Notes: svn path=/head/; revision=302007
Diffstat (limited to 'multimedia/mythtv')
-rw-r--r--multimedia/mythtv/Makefile22
-rw-r--r--multimedia/mythtv/distinfo4
-rw-r--r--multimedia/mythtv/files/patch-bindings__php__MythBase.php11
-rw-r--r--multimedia/mythtv/files/patch-bindings__python__setup.py4
-rw-r--r--multimedia/mythtv/pkg-plist14
5 files changed, 42 insertions, 13 deletions
diff --git a/multimedia/mythtv/Makefile b/multimedia/mythtv/Makefile
index 3f4e956c21c7..6785b6ffd889 100644
--- a/multimedia/mythtv/Makefile
+++ b/multimedia/mythtv/Makefile
@@ -7,8 +7,7 @@
# $FreeBSD$
PORTNAME= mythtv
-PORTVERSION= 0.25
-PORTREVISION= 1
+PORTVERSION= 0.25.2
CATEGORIES= multimedia
MASTER_SITES= http://ftp.osuosl.org/pub/mythtv/ \
http://ftp.osuosl.org/pub/mythtv/old_releases/ \
@@ -57,7 +56,7 @@ CONFIGURE_ARGS= --prefix="${PREFIX}" --dvb-path="${LOCALBASE}/include" \
QMAKESPEC?= ${LOCALBASE}/share/qt4/mkspecs/freebsd-g++
-OPTIONS= BINDINGS "Perl and Python bindings" off \
+OPTIONS= BINDINGS "Perl and Python bindings" on \
LIRC "Native LIRC Support" off \
MYSQL_LOCAL "RUN_DEPEND on selected MySQL server" off \
OPENGL "OpenGL support" on \
@@ -71,18 +70,25 @@ SUB_FILES= pkg-message
USE_PYTHON= yes
INSTALLS_EGGINFO=yes
PYDISTUTILS_PKGNAME=MythTV
-PYDISTUTILS_PKGVERSION=${PORTVERSION}.0
+PYDISTUTILS_PKGVERSION=${PORTVERSION}
BUILD_DEPENDS+= py*-lxml>=0:${PORTSDIR}/devel/py-lxml \
${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:${PORTSDIR}/databases/py-MySQLdb \
- ${PYTHON_PKGNAMEPREFIX}urlgrabber>=3.1.0_1:${PORTSDIR}/www/py-urlgrabber
+ ${PYTHON_PKGNAMEPREFIX}urlgrabber>=3.1.0_1:${PORTSDIR}/www/py-urlgrabber \
+ p5-HTTP-Request-Params>=0:${PORTSDIR}/www/p5-HTTP-Request-Params \
+ p5-LWP-UserAgent-Determined>=0:${PORTSDIR}/www/p5-LWP-UserAgent-Determined \
+ p5-Net-UPnP>=0:${PORTSDIR}/multimedia/p5-Net-UPnP \
+ p5-IO-Socket-INET6>=2.51:${PORTSDIR}/net/p5-IO-Socket-INET6
RUN_DEPENDS+= py*-lxml>=0:${PORTSDIR}/devel/py-lxml \
${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:${PORTSDIR}/databases/py-MySQLdb \
- ${PYTHON_PKGNAMEPREFIX}urlgrabber>=3.1.0_1:${PORTSDIR}/www/py-urlgrabber
-CONFIGURE_ARGS+=--without-bindings=perl,php
+ ${PYTHON_PKGNAMEPREFIX}urlgrabber>=3.1.0_1:${PORTSDIR}/www/py-urlgrabber \
+ p5-HTTP-Request-Params>=0:${PORTSDIR}/www/p5-HTTP-Request-Params \
+ p5-LWP-UserAgent-Determined>=0:${PORTSDIR}/www/p5-LWP-UserAgent-Determined \
+ p5-Net-UPnP>=0:${PORTSDIR}/multimedia/p5-Net-UPnP \
+ p5-IO-Socket-INET6>=2.51:${PORTSDIR}/net/p5-IO-Socket-INET6
PLIST_SUB+= BINDINGS=""
.else
-CONFIGURE_ARGS+=--without-bindings=perl,python,php
+CONFIGURE_ARGS+=--without-bindings=perl,python
PLIST_SUB+= BINDINGS="@comment "
.endif
diff --git a/multimedia/mythtv/distinfo b/multimedia/mythtv/distinfo
index dd16dd73afdf..fa432f20bc4a 100644
--- a/multimedia/mythtv/distinfo
+++ b/multimedia/mythtv/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mythtv-0.25.tar.bz2) = 341d6efdfe22540a62af7926ef8245c48fe1b256df8bc5f69c38a936436b68f0
-SIZE (mythtv-0.25.tar.bz2) = 31883030
+SHA256 (mythtv-0.25.2.tar.bz2) = d6b7f1692f30b3dde170d2b755453675de1d222aa8556197e62b8d8617beeac6
+SIZE (mythtv-0.25.2.tar.bz2) = 31838320
diff --git a/multimedia/mythtv/files/patch-bindings__php__MythBase.php b/multimedia/mythtv/files/patch-bindings__php__MythBase.php
new file mode 100644
index 000000000000..e291c6dc26f6
--- /dev/null
+++ b/multimedia/mythtv/files/patch-bindings__php__MythBase.php
@@ -0,0 +1,11 @@
+--- bindings/php/MythBase.php.orig 2012-07-16 17:21:00.000000000 +0200
++++ bindings/php/MythBase.php 2012-07-29 14:13:02.915720097 +0200
+@@ -47,7 +47,7 @@
+
+ public function __destruct() {
+ if (!is_null($this->cacheKey))
+- Cache::setObject($this->cacheKey, &$this, $this->cacheLifetime);
++ Cache::setObject($this->cacheKey, $this, $this->cacheLifetime);
+ $this->cacheKey = null;
+ }
+
diff --git a/multimedia/mythtv/files/patch-bindings__python__setup.py b/multimedia/mythtv/files/patch-bindings__python__setup.py
index 5ccad0b4188d..9cda71b3ab21 100644
--- a/multimedia/mythtv/files/patch-bindings__python__setup.py
+++ b/multimedia/mythtv/files/patch-bindings__python__setup.py
@@ -4,8 +4,8 @@
setup(
name='MythTV',
-- version='0.24.0',
-+ version='0.25.0',
+- version='0.25.0',
++ version='0.25.2',
description='MythTV Python bindings.',
long_description='Provides canned database and protocol access to the MythTV database, mythproto, mythxml, and frontend remote control.',
packages=['MythTV', 'MythTV/tmdb', 'MythTV/tmdb3', 'MythTV/ttvdb', 'MythTV/wikiscripts'],
diff --git a/multimedia/mythtv/pkg-plist b/multimedia/mythtv/pkg-plist
index ea61137dbb13..3507c9543272 100644
--- a/multimedia/mythtv/pkg-plist
+++ b/multimedia/mythtv/pkg-plist
@@ -1,4 +1,4 @@
-@comment $FreeBSD: /tmp/pcvs/ports/multimedia/mythtv/pkg-plist,v 1.12 2012-05-10 08:21:13 decke Exp $
+@comment $FreeBSD$
bin/mythavtest
bin/mythbackend
bin/mythccextractor
@@ -469,6 +469,8 @@ include/mythtv/xmlparse.h
%%BINDINGS%%%%PYTHON_SITELIBDIR%%/MythTV/tmdb3/request.pyc
%%BINDINGS%%%%PYTHON_SITELIBDIR%%/MythTV/tmdb3/tmdb_api.py
%%BINDINGS%%%%PYTHON_SITELIBDIR%%/MythTV/tmdb3/tmdb_api.pyc
+%%BINDINGS%%%%PYTHON_SITELIBDIR%%/MythTV/tmdb3/tmdb_auth.py
+%%BINDINGS%%%%PYTHON_SITELIBDIR%%/MythTV/tmdb3/tmdb_auth.pyc
%%BINDINGS%%%%PYTHON_SITELIBDIR%%/MythTV/tmdb3/tmdb_exceptions.py
%%BINDINGS%%%%PYTHON_SITELIBDIR%%/MythTV/tmdb3/tmdb_exceptions.pyc
%%BINDINGS%%%%PYTHON_SITELIBDIR%%/MythTV/tmdb3/util.py
@@ -583,6 +585,14 @@ lib/mythtv/filters/libyadif.so
%%DATADIR%%/MXML_scpd.xml
%%DATADIR%%/backend-config/config_backend_database.xml
%%DATADIR%%/backend-config/config_backend_general.xml
+%%DATADIR%%/bindings/php/MythBackend.php
+%%DATADIR%%/bindings/php/MythBase.php
+%%DATADIR%%/bindings/php/MythFrontend.php
+%%DATADIR%%/bindings/php/MythTVChannel.php
+%%DATADIR%%/bindings/php/MythTV.php
+%%DATADIR%%/bindings/php/MythTVProgram.php
+%%DATADIR%%/bindings/php/MythTVRecording.php
+%%DATADIR%%/bindings/php/MythTVStorageGroup.php
%%DATADIR%%/database/mc.sql
%%DATADIR%%/devicemaster.xml
%%DATADIR%%/deviceslave.xml
@@ -2136,6 +2146,8 @@ lib/mythtv/filters/libyadif.so
@dirrm %%DATADIR%%/hardwareprofile
@dirrm %%DATADIR%%/fonts
@dirrm %%DATADIR%%/database
+@dirrm %%DATADIR%%/bindings/php
+@dirrm %%DATADIR%%/bindings
@dirrm %%DATADIR%%/backend-config
@dirrmtry %%DATADIR%%
@dirrm lib/mythtv/filters