aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mythtv
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /multimedia/mythtv
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
downloadports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.tar.gz
ports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Notes
Notes: svn path=/head/; revision=373448
Diffstat (limited to 'multimedia/mythtv')
-rw-r--r--multimedia/mythtv/Makefile4
-rw-r--r--multimedia/mythtv/pkg-plist4
2 files changed, 2 insertions, 6 deletions
diff --git a/multimedia/mythtv/Makefile b/multimedia/mythtv/Makefile
index 7a86f42bc504..0e666af35761 100644
--- a/multimedia/mythtv/Makefile
+++ b/multimedia/mythtv/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mythtv
PORTVERSION= 0.27.0.20140121
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= multimedia
MASTER_SITES= http://people.freebsd.org/~decke/distfiles/
@@ -29,7 +29,7 @@ GH_COMMIT= 5a5e1cd
WRKSRC= ${WRKDIR}/${GH_ACCOUNT}-${GH_PROJECT}-${GH_COMMIT}/${GH_PROJECT}
ONLY_FOR_ARCHS= i386 amd64
-USE_PERL5= run build fixpacklist
+USE_PERL5= run build
NOPRECIOUSMAKEVARS= # don't override $(ARCH) in ffmpeg makefiles
USES= gmake libtool perl5 pkgconfig pathfix
USE_QT4= gui sql network script linguist_build l10n sql-mysql_run \
diff --git a/multimedia/mythtv/pkg-plist b/multimedia/mythtv/pkg-plist
index a8d0dac9c4af..5a9084754ce5 100644
--- a/multimedia/mythtv/pkg-plist
+++ b/multimedia/mythtv/pkg-plist
@@ -493,7 +493,6 @@ include/mythtv/xmlparse.h
include/mythtv/zeromq/zmq.h
include/mythtv/zeromq/zmq.hpp
include/mythtv/zeromq/zmq_utils.h
-%%BINDINGS%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/MythTV/.packlist
%%BINDINGS%%%%SITE_PERL%%/IO/Socket/INET/MythTV.pm
%%BINDINGS%%%%SITE_PERL%%/MythTV.pm
%%BINDINGS%%%%SITE_PERL%%/MythTV/Channel.pm
@@ -2327,9 +2326,6 @@ libdata/pkgconfig/libmythzmq.pc
%%BINDINGS%%@dirrm %%PYTHON_SITELIBDIR%%/MythTV/ttvdb
%%BINDINGS%%@dirrm %%PYTHON_SITELIBDIR%%/MythTV/tmdb3
%%BINDINGS%%@dirrm %%PYTHON_SITELIBDIR%%/MythTV
-%%BINDINGS%%@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MythTV
-%%BINDINGS%%@dirrmtry %%SITE_PERL%%/IO/Socket/INET
-%%BINDINGS%%@dirrm %%SITE_PERL%%/MythTV
@dirrm include/mythtv/zeromq
@dirrm include/mythtv/upnp
@dirrm include/mythtv/mpeg2dec