aboutsummaryrefslogtreecommitdiff
path: root/multimedia/obs-studio
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2023-06-14 22:00:28 +0000
committerRene Ladan <rene@FreeBSD.org>2023-06-27 19:34:34 +0000
commit3d9a815d9c5acbb71f4bb07738bdeab4879feacb (patch)
treeeb093f22197a2c68a88dd2372ec1922c3f6d3c10 /multimedia/obs-studio
parentc58ef91e06e8edc4fd8579837f1453b562da3fbb (diff)
downloadports-3d9a815d9c5acbb71f4bb07738bdeab4879feacb.tar.gz
ports-3d9a815d9c5acbb71f4bb07738bdeab4879feacb.zip
all: remove explicit versions in USES=python for "3.x+"
The logic in USES=python will automatically convert this to 3.8+ by itself. Adjust two ports that only had Python 3.7 mentioned but build fine on Python 3.8 too. finance/quickfix: mark BROKEN with PYTHON libtool: compile: c++ -DHAVE_CONFIG_H -I. -I../.. -I -I. -I.. -I../.. -I../C++ -DLIBICONV_PLUG -DPYTHON_MAJOR_VERSION=3 -Wno-unused-variable -Wno-maybe-uninitialized -O2 -pipe -DLIBICONV_PLUG -fstack-protector-strong -fno-strict-aliasing -DLIBICONV_PLUG -Wall -ansi -Wno-unused-command-line-argument -Wpointer-arith -Wwrite-strings -Wno-overloaded-virtual -Wno-deprecated-declarations -Wno-deprecated -std=c++0x -MT _quickfix_la-QuickfixPython.lo -MD -MP -MF .deps/_quickfix_la-QuickfixPython.Tpo -c QuickfixPython.cpp -fPIC -DPIC -o .libs/_quickfix_la-QuickfixPython.o warning: unknown warning option '-Wno-maybe-uninitialized'; did you mean '-Wno-uninitialized'? [-Wunknown-warning-option] QuickfixPython.cpp:175:11: fatal error: 'Python.h' file not found ^~~~~~~~~~ 1 warning and 1 error generated. Reviewed by: portmgr, vishwin, yuri Differential Revision: <https://reviews.freebsd.org/D40568>
Diffstat (limited to 'multimedia/obs-studio')
-rw-r--r--multimedia/obs-studio/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/multimedia/obs-studio/Makefile b/multimedia/obs-studio/Makefile
index 2ea1c7c3d910..47881baddaa9 100644
--- a/multimedia/obs-studio/Makefile
+++ b/multimedia/obs-studio/Makefile
@@ -46,7 +46,7 @@ LIB_DEPENDS_powerpc= libluajit-5.1.so:lang/luajit
LIB_DEPENDS_powerpc64= libluajit-5.1.so:lang/luajit-openresty
LIB_DEPENDS_powerpc64le= libluajit-5.1.so:lang/luajit-openresty
-USES= cmake compiler:c++17-lang desktop-file-utils gl gnome lua pkgconfig python:3.4+ \
+USES= cmake compiler:c++17-lang desktop-file-utils gl gnome lua pkgconfig python \
qt:6 xorg
USE_QT= base svg tools:build
USE_GNOME= glib20