aboutsummaryrefslogtreecommitdiff
path: root/multimedia/ogle
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-04-18 02:26:16 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-04-18 02:26:16 +0000
commit5641a05fd0249a9a7fafdc2dfcf8f1ff7024c08d (patch)
tree8366e0898c9779f6846101752224efabff119285 /multimedia/ogle
parent2dbd0db0ee5e9934fb8043bb402d251ea5f52eed (diff)
downloadports-5641a05fd0249a9a7fafdc2dfcf8f1ff7024c08d.tar.gz
ports-5641a05fd0249a9a7fafdc2dfcf8f1ff7024c08d.zip
o Enable WITH_OPTIMIZED_BYTESWAP if CPUTYPE was set properly
o Re-arrange a bit so that this affects the whole port Reviewed by: kris
Notes
Notes: svn path=/head/; revision=57832
Diffstat (limited to 'multimedia/ogle')
-rw-r--r--multimedia/ogle/Makefile36
1 files changed, 21 insertions, 15 deletions
diff --git a/multimedia/ogle/Makefile b/multimedia/ogle/Makefile
index 84f135445d98..9a8f74530d2d 100644
--- a/multimedia/ogle/Makefile
+++ b/multimedia/ogle/Makefile
@@ -33,20 +33,6 @@ MAN5= oglerc.5
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
-pre-everything::
-.ifndef(WITH_DVD_DEVICE)
- @${ECHO_MSG} '===> The default DVD device is /dev/acd0c'
- @${ECHO_MSG} "===> You can choose any DVD device at Ogle's command line"
- @${ECHO_MSG} '===> Define WITH_DVD_DEVICE if you want to change the default'
- @${ECHO_MSG} "===> For example, 'make WITH_DVD_DEVICE=\"/dev/somedevice\"'"
-.endif
-.ifndef(WITH_OPTIMIZED_BYTESWAP)
- @${ECHO_MSG} '===>'
- @${ECHO_MSG} '===> Define WITH_OPTIMIZED_BYTESWAP to use optimized byteswap'
- @${ECHO_MSG} '===> routines. This works only in the i386 architecture but'
- @${ECHO_MSG} '===> only with 486 processors and above.'
-.endif
-
post-patch:
.ifdef(WITH_DVD_DEVICE)
@${PERL} -pi.orig -e \
@@ -69,8 +55,28 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386" && defined(WITH_OPTIMIZED_BYTESWAP)
+.if ${ARCH} == "i386"
+. if (defined(MACHINE_CPU) && ${MACHINE_CPU:Mi486} == "i486")
+WITH_OPTIMIZED_BYTESWAP=yes
+. endif
+
+. if defined(WITH_OPTIMIZED_BYTESWAP)
EXTRA_PATCHES= ${FILESDIR}/extra-patch-include:ogle_endian.h
+. endif
+.endif
+
+pre-everything::
+.ifndef(WITH_DVD_DEVICE)
+ @${ECHO_MSG} '===> The default DVD device is /dev/acd0c'
+ @${ECHO_MSG} "===> You can choose any DVD device at Ogle's command line"
+ @${ECHO_MSG} '===> Define WITH_DVD_DEVICE if you want to change the default'
+ @${ECHO_MSG} "===> For example, 'make WITH_DVD_DEVICE=\"/dev/somedevice\"'"
+.endif
+.ifndef(WITH_OPTIMIZED_BYTESWAP)
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> Define WITH_OPTIMIZED_BYTESWAP to use optimized byteswap'
+ @${ECHO_MSG} '===> routines. This works only in the i386 architecture, and'
+ @${ECHO_MSG} '===> only with 486 processors and above.'
.endif
.include <bsd.port.post.mk>