aboutsummaryrefslogtreecommitdiff
path: root/multimedia/pipewire/files
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2020-02-28 16:45:21 +0000
committerGleb Popov <arrowd@FreeBSD.org>2020-02-28 16:45:21 +0000
commit71b032138591b104476fe377f0844849eab44f10 (patch)
treef2f6efdc9e6ea57495a87217cc788d849ac8c815 /multimedia/pipewire/files
parent29af7b5e6db2a0e0db1f0d62326b55f44ac4da08 (diff)
downloadports-71b032138591b104476fe377f0844849eab44f10.tar.gz
ports-71b032138591b104476fe377f0844849eab44f10.zip
multimedia/pipewire: Add a new port.
PipeWire aims to be a "new pulseaudio", that is "a server and userspace API to deal with multimedia pipelines". Most of software's functionality is turned off by now, as I'm only need this library to make another port. PRs or patches to change that are welcome.
Notes
Notes: svn path=/head/; revision=527338
Diffstat (limited to 'multimedia/pipewire/files')
-rw-r--r--multimedia/pipewire/files/patch-meson53
-rw-r--r--multimedia/pipewire/files/patch-src_tools_pw-cli.c12
2 files changed, 65 insertions, 0 deletions
diff --git a/multimedia/pipewire/files/patch-meson b/multimedia/pipewire/files/patch-meson
new file mode 100644
index 000000000000..ac0553c51527
--- /dev/null
+++ b/multimedia/pipewire/files/patch-meson
@@ -0,0 +1,53 @@
+--- meson.build.orig 2020-02-20 14:33:31 UTC
++++ meson.build
+@@ -221,6 +221,10 @@ epoll_shim_dep = (build_machine.system() == 'freebsd'
+ ? dependency('epoll-shim', required: true)
+ : dependency('', required: false))
+
++if build_machine.system() == 'freebsd'
++ epoll_shim_dep = dependency('epoll-shim', required: true)
++endif
++
+ subdir('spa')
+ subdir('src')
+
+--- spa/plugins/alsa/meson.build.orig 2020-02-20 14:33:31 UTC
++++ spa/plugins/alsa/meson.build
+@@ -10,6 +10,6 @@ spa_alsa_sources = ['alsa.c',
+ spa_alsa = shared_library('spa-alsa',
+ spa_alsa_sources,
+ include_directories : [spa_inc],
+- dependencies : [ alsa_dep, libudev_dep, mathlib, ],
++ dependencies : [ alsa_dep, libudev_dep, mathlib, epoll_shim_dep],
+ install : true,
+ install_dir : join_paths(spa_plugindir, 'alsa'))
+--- spa/plugins/audiotestsrc/meson.build.orig 2020-02-20 14:33:31 UTC
++++ spa/plugins/audiotestsrc/meson.build
+@@ -3,6 +3,6 @@ audiotestsrc_sources = ['audiotestsrc.c', 'plugin.c']
+ audiotestsrclib = shared_library('spa-audiotestsrc',
+ audiotestsrc_sources,
+ include_directories : [spa_inc],
+- dependencies : [mathlib, ],
++ dependencies : [mathlib, epoll_shim_dep],
+ install : true,
+ install_dir : join_paths(spa_plugindir, 'audiotestsrc'))
+--- src/modules/meson.build.orig 2020-02-20 14:33:31 UTC
++++ src/modules/meson.build
+@@ -29,7 +29,7 @@ pipewire_module_rtkit = shared_library('pipewire-modul
+ include_directories : [configinc, spa_inc],
+ install : true,
+ install_dir : modules_install_dir,
+- dependencies : [dbus_dep, mathlib, dl_lib, pipewire_dep],
++ dependencies : [dbus_dep, mathlib, dl_lib, pipewire_dep, epoll_shim_dep],
+ )
+ endif
+
+@@ -42,7 +42,7 @@ pipewire_module_client_node = shared_library('pipewire
+ include_directories : [configinc, spa_inc],
+ install : true,
+ install_dir : modules_install_dir,
+- dependencies : [mathlib, dl_lib, pipewire_dep],
++ dependencies : [mathlib, dl_lib, pipewire_dep, epoll_shim_dep],
+ )
+
+ pipewire_module_link_factory = shared_library('pipewire-module-link-factory',
diff --git a/multimedia/pipewire/files/patch-src_tools_pw-cli.c b/multimedia/pipewire/files/patch-src_tools_pw-cli.c
new file mode 100644
index 000000000000..174af07c07e6
--- /dev/null
+++ b/multimedia/pipewire/files/patch-src_tools_pw-cli.c
@@ -0,0 +1,12 @@
+--- src/tools/pw-cli.c.orig 2020-02-20 14:33:31 UTC
++++ src/tools/pw-cli.c
+@@ -28,7 +28,9 @@
+ #include <signal.h>
+ #include <string.h>
+ #include <ctype.h>
++#ifndef __FreeBSD__
+ #include <alloca.h>
++#endif
+
+ #include <spa/utils/result.h>
+ #include <spa/debug/pod.h>