aboutsummaryrefslogtreecommitdiff
path: root/multimedia/plexmediaserver-plexpass/Makefile
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2014-02-24 21:02:33 +0000
committerMark Felder <feld@FreeBSD.org>2014-02-24 21:02:33 +0000
commitdab182e3c7b048c3577fdeacb051b734ae497bb2 (patch)
treef684e44221541c15048e60266782cdda90442427 /multimedia/plexmediaserver-plexpass/Makefile
parent5ea0dfe5106f4db4d6b8de73d702926940d6156b (diff)
downloadports-dab182e3c7b048c3577fdeacb051b734ae497bb2.tar.gz
ports-dab182e3c7b048c3577fdeacb051b734ae497bb2.zip
Welcome plexmediaserver-plexpass to ports
This is a clone of the existing multimedia/plexmediaserver port. All future "Plexpass" (read: bleeding edge) releases will land here on this port. Subsequently, all future public/stable releases of Plex Media Server will be committed to the existing multimedia/plexmediaserver port. Now that Plex has stabilized on FreeBSD and users are not waiting for a laundry list of platform-specific bugfixes it is important that we offer choice of both the recommended stable version as well as the bleeding edge.
Notes
Notes: svn path=/head/; revision=345898
Diffstat (limited to 'multimedia/plexmediaserver-plexpass/Makefile')
-rw-r--r--multimedia/plexmediaserver-plexpass/Makefile65
1 files changed, 65 insertions, 0 deletions
diff --git a/multimedia/plexmediaserver-plexpass/Makefile b/multimedia/plexmediaserver-plexpass/Makefile
new file mode 100644
index 000000000000..86a51edda3a2
--- /dev/null
+++ b/multimedia/plexmediaserver-plexpass/Makefile
@@ -0,0 +1,65 @@
+# Created by: KalleDK <plexmaintainer@k-moeller.dk>
+# $FreeBSD$
+
+PORTNAME= plexmediaserver
+PORTVERSION= 0.9.9.4.409
+CATEGORIES= multimedia
+MASTER_SITES= http://plex.r.worldssl.net/plex-media-server/${PORTVERSION}-${PLEX_BUILD}/
+PKGNAMESUFFIX= -plexpass
+DISTNAME= PlexMediaServer-${PORTVERSION}-${PLEX_BUILD}-freebsd-amd64
+
+MAINTAINER= feld@FreeBSD.org
+COMMENT= The Plex Media Server component
+
+USE_BZIP2= yes
+PLEX_BUILD= bf81d98
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/PlexMediaServer-${PORTVERSION}-${PLEX_BUILD}
+
+USE_RC_SUBR= plexmediaserver
+
+SUB_FILES= plexmediaserver
+SUB_LIST= SUPPORT_PATH=${SUPPORT_PATH} SCRIPT_PATH="${SCRIPT_PATH}" USERS=${USERS} GROUPS=${GROUPS}
+
+USERS= plex
+GROUPS= plex
+SUPPORT_PATH?= ${PREFIX}/plexdata
+SCRIPT_PATH?= ${DATADIR}
+
+ONLY_FOR_ARCHS= amd64
+
+CONFLICTS= plexmediaserver-[0-9]*
+
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD
+.if ${OSVERSION} < 900000
+IGNORE= supplied binaries compiled for FreeBSD 9
+.endif
+
+.if ${OSVERSION} >= 1000054
+RUN_DEPENDS+= ${LOCALBASE}/lib/compat/libstdc++.so.6:${PORTSDIR}/misc/compat9x
+.endif
+.endif
+
+post-patch:
+ # binaries don't come pre-stripped
+ ${FIND} ${WRKSRC} -name '*.so' -exec ${STRIP_CMD} {} \;
+
+do-install:
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} Resources ${STAGEDIR}/${SCRIPT_PATH})
+ ${INSTALL_PROGRAM} ${WRKSRC}/Plex\ DLNA\ Server ${STAGEDIR}/${SCRIPT_PATH}
+ ${INSTALL_PROGRAM} ${WRKSRC}/Plex\ Media\ Scanner ${STAGEDIR}/${SCRIPT_PATH}
+ ${INSTALL_PROGRAM} ${WRKSRC}/Plex\ Media\ Server ${STAGEDIR}/${SCRIPT_PATH}
+ ${INSTALL_SCRIPT} ${WRKSRC}/start.sh ${STAGEDIR}/${SCRIPT_PATH}
+ ${INSTALL_LIB} ${WRKSRC}/lib* ${STAGEDIR}/${SCRIPT_PATH}
+ # Fix permissions to programs and db
+ @${CHMOD} a+x ${STAGEDIR}/${SCRIPT_PATH}/Resources/rsync
+ @${CHMOD} a+x ${STAGEDIR}/${SCRIPT_PATH}/Resources/Plex\ New\ Transcoder
+ @${CHMOD} a+x ${STAGEDIR}/${SCRIPT_PATH}/Resources/Plex\ Transcoder
+ @${CHMOD} a+x ${STAGEDIR}/${SCRIPT_PATH}/Resources/Python/bin/python
+ @${CHMOD} u+w ${STAGEDIR}/${SCRIPT_PATH}/Resources/com.plexapp.plugins.library.db
+ # Python fix
+ @${LN} -s ${SCRIPT_PATH}/libpython2.7.so.1 ${STAGEDIR}/${SCRIPT_PATH}/libpython2.7.so
+
+.include <bsd.port.post.mk>