aboutsummaryrefslogtreecommitdiff
path: root/multimedia/pvrxxx
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-01-20 06:28:45 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-01-20 06:28:45 +0000
commitcefe036b57c9f51880a0c1b8a753c89d348da1ac (patch)
treeb9e58e1872761fda7545f963037927c6e2a231da /multimedia/pvrxxx
parentbececa38ea2365df3cea4756e6f8a55db3bdcea7 (diff)
downloadports-cefe036b57c9f51880a0c1b8a753c89d348da1ac.tar.gz
ports-cefe036b57c9f51880a0c1b8a753c89d348da1ac.zip
Attached you will find an file to add to files dir and a diff to
the makefile to add a european channel set for the PVR250 driver. I already sent John Wehle the additional channel set to include it in the next driver version, then the final patch to cxm_tuner.c should be smaller. Would be cool to find this in the next port version, so I don't have to patch manually every time again and maybe others in old europe (actually I tested it for germany) may find it useful, too. Thanx, Oliver Submitted by: Oliver Brandmueller <ob@e-Gitt.NET>
Notes
Notes: svn path=/head/; revision=126899
Diffstat (limited to 'multimedia/pvrxxx')
-rw-r--r--multimedia/pvrxxx/Makefile5
-rw-r--r--multimedia/pvrxxx/files/patchtuner-bgcable48
2 files changed, 53 insertions, 0 deletions
diff --git a/multimedia/pvrxxx/Makefile b/multimedia/pvrxxx/Makefile
index 0bd07d735d05..893ab91c2b12 100644
--- a/multimedia/pvrxxx/Makefile
+++ b/multimedia/pvrxxx/Makefile
@@ -8,6 +8,7 @@
PORTNAME= pvr250
PORTVERSION= 20041230
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://www.mavetju.org/download/adopted/
DISTFILES= ${CXMSHAR} hcwPVRP2.sys ${PVRTOOLS}.tar.gz
@@ -30,6 +31,7 @@ NO_CDROM= ${RESTRICTED}
OPTIONS= USBROADCAST "US Broadcast" Off \
USCABLE "US Cable" Off \
BGBROADCAST "B/G Broadcast" Off \
+ BGCABLE "B/G Cable" Off \
BGAUSTRALIA "B/G Australia" Off \
IBROADCAST "I Broadcast" Off \
LBROADCAST "L Broadcast" Off
@@ -53,6 +55,9 @@ EXTRA_PATCHES= ${FILESDIR}/patchtuner-uscable
.if defined(WITH_BGBROADCAST)
EXTRA_PATCHES= ${FILESDIR}/patchtuner-bgbroadcast
.endif
+.if defined(WITH_BGCABLE)
+EXTRA_PATCHES= ${FILESDIR}/patchtuner-bgcable
+.endif
.if defined(WITH_BGAUSTRALIA)
EXTRA_PATCHES= ${FILESDIR}/patchtuner-bgaustralia
.endif
diff --git a/multimedia/pvrxxx/files/patchtuner-bgcable b/multimedia/pvrxxx/files/patchtuner-bgcable
new file mode 100644
index 000000000000..5bf66d8cc90f
--- /dev/null
+++ b/multimedia/pvrxxx/files/patchtuner-bgcable
@@ -0,0 +1,48 @@
+--- dev/cxm/cxm_tuner.c.org Wed Jan 19 00:36:54 2005
++++ dev/cxm/cxm_tuner.c Wed Jan 19 00:39:46 2005
+@@ -128,6 +128,27 @@
+ };
+
+ static const struct cxm_tuner_channels
++bg_cable_channels = {
++ "B/G Cable",
++ CXM_TUNER_TV_SYSTEM_BG,
++ 1,
++ 120,
++ 38900,
++ { { 121, 38900, 0},
++ { 100, 303250, 8000 },
++ { 90, 231250, 7000 },
++ { 80, 105250, 7000 },
++ { 74, 69250, 7000 },
++ { 21, 471250, 8000 },
++ { 17, 183250, 9000 },
++ { 16, 175250, 9000 },
++ { 15, 82250, 8500 },
++ { 13, 53750, 8500 },
++ { 5, 175250, 7000 },
++ { 2, 48250, 7000 } }
++};
++
++static const struct cxm_tuner_channels
+ bg_australia_channels = {
+ "B/G Australia",
+ CXM_TUNER_TV_SYSTEM_BG,
+@@ -316,7 +337,7 @@
+ { 48250, { 0x8e, 0xa0 } } },
+ 0, 0,
+ { 0 },
+- { &bg_air_channels, NULL } },
++ { &bg_cable_channels, NULL } },
+ { "LG Innotek TPI8PSB01N",
+ { CXM_TUNER_TV_SYSTEM_BG, cxm_none_system_code_style },
+ 48250, 855250,
+@@ -325,7 +346,7 @@
+ { 48250, { 0x8e, 0xa0 } } },
+ 87500, 108000,
+ { 87500, { 0x88, 0xa5 } },
+- { &bg_air_channels, NULL } },
++ { &bg_cable_channels, NULL } },
+ { "LG Innotek TAPC-H701F",
+ { CXM_TUNER_TV_SYSTEM_MN, cxm_none_system_code_style },
+ 55250, 801250,