aboutsummaryrefslogtreecommitdiff
path: root/multimedia/py-ffmpeg-python
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-05-06 05:19:49 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-05-06 05:19:49 +0000
commit33a14f6a087d62b9a5ad8503a5eee2367c0da417 (patch)
treebb6c0aa060b3c278a48b13df79781dcec5e94d2b /multimedia/py-ffmpeg-python
parentf5f8fd4b07c810d665e78c93238e5b3f6fd542c8 (diff)
downloadports-33a14f6a087d62b9a5ad8503a5eee2367c0da417.tar.gz
ports-33a14f6a087d62b9a5ad8503a5eee2367c0da417.zip
New port: multimedia/py-ffmpeg-python: Python bindings for FFmpeg - with complex filtering support
Notes
Notes: svn path=/head/; revision=500894
Diffstat (limited to 'multimedia/py-ffmpeg-python')
-rw-r--r--multimedia/py-ffmpeg-python/Makefile23
-rw-r--r--multimedia/py-ffmpeg-python/distinfo3
-rw-r--r--multimedia/py-ffmpeg-python/pkg-descr4
3 files changed, 30 insertions, 0 deletions
diff --git a/multimedia/py-ffmpeg-python/Makefile b/multimedia/py-ffmpeg-python/Makefile
new file mode 100644
index 000000000000..d8174c87fe0a
--- /dev/null
+++ b/multimedia/py-ffmpeg-python/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= ffmpeg-python
+DISTVERSION= 0.1.17
+CATEGORIES= multimedia python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python bindings for FFmpeg - with complex filtering support
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-runner>0:devel/py-pytest-runner@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}future>0:devel/py-future@${PY_FLAVOR} \
+ ffmpeg:multimedia/ffmpeg
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/multimedia/py-ffmpeg-python/distinfo b/multimedia/py-ffmpeg-python/distinfo
new file mode 100644
index 000000000000..15d1d0a1fc3d
--- /dev/null
+++ b/multimedia/py-ffmpeg-python/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1557119362
+SHA256 (ffmpeg-python-0.1.17.tar.gz) = 2f621af3b2e76ed7bf481cc076429802f206c437eb109274dc8b06476bc6c063
+SIZE (ffmpeg-python-0.1.17.tar.gz) = 19699
diff --git a/multimedia/py-ffmpeg-python/pkg-descr b/multimedia/py-ffmpeg-python/pkg-descr
new file mode 100644
index 000000000000..d1a6b9540b36
--- /dev/null
+++ b/multimedia/py-ffmpeg-python/pkg-descr
@@ -0,0 +1,4 @@
+ffmpeg-python works well for simple as well as complex signal graphs, this
+differentiates it from other python ffmpeg wrappers.
+
+WWW: https://github.com/kkroening/ffmpeg-python