aboutsummaryrefslogtreecommitdiff
path: root/multimedia/py-qt5-multimedia
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-11-22 20:18:37 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-11-22 20:18:37 +0000
commitcc8a667aa283dbd1c377aa55dd4b47568cebc6b9 (patch)
tree61cb3664013fb792e76869e17b47783aadc54052 /multimedia/py-qt5-multimedia
parent9ea8c5a60afa67ef2f40c0e73594522c3aec51a6 (diff)
downloadports-cc8a667aa283dbd1c377aa55dd4b47568cebc6b9.tar.gz
ports-cc8a667aa283dbd1c377aa55dd4b47568cebc6b9.zip
pyqt: Change install directories for Python flavor support
* PyQt could not be installed for multiple Python versions at the same time, as there were conflicting files. This patch creates Python-version versioned directories for all these, and further installs binaries with a version number. * Note, there might be some hickups for software that depends on on of the .so's provided by PyQt5, which might not be found anymore autmotically, and maybe need some LD-flaggery. * Update PyQt5 to 5.10.1 * Mark www/py-qt5-webengine broken. It is unforuntately no longer compatible with the old qt5-webengine-5.9.4 we ship. PR: 232745 Exp-run by: antoine Differential Revision: https://reviews.freebsd.org/D8714
Notes
Notes: svn path=/head/; revision=485614
Diffstat (limited to 'multimedia/py-qt5-multimedia')
-rw-r--r--multimedia/py-qt5-multimedia/Makefile5
-rw-r--r--multimedia/py-qt5-multimedia/pkg-plist2
2 files changed, 3 insertions, 4 deletions
diff --git a/multimedia/py-qt5-multimedia/Makefile b/multimedia/py-qt5-multimedia/Makefile
index 28602298f0b0..4106f6107681 100644
--- a/multimedia/py-qt5-multimedia/Makefile
+++ b/multimedia/py-qt5-multimedia/Makefile
@@ -1,7 +1,6 @@
# $FreeBSD$
PORTNAME= multimedia
-PORTREVISION= 5
CATEGORIES= multimedia devel python
MAINTAINER= kde@FreeBSD.org
@@ -13,7 +12,7 @@ PYQT_DIST= yes
USES= python pyqt:5 qt:5
USE_GL= gl
USE_PYQT= sip_build core_run gui_run network_run
-USE_PYTHON= flavors
+USE_PYTHON= concurrent flavors py3kplist
USE_QT= core gui multimedia network qmake_build
OPTIONS_DEFINE= API DEBUG
@@ -21,7 +20,7 @@ OPTIONS_DEFAULT=API
OPTIONS_SUB= yes
API_DESC= Install QtMultimedia API for QScintilla2
-API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${QSCIDIR}
+API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${PYQT_APIDIR}
API_CONFIGURE_OFF= --no-qsci-api
API_LIB_DEPENDS= libqscintilla2_qt5.so:devel/qscintilla2-qt5
DEBUG_CONFIGURE_ON= --debug --trace
diff --git a/multimedia/py-qt5-multimedia/pkg-plist b/multimedia/py-qt5-multimedia/pkg-plist
index bc1739259c0d..7244f284f8c9 100644
--- a/multimedia/py-qt5-multimedia/pkg-plist
+++ b/multimedia/py-qt5-multimedia/pkg-plist
@@ -41,4 +41,4 @@
%%PYQT_SIPDIR%%/QtMultimedia/qvideoframe.sip
%%PYQT_SIPDIR%%/QtMultimedia/qvideoprobe.sip
%%PYQT_SIPDIR%%/QtMultimedia/qvideosurfaceformat.sip
-%%API%%share/qt5/qsci/api/python/QtMultimedia.api
+%%API%%%%PYQT_APIDIR%%/api/python/QtMultimedia.api