aboutsummaryrefslogtreecommitdiff
path: root/multimedia/smpeg2
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-26 00:44:22 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-26 00:48:20 +0000
commit95274bf4f99c71fc056013d966aec239161dfd74 (patch)
treebc1e95977678cb5b6b00b33e333b28161885e706 /multimedia/smpeg2
parentdbe06d2da8c38d9d058f7939a7c6af36a2c0f1c7 (diff)
downloadports-95274bf4f99c71fc056013d966aec239161dfd74.tar.gz
ports-95274bf4f99c71fc056013d966aec239161dfd74.zip
*/*: Fix build with llvm16 on 13.2-STABLE
As like as HEAD(14.0-RELEASE) llvm16 was merged in base for 13.2-STABLE with the OSVERSION 1302507. - Utilize USE_CXXSTD=c++14 or similar solution where applicable - Update conditionals to addtionally check for OSVERSION greater than 1302507 and less than 1400000 Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'multimedia/smpeg2')
-rw-r--r--multimedia/smpeg2/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/multimedia/smpeg2/Makefile b/multimedia/smpeg2/Makefile
index bc3e63ca92c3..bcfb5ee952ad 100644
--- a/multimedia/smpeg2/Makefile
+++ b/multimedia/smpeg2/Makefile
@@ -12,10 +12,11 @@ WWW= https://icculus.org/smpeg/
LICENSE= MIT LGPL20+
LICENSE_COMB= multi
+USES= compiler:features libtool sdl
+
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
CFLAGS+= ${COMPILER_FEATURES:Mc++11:C/.+/-Wno-error=narrowing/}
-USES= compiler:features libtool sdl
USE_SDL= sdl2
USE_LDCONFIG= yes
@@ -31,7 +32,7 @@ PLAYMPEG_VARS= LICENSE+=GPLv2+
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CPPFLAGS+= -Dregister=
.endif