aboutsummaryrefslogtreecommitdiff
path: root/multimedia/toxine
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-05-04 16:47:35 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-05-04 16:47:35 +0000
commita442fe71d52fbcda3cb6bef7db3e7db323900a11 (patch)
tree3d18a8d842526467b59446f3731aa9f5448460a6 /multimedia/toxine
parent2f7ee81807c73ee094f04a06fafb0bbe34ceb09c (diff)
downloadports-a442fe71d52fbcda3cb6bef7db3e7db323900a11.tar.gz
ports-a442fe71d52fbcda3cb6bef7db3e7db323900a11.zip
- Remove USE_REINPLACE.
- Format tabs, put targets at the end. - Remove unavoidable auto-detection of OPTIONS. - Change libxine library version (13 -> 15) in dependency. Approved by: garga (mentor)
Notes
Notes: svn path=/head/; revision=161347
Diffstat (limited to 'multimedia/toxine')
-rw-r--r--multimedia/toxine/Makefile47
1 files changed, 20 insertions, 27 deletions
diff --git a/multimedia/toxine/Makefile b/multimedia/toxine/Makefile
index 4146f010e07e..c2e5733c998b 100644
--- a/multimedia/toxine/Makefile
+++ b/multimedia/toxine/Makefile
@@ -15,10 +15,9 @@ MASTER_SITE_SUBDIR= toxine
MAINTAINER= alepulver@FreeBSD.org
COMMENT= Text user interface using the xine library
-LIB_DEPENDS= xine.13:${PORTSDIR}/multimedia/libxine
+LIB_DEPENDS= xine.15:${PORTSDIR}/multimedia/libxine
USE_X_PREFIX= yes
-USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
@@ -34,7 +33,7 @@ OPTIONS= AALIB "Enable aalib support" on \
.if ${OSVERSION} < 502000
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
-CONFIGURE_ARGS+= --with-readline=${LOCALBASE}
+CONFIGURE_ARGS+=--with-readline=${LOCALBASE}
.endif
.if ${OSVERSION} < 500000
@@ -43,40 +42,34 @@ EXTRA_PATCHES= ${FILESDIR}/extra-patch-main.c
.if !defined(WITHOUT_AALIB)
LIB_DEPENDS+= aa.1:${PORTSDIR}/graphics/aalib
+PLIST_SUB+= AALIB=""
+.else
+PLIST_SUB+= AALIB="@comment "
.endif
.if !defined(WITHOUT_LIBCACA)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libcaca.a:${PORTSDIR}/graphics/libcaca
+PLIST_SUB+= LIBCACA=""
+.else
+PLIST_SUB+= LIBCACA="@comment "
.endif
post-patch:
@${REINPLACE_CMD} -e 's|alsa09|oss|g' ${WRKSRC}/misc/dvdplayer.sh.in
.if defined(WITHOUT_OPTIMIZED_CFLAGS)
@${REINPLACE_CMD} -e 's|-mpreferred-stack-boundary=2||g ; \
- s|-fno-strict-aliasing||g ; \
- s|-fschedule-insns2||g ; \
- s|-mwide-multiply||g ; \
- s|-falign-functions=4||g ; \
- s|-falign-loops=4||g ; \
- s|-falign-jumps=4||g ; \
- s|-fomit-frame-pointer||g ; \
- s|-fexpensive-optimizations||g ; \
- s|-ffast-math||g ; \
- s|-funroll-loops||g ; \
- s|-finline-functions||g' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-.endif
-
-.if defined(WITH_AALIB) || exists(${LOCALBASE}/lib/libaa.a)
-PLIST_SUB+= AALIB=""
-.else
-PLIST_SUB+= AALIB="@comment "
-.endif
-
-.if defined(WITH_LIBCACA) || exists(${LOCALBASE}/lib/libcaca.a)
-PLIST_SUB+= LIBCACA=""
-.else
-PLIST_SUB+= LIBCACA="@comment "
+ s|-fno-strict-aliasing||g ; \
+ s|-fschedule-insns2||g ; \
+ s|-mwide-multiply||g ; \
+ s|-falign-functions=4||g ; \
+ s|-falign-loops=4||g ; \
+ s|-falign-jumps=4||g ; \
+ s|-fomit-frame-pointer||g ; \
+ s|-fexpensive-optimizations||g ; \
+ s|-ffast-math||g ; \
+ s|-funroll-loops||g ; \
+ s|-finline-functions||g' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
.endif
.include <bsd.port.post.mk>