aboutsummaryrefslogtreecommitdiff
path: root/multimedia/transcode
diff options
context:
space:
mode:
authorJohannes Jost Meixner <xmj@FreeBSD.org>2014-11-22 16:23:34 +0000
committerJohannes Jost Meixner <xmj@FreeBSD.org>2014-11-22 16:23:34 +0000
commit4f12f3b1783327d4e833649c63d8e1724bb16588 (patch)
tree69858a5647bf444b8dbaae3a0602f21ce314cc16 /multimedia/transcode
parentd2ddcbb5a0935eab677bbd463a5653e4564b369b (diff)
downloadports-4f12f3b1783327d4e833649c63d8e1724bb16588.tar.gz
ports-4f12f3b1783327d4e833649c63d8e1724bb16588.zip
multimedia/x264: General overhaul
- Split x264 into two ports: the CLI application (x264), and the library (libx264). This will allow x264 to use lavf and friends from ffmpeg for decoding and demuxing while preventing a circular dependency between the two: x264 can depend on ffmpeg, but ffmpeg will depend on libx264 rather than x264. - Add the LAVF option to the CLI port, making the dependency on ffmpeg optional. - Update to 0.142.2455. - Amend fixes to local patches so that they can apply to the new upstream files. - Provide the git revision and other version information to the build environment, allowing the CLI binary to display this information (like the Windows builds). - Remove unsupported build options (X11_OUTPUT). - Ensure that the library and CLI ports each have the appropriate options. - Add notes for future contributors who wish to update the ports. - Bump PORTREVISION for all dependent ports. PR: 187805 Differential Revision: https://reviews.freebsd.org/D1159 Submitted by: Andrew Berg <aberg010@my.hennepintech.edu> Approved by: koobs (maintainer, mentor)
Notes
Notes: svn path=/head/; revision=373073
Diffstat (limited to 'multimedia/transcode')
-rw-r--r--multimedia/transcode/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/multimedia/transcode/Makefile b/multimedia/transcode/Makefile
index 1eac9aafcfeb..ca08e8dfe151 100644
--- a/multimedia/transcode/Makefile
+++ b/multimedia/transcode/Makefile
@@ -3,7 +3,7 @@
PORTNAME= transcode
PORTVERSION= 1.1.7
-PORTREVISION= 18
+PORTREVISION= 19
CATEGORIES= multimedia
MASTER_SITES= http://cdn.bitbucket.org/france/transcode-tcforge/downloads/
@@ -56,7 +56,7 @@ XVID_LIB_DEPENDS= libxvidcore.so:${PORTSDIR}/multimedia/xvid
XVID_CONFIGURE_ENABLE= xvid
XVID_CONFIGURE_ON= --with-xvid-prefix=${LOCALBASE}
-X264_LIB_DEPENDS= libx264.so:${PORTSDIR}/multimedia/x264
+X264_LIB_DEPENDS= libx264.so:${PORTSDIR}/multimedia/libx264
X264_CONFIGURE_ENABLE= x264
OGG_LIB_DEPENDS= libogg.so:${PORTSDIR}/audio/libogg