aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vdr-plugin-remote/files/patch-Makefile
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2023-06-30 21:04:38 +0000
committerRene Ladan <rene@FreeBSD.org>2023-06-30 21:04:56 +0000
commit17899659746e8bd507d6ec08461d7ee324b86da8 (patch)
tree1ec367358bffc7372ccdefcd3f18da5d9b5d2c9f /multimedia/vdr-plugin-remote/files/patch-Makefile
parent139ad9a9e206975e09d9f969fa8e2e462fb24098 (diff)
downloadports-17899659746e8bd507d6ec08461d7ee324b86da8.tar.gz
ports-17899659746e8bd507d6ec08461d7ee324b86da8.zip
cleanup: Remove expired multimedia/vdr ports:
2023-06-30 multimedia/vdr-plugin-osdteletext: Depends on abandoned fork of VDR 2023-06-30 multimedia/vdr-plugin-wirbelscan: Depends on abandoned fork of VDR 2023-06-30 multimedia/vdr-plugin-control: Depends on abandoned fork of VDR 2023-06-30 multimedia/vdr-plugin-markad: Depends on abandoned fork of VDR 2023-06-30 multimedia/vdr-plugin-iptv: Depends on abandoned fork of VDR 2023-06-30 multimedia/vdr-plugin-femon: Depends on abandoned fork of VDR 2023-06-30 multimedia/vdr-plugin-sleeptimer: Depends on abandoned fork of VDR 2023-06-30 multimedia/vdr-plugin-remote: Depends on abandoned fork of VDR 2023-06-30 multimedia/vdr-plugin-infosatepg: Depends on abandoned fork of VDR 2023-06-30 multimedia/vdr-plugin-reelchannelscan: Depends on abandoned fork of VDR 2023-06-30 multimedia/vdr-plugin-extrecmenu: Depends on abandoned fork of VDR 2023-06-30 multimedia/vdr-plugin-vdrmanager: Depends on abandoned fork of VDR 2023-06-30 multimedia/vdr-plugin-vnsiserver: Depends on abandoned fork of VDR 2023-06-30 multimedia/vdr-plugin-xvdr: Depends on abandoned fork of VDR 2023-06-30 multimedia/vdr-plugins: Depends on abandoned fork of VDR 2023-06-30 multimedia/vdr-plugin-eepg: Depends on abandoned fork of VDR 2023-06-30 multimedia/vdr-plugin-xineliboutput: Depends on abandoned fork of VDR 2023-06-30 multimedia/vdr: Abandoned "work in progress" fork in 2015 2023-06-30 multimedia/vdr-plugin-osdpip: Depends on abandoned fork of VDR 2023-06-30 multimedia/vdr-plugin-epgsearch: Depends on abandoned fork of VDR 2023-06-30 multimedia/vdr-plugin-streamdev: Depends on abandoned fork of VDR 2023-06-30 www/vdr-plugin-live: Depends on abandoned fork of VDR 2023-06-30 multimedia/vdr-plugin-skinenigmang: Depends on abandoned fork of VDR 2023-06-30 multimedia/vdr-plugin-ttxtsubs: Depends on abandoned fork of VDR
Diffstat (limited to 'multimedia/vdr-plugin-remote/files/patch-Makefile')
-rw-r--r--multimedia/vdr-plugin-remote/files/patch-Makefile48
1 files changed, 0 insertions, 48 deletions
diff --git a/multimedia/vdr-plugin-remote/files/patch-Makefile b/multimedia/vdr-plugin-remote/files/patch-Makefile
deleted file mode 100644
index 45e0d87e4b88..000000000000
--- a/multimedia/vdr-plugin-remote/files/patch-Makefile
+++ /dev/null
@@ -1,48 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -54,6 +54,12 @@ DEFINES += -D_GNU_SOURCE -DPLUGIN_NAME_I
- DEFINES += -DREMOTE_FEATURE_LIRC
- DEFINES += -DREMOTE_FEATURE_TCPIP
-
-+ifeq ($(OSTYPE),FreeBSD)
-+DEFINES += -DREMOTE_FEATURE_UHID
-+else
-+DEFINES += -DREMOTE_FEATURE_DEVINPUT
-+endif
-+
- ### The object files (add further files here):
-
- OBJS = $(PLUGIN).o ttystatus.o
-@@ -81,9 +87,9 @@ $(DEPFILE): Makefile
-
- ### Internationalization (I18N):
-
--ifneq ($(shell grep 'LOCALEDIR' $(VDRDIR)/Makefile),)
-+#ifneq ($(shell grep 'LOCALEDIR' $(VDRDIR)/Makefile),)
- PODIR = po
- LOCALEDIR = $(VDRDIR)/locale
- I18Npo = $(wildcard $(PODIR)/*.po)
- I18Nmo = $(addsuffix .mo, $(foreach file, $(I18Npo), $(basename $(file))))
- I18Ndirs = $(notdir $(foreach file, $(I18Npo), $(basename $(file))))
-@@ -104,10 +110,10 @@ i18n: $(I18Nmo)
- mkdir -p $(LOCALEDIR)/$$i/LC_MESSAGES;\
- cp $(PODIR)/$$i.mo $(LOCALEDIR)/$$i/LC_MESSAGES/vdr-$(PLUGIN).mo;\
- done
--else
--OBJS += i18n.o
--i18n: ;
--endif
-+#else
-+#OBJS += i18n.o
-+#i18n: ;
-+#endif
-
- ### Targets:
-
-@@ -126,3 +132,6 @@ dist: clean
- clean:
- @-rm -f $(PODIR)/*.mo $(PODIR)/*.pot
- @-rm -f *.o $(DEPFILE) *.so *.tgz core* *~
-+
-+install:
-+ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) ${DESTDIR}$(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)