aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vdr-plugin-remote/files/patch-Makefile
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2012-04-21 14:10:58 +0000
committerJuergen Lock <nox@FreeBSD.org>2012-04-21 14:10:58 +0000
commit21694da2c566eaa9c10c6ef28211ff5dcc64fc0b (patch)
treeaddbbf4b5bdb1599aaa2de3e5468c3e5086cf6ac /multimedia/vdr-plugin-remote/files/patch-Makefile
parent81c24ded0d6dc41a98692d88f643711724fd25c1 (diff)
downloadports-21694da2c566eaa9c10c6ef28211ff5dcc64fc0b.tar.gz
ports-21694da2c566eaa9c10c6ef28211ff5dcc64fc0b.zip
- Update multimedia/vdr and multimedia/vdr-plugins to 1.7.27 .
- Update multimedia/vdr-plugin-epgsearch to 1.0.1s20120322 git snapshot. - Update multimedia/vdr-plugin-femon to 1.7.15 . - Update multimedia/vdr-plugin-iptv to 0.5.0 . - Update multimedia/vdr-plugin-osdteletext to 0.9.2 . - Update multimedia/vdr-plugin-streamdev to 0.5.1p20120311 git snapthot. - Update multimedia/vdr-plugin-xineliboutput to 1.0.90s20111129.1002 cvs snapshot. - Bump PORTREVISION for all other plugins and add vdr 1.7.27 compatibility/bugfix patches where necessary.
Notes
Notes: svn path=/head/; revision=295188
Diffstat (limited to 'multimedia/vdr-plugin-remote/files/patch-Makefile')
-rw-r--r--multimedia/vdr-plugin-remote/files/patch-Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/multimedia/vdr-plugin-remote/files/patch-Makefile b/multimedia/vdr-plugin-remote/files/patch-Makefile
index 40b6fef3d4de..59b7603187c4 100644
--- a/multimedia/vdr-plugin-remote/files/patch-Makefile
+++ b/multimedia/vdr-plugin-remote/files/patch-Makefile
@@ -13,6 +13,32 @@
### The object files (add further files here):
OBJS = $(PLUGIN).o ttystatus.o
+@@ -81,9 +87,9 @@ $(DEPFILE): Makefile
+
+ ### Internationalization (I18N):
+
+-ifneq ($(shell grep 'LOCALEDIR' $(VDRDIR)/Makefile),)
++#ifneq ($(shell grep 'LOCALEDIR' $(VDRDIR)/Makefile),)
+ PODIR = po
+ LOCALEDIR = $(VDRDIR)/locale
+ I18Npo = $(wildcard $(PODIR)/*.po)
+ I18Nmo = $(addsuffix .mo, $(foreach file, $(I18Npo), $(basename $(file))))
+ I18Ndirs = $(notdir $(foreach file, $(I18Npo), $(basename $(file))))
+@@ -104,10 +110,10 @@ i18n: $(I18Nmo)
+ mkdir -p $(LOCALEDIR)/$$i/LC_MESSAGES;\
+ cp $(PODIR)/$$i.mo $(LOCALEDIR)/$$i/LC_MESSAGES/vdr-$(PLUGIN).mo;\
+ done
+-else
+-OBJS += i18n.o
+-i18n: ;
+-endif
++#else
++#OBJS += i18n.o
++#i18n: ;
++#endif
+
+ ### Targets:
+
@@ -126,3 +132,6 @@ dist: clean
clean:
@-rm -f $(PODIR)/*.mo $(PODIR)/*.pot