aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vdr-plugin-upnp
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2012-06-19 18:42:12 +0000
committerJuergen Lock <nox@FreeBSD.org>2012-06-19 18:42:12 +0000
commit06a1a754bf11f8d8bd5f7a48aaca173bf6cef618 (patch)
treec52fc6c0fdf6d98bbdbfaa0ad6db66308f0a2d76 /multimedia/vdr-plugin-upnp
parentd95ff34009ff04c9b302834a93a37e7ff36b1f8e (diff)
downloadports-06a1a754bf11f8d8bd5f7a48aaca173bf6cef618.tar.gz
ports-06a1a754bf11f8d8bd5f7a48aaca173bf6cef618.zip
- Update multimedia/vdr and multimedia/vdr-plugins to 1.7.28 .
- Update xineliboutput XKeySym.Pause key in example remote.conf. ("space" instead of "Space") - Add multimedia/vdr-plugin-extrecmenu 1.2.2 to vdr-plugins metaport. - Update multimedia/vdr-plugin-skinenigmang to 0.1.2s20120606 git snapshot. - Update www/vdr-plugin-live to 0.2.0s20120325 git snapshot. - Bump PORTREVISION for all other plugins and add api fixes where necessary. - Add HISTORY to PORTDOCS for most plugins. (those that have it) - Remove shlib major versions from LIB_DEPENDS to pet portlint.
Notes
Notes: svn path=/head/; revision=299655
Diffstat (limited to 'multimedia/vdr-plugin-upnp')
-rw-r--r--multimedia/vdr-plugin-upnp/Makefile10
-rw-r--r--multimedia/vdr-plugin-upnp/files/patch-receiver-livereceiver.cpp29
2 files changed, 34 insertions, 5 deletions
diff --git a/multimedia/vdr-plugin-upnp/Makefile b/multimedia/vdr-plugin-upnp/Makefile
index 2c8affa33fae..6fe2d6ace091 100644
--- a/multimedia/vdr-plugin-upnp/Makefile
+++ b/multimedia/vdr-plugin-upnp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vdr-plugin-upnp
PORTVERSION= 0.0.2a2
-PORTREVISION= 16
+PORTREVISION= 17
CATEGORIES= multimedia
MASTER_SITES= http://projects.vdr-developer.org/attachments/download/177/
DISTNAME= ${PORTNAME:S/-plugin-/-/}-${DISTVERSIONPREFIX}${DISTVERSION:S/a/-alpha/}${DISTVERSIONSUFFIX}
@@ -16,15 +16,15 @@ EXTRACT_SUFX= .tgz
MAINTAINER= nox@FreeBSD.org
COMMENT= Video Disk Recorder - UPnP/DLNA plugin (alpha!)
-LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg \
+LIB_DEPENDS+= avcodec:${PORTSDIR}/multimedia/ffmpeg \
boost_system:${PORTSDIR}/devel/boost-libs \
- upnp.9:${PORTSDIR}/devel/upnp \
- sqlite3.8:${PORTSDIR}/databases/sqlite3
+ upnp:${PORTSDIR}/devel/upnp \
+ sqlite3:${PORTSDIR}/databases/sqlite3
DIST_SUBDIR= vdr
PATCH_STRIP= -p1
HAVE_CONFIGURE= yes
-PORTDOCS= COPYING README
+PORTDOCS= COPYING README HISTORY
MAKE_JOBS_SAFE= yes
WRKSRC= ${WRKDIR}/${PLUGIN}-${DISTVERSION:S/a2//}
diff --git a/multimedia/vdr-plugin-upnp/files/patch-receiver-livereceiver.cpp b/multimedia/vdr-plugin-upnp/files/patch-receiver-livereceiver.cpp
new file mode 100644
index 000000000000..51fcc7e52a46
--- /dev/null
+++ b/multimedia/vdr-plugin-upnp/files/patch-receiver-livereceiver.cpp
@@ -0,0 +1,29 @@
+--- a/receiver/livereceiver.cpp
++++ b/receiver/livereceiver.cpp
+@@ -31,9 +31,19 @@ cLiveReceiver* cLiveReceiver::newInstanc
+ }
+ }
+
++#if (APIVERSNUM < 10725)
+ cLiveReceiver::cLiveReceiver(cChannel *Channel, cDevice *Device)
+ : cReceiver( Channel->GetChannelID(), 0, Channel->Vpid(), Channel->Apids(), Channel->Dpids(), Channel->Spids()),
+ mDevice(Device), mChannel(Channel){
++#else
++cLiveReceiver::cLiveReceiver(cChannel *Channel, cDevice *Device)
++: cReceiver( Channel, 0),
++ mDevice(Device), mChannel(Channel){
++ AddPid(Channel->Vpid());
++ AddPids(Channel->Apids());
++ AddPids(Channel->Dpids());
++ AddPids(Channel->Spids());
++#endif
+ this->mLiveBuffer = NULL;
+ this->mOutputBuffer = NULL;
+ this->mFrameDetector = NULL;
+@@ -185,4 +195,4 @@ void cLiveReceiver::close(){
+ delete this->mLiveBuffer; this->mLiveBuffer = NULL;
+ this->mFrameDetector = NULL;
+ MESSAGE(VERBOSE_LIVE_TV, "Live receiver closed.");
+-}
+\ No newline at end of file
++}