aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vlc/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2009-02-12 03:48:48 +0000
committerBeech Rintoul <beech@FreeBSD.org>2009-02-12 03:48:48 +0000
commit620d50c654017338550f43def3d878f3f269107a (patch)
tree812f0d7bac44116962965fa4606b6e0f71768727 /multimedia/vlc/Makefile
parent369b4d7b61e91150ff4fb02d84c36183686a55e2 (diff)
downloadports-620d50c654017338550f43def3d878f3f269107a.tar.gz
ports-620d50c654017338550f43def3d878f3f269107a.zip
- Add xulrunner to USE_GECKO within WITH_VLC_MOZILLA_PLUGIN
PR: ports/131541 Submitted by: Naram Qashat <cyberbotx@cyberbotx.com> Approved by: Joseph S. Atkinson <jsatkinson@embarqmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=228097
Diffstat (limited to 'multimedia/vlc/Makefile')
-rw-r--r--multimedia/vlc/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 7241804b564f..ee5cb3ebe160 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -20,7 +20,8 @@ MASTER_SITES= http://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSIO
MAINTAINER= jsa@wickedmachine.net
COMMENT= Multimedia streaming server and player for various audio/video formats
-BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev.h:${PORTSDIR}/multimedia/v4l_compat
+BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev.h:${PORTSDIR}/multimedia/v4l_compat \
+ ${LOCALBASE}/include/X11/xpm.h:${PORTSDIR}/x11/libXpm
LIB_DEPENDS= tar.0:${PORTSDIR}/devel/libtar \
avcodec.1:${PORTSDIR}/multimedia/ffmpeg
RUN_DEPENDS= ${LOCALBASE}/lib/X11/fonts/bitstream-vera/Vera.ttf:${PORTSDIR}/x11-fonts/bitstream-vera
@@ -390,7 +391,7 @@ CONFIGURE_ARGS+=--disable-a52
.endif
.if defined(WITH_VLC_MOZILLA_PLUGIN) && !defined(WITHOUT_VLC_MOZILLA_PLUGIN)
-USE_GECKO= firefox mozilla seamonkey nvu
+USE_GECKO= firefox xulrunner seamonkey
USE_WEBPLUGINS= gecko*
WEBPLUGINS_FILES=libvlcplugin.so
.include "${PORTSDIR}/www/firefox/Makefile.webplugins"