aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vlc
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2018-01-01 10:28:51 +0000
committerThomas Zander <riggs@FreeBSD.org>2018-01-01 10:28:51 +0000
commit0d12232d883b4fce64c18e0f371f9919253ca1b5 (patch)
treebfaeced4a8d72f1dfe3290ad679c8d8be6c02237 /multimedia/vlc
parent352af737c0f7add6e1969a5c57ae590396d78c4c (diff)
downloadports-0d12232d883b4fce64c18e0f371f9919253ca1b5.tar.gz
ports-0d12232d883b4fce64c18e0f371f9919253ca1b5.zip
Update to upstream version 2.2.8
Additional details: - Update FFmpeg version required to 3.4.1,1 - Clean some unrecognized options - Fix build with net/freerdp and audio/libsidplay2 - Drop DIRAC option because the module was removed upstream (dirac codec is still supported via schroedinger) PR: 224660 Submitted by: cpm
Notes
Notes: svn path=/head/; revision=457763
Diffstat (limited to 'multimedia/vlc')
-rw-r--r--multimedia/vlc/Makefile50
-rw-r--r--multimedia/vlc/distinfo6
-rw-r--r--multimedia/vlc/files/patch-modules_access_rdp.c118
-rw-r--r--multimedia/vlc/pkg-descr2
-rw-r--r--multimedia/vlc/pkg-plist4
5 files changed, 146 insertions, 34 deletions
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index b6a243f81cbe..01c5c3a67a00 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= vlc
-DISTVERSION= 2.2.6
-PORTREVISION= 5
+DISTVERSION= 2.2.8
PORTEPOCH= 4
CATEGORIES= multimedia audio ipv6 net www
MASTER_SITES= http://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION:S/a$//}/ \
@@ -20,9 +19,9 @@ LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libidn.so:dns/libidn
-BUILD_DEPENDS= ffmpeg>=2.0:multimedia/ffmpeg \
+BUILD_DEPENDS= ffmpeg>=3.4.1,1:multimedia/ffmpeg \
yasm:devel/yasm
-RUN_DEPENDS= ffmpeg>=2.0:multimedia/ffmpeg
+RUN_DEPENDS= ffmpeg>=3.4.1,1:multimedia/ffmpeg
# VLC git (post 2.2.4) requires C++11 support and passes the appropriate flag
# to the compiler. Until the port is updated, we explicitly pass -std=c++11 to
@@ -45,10 +44,10 @@ CONFIGURE_ARGS= --enable-avcodec --enable-avformat --enable-dvbpsi \
--enable-swscale --enable-vlc \
--disable-alsa --disable-chromaprint --disable-crystalhd \
--disable-dc1394 --disable-decklink --disable-directfb \
- --disable-dv1394 --disable-egl --disable-fdkaac \
+ --disable-dv1394 --disable-fdkaac \
--disable-gles1 --disable-gles2 --disable-kai --disable-kva \
- --disable-libvnc --disable-opencv --disable-projectm \
- --disable-quicksync --disable-telx \
+ --disable-vnc --disable-opencv --disable-projectm \
+ --disable-telx \
--disable-tiger --disable-tremor --disable-udev \
--disable-update-check --disable-vcdx --disable-vsxu \
--disable-wasapi --disable-x26410b \
@@ -61,15 +60,14 @@ CPPFLAGS+= -I${LOCALBASE}/include
CFLAGS_i386= -fomit-frame-pointer
LIBS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= A52 AALIB ASS AVAHI CACA DBUS DCA DIRAC DOCS DVDREAD \
- DVDNAV FAAD FLAC FLUID FRIBIDI GME GNOMEVFS2 GNUTLS \
+OPTIONS_DEFINE= A52 AALIB ASS AVAHI CACA DBUS DCA DOCS DVDREAD \
+ DVDNAV FAAD FLAC FLUID FREERDP FRIBIDI GME GNOMEVFS2 GNUTLS \
GOOM HTTPD JACK KATE LIBBLURAY LIBRSVG2 LIBSSH2 LIRC \
- LIVEMEDIA LUA MAD MATROSKA MODPLUG \
- MPEG2 MTP MUSEPACK NCURSES NLS NOTIFY OGG OPTIMIZED_CFLAGS \
- OPUS PNG PULSEAUDIO QT4 QT5 REALRTSP RUNROOT SAMPLERATE \
- SCHROEDINGER SDL SHOUTCAST SKINS SMB SNDIO STREAM SPEEX \
- TAGLIB THEORA TWOLAME UPNP V4L VAAPI VCD VDPAU VORBIS \
- X11 X264 X265 ZVBI
+ LIVEMEDIA LUA MAD MATROSKA MODPLUG MPEG2 MTP MUSEPACK \
+ NCURSES NLS NOTIFY OGG OPTIMIZED_CFLAGS OPUS PNG PULSEAUDIO \
+ QT4 QT5 REALRTSP RUNROOT SAMPLERATE SIDPLAY SCHROEDINGER \
+ SDL SHOUTCAST SKINS SMB SNDIO STREAM SPEEX TAGLIB THEORA \
+ TWOLAME UPNP V4L VAAPI VCD VDPAU VORBIS X11 X264 X265 ZVBI
OPTIONS_DEFAULT=A52 AVAHI DBUS DCA DVDREAD DVDNAV FAAD FLAC GNUTLS \
HTTPD LIVEMEDIA LUA MAD MATROSKA MPEG2 OGG OPTIMIZED_CFLAGS \
OPUS PNG QT5 SAMPLERATE STREAM SPEEX TAGLIB THEORA TWOLAME V4L \
@@ -116,9 +114,6 @@ DBUS_CONFIGURE_ENABLE= dbus
DCA_LIB_DEPENDS= libdca.so:multimedia/libdca
DCA_CONFIGURE_ENABLE= dca
-DIRAC_LIB_DEPENDS= libdirac_decoder.so:multimedia/dirac
-DIRAC_CONFIGURE_ENABLE= dirac
-
DVDREAD_LIB_DEPENDS= libdvdread.so:multimedia/libdvdread
DVDREAD_CONFIGURE_ENABLE= dvdread
@@ -136,10 +131,11 @@ FLAC_CONFIGURE_ENABLE= flac
FLUID_LIB_DEPENDS= libfluidsynth.so:audio/fluidsynth
FLUID_CONFIGURE_ENABLE= fluidsynth
-# XXX vlc doesn't seem to like the freerdp version in ports
-#FREERDP_LIB_DEPENDS= libfreerdp-core.so:net/freerdp
-#FREERDP_CONFIGURE_ENABLE= libfreerdp
-CONFIGURE_ARGS+= -disable-freerdp
+FREERDP_LIB_DEPENDS= libfreerdp2.so:net/freerdp
+FREERDP_CONFIGURE_ENABLE= freerdp
+FREERDP_CONFIGURE_ENV= FREERDP_CFLAGS="-I${LOCALBASE}/include/freerdp2 \
+ -I${LOCALBASE}/include/winpr2" \
+ FREERDP_LIBS="-L${LOCALBASE}/lib"
FRIBIDI_LIB_DEPENDS= libfribidi.so:converters/fribidi
FRIBIDI_CONFIGURE_ENABLE= fribidi
@@ -261,11 +257,9 @@ SCHROEDINGER_CONFIGURE_ENABLE= schroedinger
SDL_USE= SDL=image
SDL_CONFIGURE_ENABLE= sdl sdl-image
-# libsidplay build broken with:
-# /usr/bin/ld: /usr/local/lib/sidplay/builders/libresid-builder.a(resid-builder.o): relocation R_X86_64_32S against `_ZTV12ReSIDBuilder' can not be used when making a shared object; recompile with -fPIC
-#SIDPLAY_LIB_DEPENDS= libsidplay2.so:audio/libsidplay2
-#SIDPLAY_LDFLAGS= -L${LOCALBASE}/lib/sidplay/builders
-#SIDPLAY_CONFIGURE_ENABLE= sid
+SIDPLAY_LIB_DEPENDS= libsidplay2.so:audio/libsidplay2
+SIDPLAY_LDFLAGS= -L${LOCALBASE}/lib/sidplay/builders
+SIDPLAY_CONFIGURE_ENABLE= sid
CONFIGURE_ARGS+= --disable-sid
SHOUTCAST_LIB_DEPENDS= libshout.so:audio/libshout
@@ -312,7 +306,7 @@ VORBIS_CONFIGURE_ENABLE=vorbis
X11_USE= GL=gl XORG=xcb,xproto
X11_LIB_DEPENDS= libxcb-keysyms.so:x11/xcb-util-keysyms
-X11_CONFIGURE_ENABLE= glx xcb xvideo
+X11_CONFIGURE_ENABLE= xcb xvideo
X11_CONFIGURE_WITH= x
X264_LIB_DEPENDS= libx264.so:multimedia/libx264
diff --git a/multimedia/vlc/distinfo b/multimedia/vlc/distinfo
index 357ed075279c..35a059fb8365 100644
--- a/multimedia/vlc/distinfo
+++ b/multimedia/vlc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1495777516
-SHA256 (vlc-2.2.6.tar.xz) = c403d3accd9a400eb2181c958f3e7bc5524fe5738425f4253d42883b425a42a8
-SIZE (vlc-2.2.6.tar.xz) = 22198720
+TIMESTAMP = 1514481430
+SHA256 (vlc-2.2.8.tar.xz) = 9bf046848fb56d93518881b39099b8288ee005d5ba0ddf705b6f6643b8d562ec
+SIZE (vlc-2.2.8.tar.xz) = 22137276
diff --git a/multimedia/vlc/files/patch-modules_access_rdp.c b/multimedia/vlc/files/patch-modules_access_rdp.c
new file mode 100644
index 000000000000..3f56335f8db5
--- /dev/null
+++ b/multimedia/vlc/files/patch-modules_access_rdp.c
@@ -0,0 +1,118 @@
+--- modules/access/rdp.c.orig 2016-07-22 12:10:45 UTC
++++ modules/access/rdp.c
+@@ -45,18 +45,6 @@
+ # include <freerdp/version.h>
+ #endif
+
+-#if !defined(FREERDP_VERSION_MAJOR) || \
+- (defined(FREERDP_VERSION_MAJOR) && !(FREERDP_VERSION_MAJOR > 1 || (FREERDP_VERSION_MAJOR == 1 && FREERDP_VERSION_MINOR >= 1)))
+-# define SoftwareGdi sw_gdi
+-# define Fullscreen fullscreen
+-# define ServerHostname hostname
+-# define Username username
+-# define Password password
+-# define ServerPort port
+-# define EncryptionMethods encryption
+-# define ContextSize context_size
+-#endif
+-
+ #include <errno.h>
+ #ifdef HAVE_POLL
+ # include <poll.h>
+@@ -140,6 +128,7 @@ static void desktopResizeHandler( rdpCon
+ vlcrdp_context_t * p_vlccontext = (vlcrdp_context_t *) p_context;
+ demux_sys_t *p_sys = p_vlccontext->p_demux->p_sys;
+ rdpGdi *p_gdi = p_context->gdi;
++ unsigned bytesPerPixel;
+
+ if ( p_sys->es )
+ {
+@@ -149,17 +138,21 @@ static void desktopResizeHandler( rdpCon
+
+ /* Now init and fill es format */
+ vlc_fourcc_t i_chroma;
+- switch( p_gdi->bytesPerPixel )
++ switch( p_gdi->dstFormat )
+ {
+ default:
+- case 16:
++ msg_Dbg( p_vlccontext->p_demux, "unhandled dstFormat %x bpp", p_gdi->dstFormat );
++ case PIXEL_FORMAT_BGR16:
+ i_chroma = VLC_CODEC_RGB16;
++ bytesPerPixel = 16;
+ break;
+- case 24:
++ case PIXEL_FORMAT_BGR24:
+ i_chroma = VLC_CODEC_RGB24;
++ bytesPerPixel = 24;
+ break;
+- case 32:
++ case PIXEL_FORMAT_BGRA32:
+ i_chroma = VLC_CODEC_RGB32;
++ bytesPerPixel = 32;
+ break;
+ }
+ es_format_t fmt;
+@@ -172,7 +165,7 @@ static void desktopResizeHandler( rdpCon
+ fmt.video.i_height = p_gdi->height;
+ fmt.video.i_frame_rate_base = 1000;
+ fmt.video.i_frame_rate = 1000 * p_sys->f_fps;
+- p_sys->i_framebuffersize = p_gdi->width * p_gdi->height * p_gdi->bytesPerPixel;
++ p_sys->i_framebuffersize = p_gdi->width * p_gdi->height * bytesPerPixel;
+
+ if ( p_sys->p_block )
+ p_sys->p_block = block_Realloc( p_sys->p_block, 0, p_sys->i_framebuffersize );
+@@ -233,28 +226,19 @@ static bool postConnectHandler( freerdp
+ vlcrdp_context_t * p_vlccontext = (vlcrdp_context_t *) p_instance->context;
+
+ msg_Dbg( p_vlccontext->p_demux, "connected to desktop %dx%d (%d bpp)",
+-#if defined(FREERDP_VERSION_MAJOR) && (FREERDP_VERSION_MAJOR > 1 || (FREERDP_VERSION_MAJOR == 1 && FREERDP_VERSION_MINOR >= 1))
+ p_instance->settings->DesktopWidth,
+ p_instance->settings->DesktopHeight,
+ p_instance->settings->ColorDepth
+-#else
+- p_instance->settings->width,
+- p_instance->settings->height,
+- p_instance->settings->color_depth
+-#endif
+ );
+
+ p_instance->update->DesktopResize = desktopResizeHandler;
+ p_instance->update->BeginPaint = beginPaintHandler;
+ p_instance->update->EndPaint = endPaintHandler;
+
+- gdi_init( p_instance,
+- CLRBUF_16BPP |
+-#if defined(FREERDP_VERSION_MAJOR) && defined(FREERDP_VERSION_MINOR) && \
+- !(FREERDP_VERSION_MAJOR > 1 || (FREERDP_VERSION_MAJOR == 1 && FREERDP_VERSION_MINOR >= 2))
+- CLRBUF_24BPP |
+-#endif
+- CLRBUF_32BPP, NULL );
++ if ( p_instance->settings->ColorDepth > 16 )
++ gdi_init( p_instance, PIXEL_FORMAT_XRGB32);
++ else
++ gdi_init( p_instance, PIXEL_FORMAT_RGB16);
+
+ desktopResizeHandler( p_instance->context );
+ return true;
+@@ -428,10 +412,6 @@ static int Open( vlc_object_t *p_this )
+ if ( p_sys->f_fps <= 0 ) p_sys->f_fps = 1.0;
+ p_sys->i_frame_interval = 1000000 / p_sys->f_fps;
+
+-#if FREERDP_VERSION_MAJOR == 1 && FREERDP_VERSION_MINOR < 2
+- freerdp_channels_global_init();
+-#endif
+-
+ p_sys->p_instance = freerdp_new();
+ if ( !p_sys->p_instance )
+ {
+@@ -506,9 +486,6 @@ static void Close( vlc_object_t *p_this
+
+ freerdp_disconnect( p_sys->p_instance );
+ freerdp_free( p_sys->p_instance );
+-#if FREERDP_VERSION_MAJOR == 1 && FREERDP_VERSION_MINOR < 2
+- freerdp_channels_global_uninit();
+-#endif
+
+ if ( p_sys->p_block )
+ block_Release( p_sys->p_block );
diff --git a/multimedia/vlc/pkg-descr b/multimedia/vlc/pkg-descr
index 4ed82567bd40..cef0b7066075 100644
--- a/multimedia/vlc/pkg-descr
+++ b/multimedia/vlc/pkg-descr
@@ -5,4 +5,4 @@ can also be used as a server to stream in unicast or multicast in
IPv4 or IPv6 on a high-bandwidth network. VLC also has the ability
to transcode media on-the-fly for streaming or saving to disk.
-WWW: http://www.videolan.org/
+WWW: https://www.videolan.org
diff --git a/multimedia/vlc/pkg-plist b/multimedia/vlc/pkg-plist
index f22fd7c5cb58..bc62db0e0b65 100644
--- a/multimedia/vlc/pkg-plist
+++ b/multimedia/vlc/pkg-plist
@@ -96,10 +96,10 @@ include/vlc/plugins/vlc_xml.h
include/vlc/vlc.h
lib/libvlc.so
lib/libvlc.so.5
-lib/libvlc.so.5.5.0
+lib/libvlc.so.5.5.1
lib/libvlccore.so
lib/libvlccore.so.8
-lib/libvlccore.so.8.0.0
+lib/libvlccore.so.8.0.1
libdata/pkgconfig/libvlc.pc
libdata/pkgconfig/vlc-plugin.pc
man/man1/vlc-wrapper.1.gz