aboutsummaryrefslogtreecommitdiff
path: root/multimedia/w_scan/Makefile
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2011-12-03 17:12:29 +0000
committerJuergen Lock <nox@FreeBSD.org>2011-12-03 17:12:29 +0000
commit556f752a1033e50d4d369ec6488790d939fb622b (patch)
treef32317f9a4ee2face2a4dea3fc1c9e8b2429aca0 /multimedia/w_scan/Makefile
parent75db61c2225e34d8e728a1553735779d12612198 (diff)
downloadports-556f752a1033e50d4d369ec6488790d939fb622b.tar.gz
ports-556f752a1033e50d4d369ec6488790d939fb622b.zip
- Update to 20111203 .
- Add knob to install the Linux version too (needs multimedia/linux_dvbwrapper-kmod kldload'ed to run.) - Add workaround to avoid invalid UTF-8 encodings when converting from ISO_6937-2 (that the iconv used on FreeBSD doesn't know) - if you need ISO_6937-2 converted properly you have to use the Linux version for now. (Tho all the 8-bit channel names I see here marked as the default ISO_6937-2 charset are in fact ISO8859-1(5) i.e. the charset isn't marked properly on those transponders and thus the Linux version would convert them wrongly too.) Feature safe: yes
Notes
Notes: svn path=/head/; revision=286811
Diffstat (limited to 'multimedia/w_scan/Makefile')
-rw-r--r--multimedia/w_scan/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/multimedia/w_scan/Makefile b/multimedia/w_scan/Makefile
index e131bb6802ab..37874767516b 100644
--- a/multimedia/w_scan/Makefile
+++ b/multimedia/w_scan/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= w_scan
-PORTVERSION= 20111011
+PORTVERSION= 20111203
CATEGORIES= multimedia
MASTER_SITES= http://wirbel.htpc-forum.de/w_scan/
@@ -15,6 +15,10 @@ COMMENT= Perform frequency scans for DVB and ATSC transmissions
BUILD_DEPENDS= ${LOCALBASE}/include/linux/dvb/frontend.h:${PORTSDIR}/multimedia/v4l_compat
+OPTIONS= LINUX "Install Linux binary too (linux-w_scan)" off
+
+.include <bsd.port.options.mk>
+
USE_BZIP2= yes
GNU_CONFIGURE= yes
PATCH_STRIP= -p1
@@ -26,13 +30,23 @@ PLIST_FILES= bin/${PORTNAME}
MAN1= w_scan.1
MAKE_JOBS_SAFE= yes
+.if defined(WITH_LINUX)
+USE_LINUX= yes
+RUN_DEPENDS+= linux_dvbwrapper-kmod>=1.0:${PORTSDIR}/multimedia/linux_dvbwrapper-kmod
+PLIST_FILES+= bin/linux-${PORTNAME}
+.endif
+
post-patch:
${REINPLACE_CMD} -f ${FILESDIR}/types.sed ${WRKSRC}/configure ${WRKSRC}/*.c ${WRKSRC}/*.h
+ ${CP} ${WRKSRC}/${PORTNAME} ${WRKSRC}/linux-${PORTNAME}
-.if !defined(NOPORTDOCS)
post-install:
+.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
.endif
+.if defined(WITH_LINUX)
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} linux-${PORTNAME} ${PREFIX}/bin)
+.endif
.include <bsd.port.mk>