aboutsummaryrefslogtreecommitdiff
path: root/multimedia/x265
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-02-29 15:53:56 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-02-29 15:53:56 +0000
commit386621d73ef9088f46bf9176c9956723599d97a1 (patch)
tree7e45d3d9579ba23224c5dc054f9f666257a2b79f /multimedia/x265
parent6f40ea84e56065f0c9d3f8888def5616741e2bf8 (diff)
downloadports-386621d73ef9088f46bf9176c9956723599d97a1.tar.gz
ports-386621d73ef9088f46bf9176c9956723599d97a1.zip
multimedia/vmaf: update to 1.5.1
Changes: https://github.com/Netflix/vmaf/releases/tag/v1.5.1 Reported by: GitHub (watch releases)
Notes
Notes: svn path=/head/; revision=527426
Diffstat (limited to 'multimedia/x265')
-rw-r--r--multimedia/x265/Makefile4
-rw-r--r--multimedia/x265/files/patch-source_encoder_api.cpp17
2 files changed, 19 insertions, 2 deletions
diff --git a/multimedia/x265/Makefile b/multimedia/x265/Makefile
index 5281b7a2004e..3508f4e07053 100644
--- a/multimedia/x265/Makefile
+++ b/multimedia/x265/Makefile
@@ -3,7 +3,7 @@
PORTNAME= x265
PORTVERSION= 3.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
MASTER_SITES= https://bitbucket.org/multicoreware/x265/downloads/ \
https://downloads.videolan.org/pub/videolan/x265/ \
@@ -39,7 +39,7 @@ OPTIMIZED_FLAGS_VARS= CFLAGS+=-O3
SVTHEVC_LIB_DEPENDS= libSvtHevcEnc.so:multimedia/svt-hevc
SVTHEVC_CMAKE_BOOL= ENABLE_SVT_HEVC
SVTHEVC_CMAKE_ON= -DSVT_HEVC_INCLUDE_DIR:PATH="${LOCALBASE}/include/svt-hevc"
-VMAF_BUILD_DEPENDS= ${LOCALBASE}/lib/libvmaf.a:multimedia/vmaf
+VMAF_LIB_DEPENDS= libvmaf.so:multimedia/vmaf
VMAF_USES= localbase:ldflags
VMAF_CMAKE_BOOL= ENABLE_LIBVMAF
diff --git a/multimedia/x265/files/patch-source_encoder_api.cpp b/multimedia/x265/files/patch-source_encoder_api.cpp
new file mode 100644
index 000000000000..c28fc32b6445
--- /dev/null
+++ b/multimedia/x265/files/patch-source_encoder_api.cpp
@@ -0,0 +1,17 @@
+Chase https://github.com/Netflix/vmaf/commit/82a86e040371
+
+source/encoder/api.cpp:36:10: fatal error: 'libvmaf.h' file not found
+#include "libvmaf.h"
+ ^~~~~~~~~~~
+
+--- source/encoder/api.cpp.orig 2019-10-29 11:55:05 UTC
++++ source/encoder/api.cpp
+@@ -33,7 +33,7 @@
+ #include "svt.h"
+
+ #if ENABLE_LIBVMAF
+-#include "libvmaf.h"
++#include "libvmaf/libvmaf.h"
+ #endif
+
+ /* multilib namespace reflectors */