aboutsummaryrefslogtreecommitdiff
path: root/multimedia/x265
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2018-08-05 22:15:03 +0000
committerMikhail Teterin <mi@FreeBSD.org>2018-08-05 22:15:03 +0000
commit79a7acbee06c4e0acd961dcba2ae65100da42547 (patch)
tree95c1a3b0c2f8dc5b9043d23fae9428c545d37e98 /multimedia/x265
parent5eb5b0b9f0d095cb74a89a7caf5649dfc99c69f9 (diff)
downloadports-79a7acbee06c4e0acd961dcba2ae65100da42547.tar.gz
ports-79a7acbee06c4e0acd961dcba2ae65100da42547.zip
Fix the underlying problem in the code, which previously
required disabling AVX as a work-around: PR: 229788 Submitted by: dim@ Also, switch the build-dependency from yasm to nasm -- upstream made the switch in version 2.6 Reported by: Callum Aitchison Bump PORTREVISION...
Notes
Notes: svn path=/head/; revision=476480
Diffstat (limited to 'multimedia/x265')
-rw-r--r--multimedia/x265/Makefile3
-rw-r--r--multimedia/x265/files/patch-bug-42213
-rw-r--r--multimedia/x265/files/patch-disable-avx-for-clang13
3 files changed, 15 insertions, 14 deletions
diff --git a/multimedia/x265/Makefile b/multimedia/x265/Makefile
index 0c9e3dc3dca3..8d50a04f736b 100644
--- a/multimedia/x265/Makefile
+++ b/multimedia/x265/Makefile
@@ -3,6 +3,7 @@
PORTNAME= x265
PORTVERSION= 2.8
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= https://downloads.videolan.org/pub/videolan/x265/ \
https://mirror.leaseweb.com/videolan/x265/ \
@@ -19,7 +20,7 @@ COMMENT= H.265/High Efficiency Video Coding (HEVC) format
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC:H}/COPYING
-BUILD_DEPENDS= yasm:devel/yasm
+BUILD_DEPENDS= nasm:devel/nasm
USES= cmake compiler:c++14-lang pathfix
diff --git a/multimedia/x265/files/patch-bug-422 b/multimedia/x265/files/patch-bug-422
new file mode 100644
index 000000000000..b26f06db7be1
--- /dev/null
+++ b/multimedia/x265/files/patch-bug-422
@@ -0,0 +1,13 @@
+See:
+
+ https://bitbucket.org/multicoreware/x265/issues/422
+
+--- common/pixel.cpp 2018-05-21 08:33:10 UTC
++++ common/pixel.cpp 2018-08-05 21:57:26 UTC
+@@ -923,5 +923,5 @@
+ {
+ for (int i = 0; i < count; i++)
+- dst[i] = (uint16_t)(src[i] * 256.0);
++ dst[i] = (int16_t)(src[i] * 256.0);
+ }
+
diff --git a/multimedia/x265/files/patch-disable-avx-for-clang b/multimedia/x265/files/patch-disable-avx-for-clang
deleted file mode 100644
index e09495d6a5ea..000000000000
--- a/multimedia/x265/files/patch-disable-avx-for-clang
+++ /dev/null
@@ -1,13 +0,0 @@
-See:
-
- https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=229788
- https://bitbucket.org/multicoreware/x265/issues/422/when-using-clang-with-avx-enabled
-
---- CMakeLists.txt 2018-05-21 04:33:10.000000000 -0400
-+++ CMakeLists.txt 2018-07-17 12:51:05.820330000 -0400
-@@ -133,4 +133,5 @@
- if(${CMAKE_CXX_COMPILER_ID} STREQUAL "Clang")
- set(CLANG 1)
-+ add_definitions("-mno-avx")
- endif()
- if(${CMAKE_CXX_COMPILER_ID} STREQUAL "Intel")