aboutsummaryrefslogtreecommitdiff
path: root/multimedia/xfce4-parole/Makefile
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2019-01-22 14:44:38 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2019-01-22 14:44:38 +0000
commit41ff4e536e680bc94d0949bc7708ddfe6f5646a7 (patch)
tree0b87a1825693d30844e1b681ab080746ab147896 /multimedia/xfce4-parole/Makefile
parentec5f7eb8bb72b6cf44e7b35905514df560d5f22b (diff)
downloadports-41ff4e536e680bc94d0949bc7708ddfe6f5646a7.tar.gz
ports-41ff4e536e680bc94d0949bc7708ddfe6f5646a7.zip
Clenup xfce ports:
- Add missing dependencies - Remove unneeded patches - Regenerate and rename legacy patches - Add NLS option to ports providing such a knob, and missing the option - Add INSTALL_TARGET=install-strip where missing - Sort things - Remove unneeded += - Cosmetic changes to OPTION related variables to improve readability - Update WWW - Silence portlint warnings about variables order - Bump PORTREVISION where changing dependencies and/or adding install-strip
Notes
Notes: svn path=/head/; revision=490953
Diffstat (limited to 'multimedia/xfce4-parole/Makefile')
-rw-r--r--multimedia/xfce4-parole/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/multimedia/xfce4-parole/Makefile b/multimedia/xfce4-parole/Makefile
index cd468fbb0791..749915f46353 100644
--- a/multimedia/xfce4-parole/Makefile
+++ b/multimedia/xfce4-parole/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= xdg-screensaver:devel/xdg-utils
USES= compiler:c++11-lang desktop-file-utils gettext-tools \
gmake gnome libtool pkgconfig tar:bzip2 xfce:gtk3
-USE_GNOME= cairo gtk30 glib20 intltool intlhack
+USE_GNOME= cairo gtk30 glib20 intlhack intltool
USE_GSTREAMER1= core faad flac wavpack rtmp x
USE_XFCE= panel
USE_XORG= ice sm x11
@@ -43,9 +43,12 @@ OPTIONS_DEFAULT= HTTP
OPTIONS_SUB= yes
CDDA_USE= gstreamer1=cdparanoia
+
GST_PLUG_DESC= Additional GStreamer plugins
+
HTTP_DESC= HTTP streaming (libsoup)
HTTP_USE= gstreamer1=soup
+
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext-runtime