aboutsummaryrefslogtreecommitdiff
path: root/multimedia/xfce4-parole/Makefile
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2015-10-15 18:22:02 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2015-10-15 18:22:02 +0000
commitac6035e8676070e396d1d4b85958cbe2252def7c (patch)
treefc2c8a30ae937ad9efd57ff5cf0c37d1306291ed /multimedia/xfce4-parole/Makefile
parentf4e079e88482065eefc8b2e247284e4adea54dc7 (diff)
downloadports-ac6035e8676070e396d1d4b85958cbe2252def7c.tar.gz
ports-ac6035e8676070e396d1d4b85958cbe2252def7c.zip
- Update to 0.8.1 (bugfix release)
- Sort USES - Adjust dependencies (remove symbolic theme, because Adwaita already contains symbolic icons) Changelog: http://git.xfce.org/apps/parole/tree/src/parole-conf.c?id=parole-0.8.1
Notes
Notes: svn path=/head/; revision=399356
Diffstat (limited to 'multimedia/xfce4-parole/Makefile')
-rw-r--r--multimedia/xfce4-parole/Makefile32
1 files changed, 11 insertions, 21 deletions
diff --git a/multimedia/xfce4-parole/Makefile b/multimedia/xfce4-parole/Makefile
index c31a92033177..777c6eb6a327 100644
--- a/multimedia/xfce4-parole/Makefile
+++ b/multimedia/xfce4-parole/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= parole
-PORTVERSION= 0.8.0
+PORTVERSION= 0.8.1
CATEGORIES= multimedia xfce
MASTER_SITES= XFCE/src/apps/${PORTNAME}/${PORTVERSION:R}/
DIST_SUBDIR= xfce4
@@ -16,7 +16,6 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libtag.so:${PORTSDIR}/audio/taglib \
libnotify.so:${PORTSDIR}/devel/libnotify \
libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
-RUN_DEPENDS= gnome-icon-theme-symbolic>=3.6:${PORTSDIR}/x11-themes/gnome-icon-theme-symbolic
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
@@ -29,8 +28,9 @@ USE_GNOME= gtk30 glib20 intltool intlhack
USE_XFCE= panel
USE_XORG= x11 sm
USE_LDCONFIG= yes
-USES= desktop-file-utils pkgconfig gmake libtool gettext-tools \
- xfce:gtk3 tar:bzip2
+USES= desktop-file-utils gettext-tools gmake libtool pkgconfig \
+ tar:bzip2 xfce:gtk3
+INSTALL_TARGET= install-strip
OPTIONS_DEFINE= CLUTTER NLS
OPTIONS_SINGLE= GSTREAMER
@@ -40,11 +40,18 @@ OPTIONS_GROUP= GST_PLUG
OPTIONS_GROUP_GST_PLUG= CDDA HTTP
# Since 0.5.91 release, GStreamer 1.0 is enabled by default
OPTIONS_DEFAULT= GST10 HTTP NLS
+CLUTTER_LIB_DEPENDS= libclutter-gst-2.0.so:${PORTSDIR}/multimedia/clutter-gst \
+ libclutter-gtk-1.0.so:${PORTSDIR}/graphics/clutter-gtk3
+CLUTTER_IMPLIES= GST10
+CLUTTER_CONFIGURE_ENABLE= clutter
+NLS_USES= gettext-runtime
+NLS_CONFIGURE_ENABLE= nls
HTTP_DESC= HTTP streaming (libsoup)
GST01_DESC= GStreamer 0.10
GST10_DESC= GStreamer 1.0
GST_PLUG_DESC= Additional GStreamer plugins
CLUTTER_DESC= Clutter (OpenGL) backend
+OPTIONS_SUB= yes
.include <bsd.port.options.mk>
@@ -76,23 +83,6 @@ USE_GSTREAMER1+= soup
.endif
.endif
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext-runtime
-CONFIGURE_ARGS+= --enable-nls
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MCLUTTER} && ${PORT_OPTIONS:MGST10}
-LIB_DEPENDS+= libclutter-gst-2.0.so:${PORTSDIR}/multimedia/clutter-gst \
- libclutter-gtk-1.0.so:${PORTSDIR}/graphics/clutter-gtk3
-CONFIGURE_ARGS+=--enable-clutter
-.else
-CONFIGURE_ARGS+=--disable-clutter
-.endif
-
post-patch:
# Fix .rc files path
@${REINPLACE_CMD} -e 's|xfce4/src/misc|${PORTNAME}|g' \