aboutsummaryrefslogtreecommitdiff
path: root/multimedia/zoneminder
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-06-23 19:40:46 +0000
committerPawel Pekala <pawel@FreeBSD.org>2016-06-23 19:40:46 +0000
commit81c5c108accd1301b7558b906f71701a618673fb (patch)
tree28c5807826fb0260b373f2c1e13a5cd6c56068df /multimedia/zoneminder
parenteeae314d3ff9aed843cdef85b95f9f6d2ca45eaa (diff)
downloadports-81c5c108accd1301b7558b906f71701a618673fb.tar.gz
ports-81c5c108accd1301b7558b906f71701a618673fb.zip
- Add missing php dependencies, works with PHP7
- Documentation tweaks PR: 210442 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=417398
Diffstat (limited to 'multimedia/zoneminder')
-rw-r--r--multimedia/zoneminder/Makefile6
-rw-r--r--multimedia/zoneminder/files/README.FreeBSD20
2 files changed, 8 insertions, 18 deletions
diff --git a/multimedia/zoneminder/Makefile b/multimedia/zoneminder/Makefile
index 5ee33339625f..2e66b33606f4 100644
--- a/multimedia/zoneminder/Makefile
+++ b/multimedia/zoneminder/Makefile
@@ -4,6 +4,7 @@ PORTNAME= zoneminder
PORTVERSION= 1.30.0
DISTVERSIONPREFIX=v
DISTVERSIONSUFFIX=-rc1
+PORTREVISION= 1
CATEGORIES= multimedia
MAINTAINER= bsd@abinet.ru
@@ -36,10 +37,9 @@ GH_TAGNAME= c3976f1:crud
WRKSRC= ${WRKDIR}/ZoneMinder-${DISTVERSION}${DISTVERSIONSUFFIX}
-USES= cmake jpeg mysql perl5 shebangfix
+USES= cmake jpeg mysql perl5 php shebangfix
USE_RC_SUBR= zoneminder
-PHP= json pdo_mysql session
-IGNORE_WITH_PHP=70
+USE_PHP= json pdo_mysql session gd sockets
ONLY_FOR_ARCHS= amd64 i386
diff --git a/multimedia/zoneminder/files/README.FreeBSD b/multimedia/zoneminder/files/README.FreeBSD
index ff112cc402be..97ab58fdb0a8 100644
--- a/multimedia/zoneminder/files/README.FreeBSD
+++ b/multimedia/zoneminder/files/README.FreeBSD
@@ -14,18 +14,12 @@ the same server.
1. Preliminary steps
-1.1 Install databases/mysql56-server
+1.1 Install databases/mysql56-server or newer
You may choose your favourite method - ports or packages here.
- FreeBSD default setting use STRICT_TRANS_TABLES sql_mode. It's mandatory to disable it. Edit your my.cnf or create new in /var/db/mysql
-
- The following example works with ZoneMinder quite well
+ FreeBSD default setting use STRICT_TRANS_TABLES sql_mode. It's mandatory to disable it. Edit your my.cnf accordingly
- [server]
- skip-networking
- skip-name-resolve
- innodb_flush_method = O_DIRECT
- skip-innodb_doublewrite
- innodb_file_per_table
+ The following SQL mode should be compatible with ZM:
+ sql_mode= NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION
ZoneMinder use very simple queries, however it tends to write to
the database quite a lot depending on your capture mode and number
@@ -105,7 +99,7 @@ the same server.
exec(). Sorry, chroot folks.
PHP throws warning if date.timezone option is not set. The best place
- to do it is an ini file in /usr/local/etc/php
+ to do it is to create new ini file in /usr/local/etc/php with overrides
date.timezone = "UTC"
@@ -148,10 +142,6 @@ the same server.
other than zmuser/zmpass then you must now edit /usr/local/etc/zm.conf. Change
ZM_DB_USER and ZM_DB_PASS to the values you created in the previous step.
- Additionally, you must also edit
- /usr/local/www/zoneminder/api/app/Config/database.php in a similar
- manner. Scroll down and change login and password to the values you created in the previous step.
-
Enable and start ZoneMinder
sysrc zoneminder_enable="YES"
service zoneminder start