aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-10-08 17:48:06 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-10-08 17:48:06 +0000
commit051bef12df1b5f6ef4249267401449ab37c3b0d5 (patch)
tree3e90ea6698823def4a8d67092cf69a664edd5b38 /multimedia
parent600df92c426dbf8d50dde31b7a8e86f69ded4482 (diff)
downloadports-051bef12df1b5f6ef4249267401449ab37c3b0d5.tar.gz
ports-051bef12df1b5f6ef4249267401449ab37c3b0d5.zip
* Fix autodetection problem for freetype2 which breaks gmplayer for some
machines, hopefully satisfying pr/57622 * RUN_DEPENDS on mplayer-skins if compiled WITH_GUI [1] PR: 57687 Suggested by: Jeremy Messenger <mezz7@cox.net> [1]
Notes
Notes: svn path=/head/; revision=90649
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mplayer/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 67099885077d..275b4dc0d82a 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -38,10 +38,11 @@
# (if not available) and then link mplayer against it. Then you'll
# be able to use gmplayer, the graphical version of mplayer
#
-# WITH_FREETYPE
+# WITHOUT_FREETYPE
# default: undefined
-# defining this will change mplayer's font display ability from bitmap
-# fonts to truetype fonts
+# since freetype is installed on almost any system people might want
+# to run mplayer on, this port now defaults to freetype unless not
+# defined otherwise
#
#
# CPU features:
@@ -166,7 +167,7 @@
PORTNAME= mplayer
PORTVERSION= 0.92.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia audio ipv6
MASTER_SITES= http://www1.mplayerhq.hu/MPlayer/releases/ \
http://www2.mplayerhq.hu/MPlayer/releases/ \
@@ -306,6 +307,10 @@ WITH_XMMS= yes
WITH_LZO= yes
.endif
+.if exists(${LOCALBASE}/lib/libfreetype.so.9) && !defined(WITHOUT_FREETYPE)
+WITH_FREETYPE= yes
+.endif
+
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O3 -ffast-math -fomit-frame-pointer
.endif
@@ -319,6 +324,7 @@ PLIST_SUB+= GMPLAYER="@comment "
.if defined(WITH_GUI)
USE_GNOME+= gtk12
+RUN_DEPENDS+= ${LOCALBASE}/share/mplayer/Skin:${PORTSDIR}/multimedia/mplayer-skins
.if defined(PKGNAMESUFFIX)
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-gtk
.else
@@ -454,6 +460,7 @@ CONFIGURE_ARGS+= --with-extraincdir=${LOCALBASE}/include/freetype2 \
LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
.else
RUN_DEPENDS+= ${LOCALBASE}/share/mplayer/fonts:${PORTSDIR}/multimedia/mplayer-fonts
+CONFIGURE_ARGS+= --disable-freetype
.endif
.if defined(WITH_XANIM)