aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2015-08-15 11:05:06 +0000
committerRene Ladan <rene@FreeBSD.org>2015-08-15 11:05:06 +0000
commit174165466add6bc73a71a64bf0a5efe04e1ce054 (patch)
tree756857c6922e9b24adbe389672df0a6075cea99f /multimedia
parent39a07d8719630bbd378abe6dbda564259a7b9261 (diff)
downloadports-174165466add6bc73a71a64bf0a5efe04e1ce054.tar.gz
ports-174165466add6bc73a71a64bf0a5efe04e1ce054.zip
multimedia/spotify-websocket-api: as discussed with the author, mark this port
as IGNORE because login fails and set expiration date to 2016-01-01. While here pet portlint.
Notes
Notes: svn path=/head/; revision=394294
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/spotify-websocket-api/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/multimedia/spotify-websocket-api/Makefile b/multimedia/spotify-websocket-api/Makefile
index 61b8240b4ef9..70bbfbaf298b 100644
--- a/multimedia/spotify-websocket-api/Makefile
+++ b/multimedia/spotify-websocket-api/Makefile
@@ -10,6 +10,10 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= rene@FreeBSD.org
COMMENT= Websocket API and client for Spotify
+IGNORE= login fails due to protocol changes
+DEPRECATED= ${IGNORE}
+EXPIRATION_DATE=2016-01-01
+
NO_ARCH= yes
USE_GITHUB= yes
@@ -17,7 +21,7 @@ GH_ACCOUNT= Hexxeh
GH_PROJECT= spotify-websocket-api
GH_TAGNAME= d397ed2
-USES= shebangfix python
+USES= python shebangfix
SHEBANG_FILES= spotify_web/spotify.py ${CLIENTFILES}
USE_PYTHON= autoplist concurrent distutils
@@ -51,13 +55,13 @@ post-patch:
post-install:
.for f in ${CLIENTFILES}
- @${INSTALL_SCRIPT} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin
.endfor
- @${LN} -s ${PREFIX}/bin/respotify.py ${STAGEDIR}${PREFIX}/bin/respotify
+ ${LN} -s ${PREFIX}/bin/respotify.py ${STAGEDIR}${PREFIX}/bin/respotify
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for f in ${PORTEXAMPLES}
- @${INSTALL_SCRIPT} ${WRKSRC}/examples/${f} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/${f} ${STAGEDIR}${EXAMPLESDIR}
.endfor
.include <bsd.port.mk>