aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2013-09-21 11:06:03 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2013-09-21 11:06:03 +0000
commit1e3119b07ebe66367ead55242a47710e556bf383 (patch)
tree2051ba0023bbf060fa37051dc7fc6990710a53b1 /multimedia
parent0dea0192303406b3b949a31479a4264b58bafce6 (diff)
downloadports-1e3119b07ebe66367ead55242a47710e556bf383.tar.gz
ports-1e3119b07ebe66367ead55242a47710e556bf383.zip
- fix misplaced NO_STAGE in slaveports and ifdefs
Notes
Notes: svn path=/head/; revision=327804
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/replex/Makefile3
-rw-r--r--multimedia/sabbu/Makefile3
-rw-r--r--multimedia/xanim/Makefile2
3 files changed, 5 insertions, 3 deletions
diff --git a/multimedia/replex/Makefile b/multimedia/replex/Makefile
index b91fa0d314b4..e1e8002b8ed4 100644
--- a/multimedia/replex/Makefile
+++ b/multimedia/replex/Makefile
@@ -10,6 +10,8 @@ MASTER_SITE_SUBDIR=dinoex
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Remultiplex an MPEG2 TS into a PS for DVD
+NO_STAGE= yes
+
USE_GMAKE= yes
MAKE_ARGS= CFLAGS="${CFLAGS}" DEFINES="${CPPFLAGS} -DO_LARGEFILE=0 -DVERSION=\\\"$(PORTVERSION)\\\"" \
LIBS="${LDFLAGS}"
@@ -20,7 +22,6 @@ PLIST_FILES= bin/replex
PORTDOCS= CHANGES README TODO
.endif
-NO_STAGE= yes
post-patch:
@${GREP} -lR "<stdint\.h>" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|<stdint\.h>|<inttypes.h>|g'
diff --git a/multimedia/sabbu/Makefile b/multimedia/sabbu/Makefile
index 86e0fc006168..9534650dabb6 100644
--- a/multimedia/sabbu/Makefile
+++ b/multimedia/sabbu/Makefile
@@ -12,6 +12,8 @@ COMMENT= Program used to time subtitles
LIB_DEPENDS= avcodec:${PORTSDIR}/multimedia/ffmpeg \
sndfile:${PORTSDIR}/audio/libsndfile
+NO_STAGE= yes
+
USES= pkgconfig iconv
USE_BZIP2= yes
USE_GMAKE= yes
@@ -24,7 +26,6 @@ LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lswscale
OPTIONS_DEFINE= GTKSPELL
OPTIONS_DEFAULT=GTKSPELL
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/multimedia/xanim/Makefile b/multimedia/xanim/Makefile
index 195e739ba2e9..3e5e9b646b22 100644
--- a/multimedia/xanim/Makefile
+++ b/multimedia/xanim/Makefile
@@ -16,6 +16,7 @@ MAINTAINER= dinoex@FreeBSD.org
COMMENT= Play most popular animation formats and show pictures
NO_CDROM= redistributed without fee
+NO_STAGE= yes
# clang's cpp destroys whitespace, particularly hard tabs in makefiles,
# which is fatal for imake.
@@ -28,7 +29,6 @@ DLLDIR= ${PREFIX}/lib/X11/xanim
PLIST_FILES+= bin/xanim
NO_CDROM= without fee
-NO_STAGE= yes
post-extract:
${CP} ${WRKSRC}/docs/xanim.man ${WRKSRC}