aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2021-01-01 10:11:34 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2021-01-01 10:11:34 +0000
commit26b4c8f71f91d22e081b27814782686edde0c90a (patch)
tree1c321c39372c25d8634e75b5c8e08edc676b296d /multimedia
parent548f16bd1a2915f08878b716eed92ff3267e6de2 (diff)
downloadports-26b4c8f71f91d22e081b27814782686edde0c90a.tar.gz
ports-26b4c8f71f91d22e081b27814782686edde0c90a.zip
Revert r559792 to unbreak INDEX and bulk -a
It seems a lot of reverse dependencies were missed With hat: portmgr
Notes
Notes: svn path=/head/; revision=559822
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile2
-rw-r--r--multimedia/ffmpeg2theora/Makefile28
-rw-r--r--multimedia/ffmpeg2theora/distinfo3
-rw-r--r--multimedia/ffmpeg2theora/files/patch-SConstruct30
-rw-r--r--multimedia/ffmpeg2theora/files/patch-src_ffmpeg2theora.c14
-rw-r--r--multimedia/ffmpeg2theora/files/patch-src_subtitles.c11
-rw-r--r--multimedia/ffmpeg2theora/pkg-descr5
-rw-r--r--multimedia/mimms/Makefile32
-rw-r--r--multimedia/mimms/distinfo2
-rw-r--r--multimedia/mimms/pkg-descr7
-rw-r--r--multimedia/mimms/pkg-plist11
11 files changed, 145 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 5d42dce18e5d..6a9d58ebce85 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -60,6 +60,7 @@
SUBDIR += ffaudioconverter
SUBDIR += ffdec
SUBDIR += ffmpeg
+ SUBDIR += ffmpeg2theora
SUBDIR += ffmpegthumbnailer
SUBDIR += ffms2
SUBDIR += flvmeta
@@ -246,6 +247,7 @@
SUBDIR += makemkv
SUBDIR += mediainfo
SUBDIR += mencoder
+ SUBDIR += mimms
SUBDIR += minitube
SUBDIR += mjpegtools
SUBDIR += mkclean
diff --git a/multimedia/ffmpeg2theora/Makefile b/multimedia/ffmpeg2theora/Makefile
new file mode 100644
index 000000000000..28bb8f71349a
--- /dev/null
+++ b/multimedia/ffmpeg2theora/Makefile
@@ -0,0 +1,28 @@
+# Created by: Anders Nordby <anders@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= ffmpeg2theora
+PORTVERSION= 0.30
+PORTREVISION= 6
+CATEGORIES= multimedia
+MASTER_SITES= http://v2v.cc/~j/ffmpeg2theora/downloads/
+
+MAINTAINER= wg@FreeBSD.org
+COMMENT= Reencode many media file formats to Ogg Theora
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg \
+ libkate.so:multimedia/libkate \
+ libtheora.so:multimedia/libtheora
+
+USES= iconv pkgconfig scons:python2 tar:bzip2
+MAKE_ARGS= APPEND_CCFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ APPEND_LINKFLAGS="${LDFLAGS} ${LIBS}"
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib ${ICONV_LIB}
+
+PLIST_FILES= bin/ffmpeg2theora man/man1/ffmpeg2theora.1.gz
+
+.include <bsd.port.mk>
diff --git a/multimedia/ffmpeg2theora/distinfo b/multimedia/ffmpeg2theora/distinfo
new file mode 100644
index 000000000000..647b78d84f65
--- /dev/null
+++ b/multimedia/ffmpeg2theora/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1465461122
+SHA256 (ffmpeg2theora-0.30.tar.bz2) = 4f6464b444acab5d778e0a3359d836e0867a3dcec4ad8f1cdcf87cb711ccc6df
+SIZE (ffmpeg2theora-0.30.tar.bz2) = 91269
diff --git a/multimedia/ffmpeg2theora/files/patch-SConstruct b/multimedia/ffmpeg2theora/files/patch-SConstruct
new file mode 100644
index 000000000000..38b7c79686de
--- /dev/null
+++ b/multimedia/ffmpeg2theora/files/patch-SConstruct
@@ -0,0 +1,30 @@
+--- SConstruct.orig 2016-01-10 04:35:56 UTC
++++ SConstruct
+@@ -38,7 +38,7 @@ opts.AddVariables(
+ BoolVariable('libkate', 'enable libkate support', 1),
+ BoolVariable('crossmingw', 'Set to 1 for crosscompile with mingw', 0)
+ )
+-env = Environment(options = opts)
++env = Environment(options = opts, ENV=os.environ, CC = Split(os.environ['CC']))
+ Help(opts.GenerateHelpText(env))
+
+ pkg_flags="--cflags --libs"
+@@ -152,7 +152,6 @@ if not env.GetOption('clean'):
+ "libavcodec >= 52.30.0",
+ "libpostproc",
+ "libswscale",
+- "libswresample",
+ "libavutil",
+ ]
+ if os.path.exists("./ffmpeg"):
+@@ -214,9 +213,8 @@ if not env.GetOption('clean'):
+ env.Append(CCFLAGS=[
+ '-DHAVE_ICONV'
+ ])
+- if conf.CheckLib('iconv'):
+- env.Append(LIBS=['iconv'])
+
++ env.Append(LIBS=['m'])
+ if env['crossmingw']:
+ env.Append(CCFLAGS=['-Wl,-subsystem,windows'])
+ env.Append(LIBS=['m'])
diff --git a/multimedia/ffmpeg2theora/files/patch-src_ffmpeg2theora.c b/multimedia/ffmpeg2theora/files/patch-src_ffmpeg2theora.c
new file mode 100644
index 000000000000..5b210f9b14b7
--- /dev/null
+++ b/multimedia/ffmpeg2theora/files/patch-src_ffmpeg2theora.c
@@ -0,0 +1,14 @@
+--- src/ffmpeg2theora.c.orig 2016-01-10 04:35:56 UTC
++++ src/ffmpeg2theora.c
+@@ -3103,7 +3103,11 @@ int main(int argc, char **argv) {
+ fprintf(stderr,"\nUnable to decode input.\n");
+ return(1);
+ }
++#if LIBAVFORMAT_VERSION_INT < AV_VERSION_INT(53,17,0)
++ av_close_input_file(convert->context);
++#else
+ avformat_close_input(&convert->context);
++#endif
+ }
+ else{
+ if (info.frontend)
diff --git a/multimedia/ffmpeg2theora/files/patch-src_subtitles.c b/multimedia/ffmpeg2theora/files/patch-src_subtitles.c
new file mode 100644
index 000000000000..490c8670185f
--- /dev/null
+++ b/multimedia/ffmpeg2theora/files/patch-src_subtitles.c
@@ -0,0 +1,11 @@
+--- src/subtitles.c.orig 2016-01-10 04:35:56 UTC
++++ src/subtitles.c
+@@ -284,7 +284,7 @@ static char *convert_subtitle_to_utf8(co
+ return NULL;
+ }
+ outptr=newtext;
+- if (iconv(cd, &inptr, &insz, &outptr, &outsz) < 0) {
++ if (iconv(cd, &inptr, &insz, &outptr, &outsz) == (size_t)-1) {
+ warn(frontend, NULL, 0, "Failed to convert text to UTF-8\n");
+ free(newtext);
+ newtext = NULL;
diff --git a/multimedia/ffmpeg2theora/pkg-descr b/multimedia/ffmpeg2theora/pkg-descr
new file mode 100644
index 000000000000..4745349a15c3
--- /dev/null
+++ b/multimedia/ffmpeg2theora/pkg-descr
@@ -0,0 +1,5 @@
+ffmpeg2theora is a simple command line tool to convert media files to
+.ogg with Theora video and Vorbis audio streams. It supports reading any
+file format that ffmpeg can decode.
+
+WWW: http://v2v.cc/~j/ffmpeg2theora/
diff --git a/multimedia/mimms/Makefile b/multimedia/mimms/Makefile
new file mode 100644
index 000000000000..3918f11b91ac
--- /dev/null
+++ b/multimedia/mimms/Makefile
@@ -0,0 +1,32 @@
+# Created by: Yinghong.Liu <liu_yinghong@yahoo.com.cn>
+# $FreeBSD$
+
+PORTNAME= mimms
+DISTVERSION= 3.2.1
+CATEGORIES= multimedia net
+MASTER_SITES= SAVANNAH
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Download streams using the MMS protocol
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libmms.so:net/libmms
+
+USES= python:2.7 tar:bzip2
+USE_PYTHON= distutils
+PYDISTUTILS_PKGVERSION= 3.2
+NO_ARCH= yes
+
+PORTDOCS= AUTHORS COPYING NEWS README
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/multimedia/mimms/distinfo b/multimedia/mimms/distinfo
new file mode 100644
index 000000000000..9509c813fb6a
--- /dev/null
+++ b/multimedia/mimms/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mimms-3.2.1.tar.bz2) = 92cd3e1800d8bd637268274196f6baec0d95aa8e709714093dd96ba8893c2354
+SIZE (mimms-3.2.1.tar.bz2) = 18224
diff --git a/multimedia/mimms/pkg-descr b/multimedia/mimms/pkg-descr
new file mode 100644
index 000000000000..aeec7d95a2de
--- /dev/null
+++ b/multimedia/mimms/pkg-descr
@@ -0,0 +1,7 @@
+MMS is a program designed to allow you to download streams using
+the MMS protocol and save them to your computer, as opposed to
+watching them live. Similar functionality is available in full
+media player suites such as Xine and MPlayer, but MiMMS is quick
+and easy to use, and for the time being, remains a useful program.
+
+WWW: https://savannah.nongnu.org/projects/mimms/
diff --git a/multimedia/mimms/pkg-plist b/multimedia/mimms/pkg-plist
new file mode 100644
index 000000000000..23e636391eb8
--- /dev/null
+++ b/multimedia/mimms/pkg-plist
@@ -0,0 +1,11 @@
+bin/mimms
+%%PYTHON_SITELIBDIR%%/libmimms/__init__.py
+%%PYTHON_SITELIBDIR%%/libmimms/__init__.pyc
+%%PYTHON_SITELIBDIR%%/libmimms/__init__.pyo
+%%PYTHON_SITELIBDIR%%/libmimms/core.py
+%%PYTHON_SITELIBDIR%%/libmimms/core.pyc
+%%PYTHON_SITELIBDIR%%/libmimms/core.pyo
+%%PYTHON_SITELIBDIR%%/libmimms/libmms.py
+%%PYTHON_SITELIBDIR%%/libmimms/libmms.pyc
+%%PYTHON_SITELIBDIR%%/libmimms/libmms.pyo
+share/man/man1/mimms.1.gz