aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorAoek <pr@aoek.com>2021-07-18 15:14:44 +0000
committerMikael Urankar <mikael@FreeBSD.org>2021-07-18 15:19:54 +0000
commit385516904c1e1402e9a9ceb7327d8b9b1874732f (patch)
tree1a4701919bcad89459db69374e9d4d51465a6fea /multimedia
parent330c751fd75884ec2891ff920187c991013cf06d (diff)
downloadports-385516904c1e1402e9a9ceb7327d8b9b1874732f.tar.gz
ports-385516904c1e1402e9a9ceb7327d8b9b1874732f.zip
multimedia/gstreamer1-libav: Fix build on aarch64
Fix build on aarch64 when FFMPEG option is off. This is similar to the fix in multimedia/ffmpeg: svn port r507608 PR: 256935 Approved by: portmgr (build fix blanket) (cherry picked from commit 905dfe641b7045ca5b92dab3f11acda51d380134)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gstreamer1-libav/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/multimedia/gstreamer1-libav/Makefile b/multimedia/gstreamer1-libav/Makefile
index 054fbecbce60..12c5bddeca6d 100644
--- a/multimedia/gstreamer1-libav/Makefile
+++ b/multimedia/gstreamer1-libav/Makefile
@@ -35,6 +35,12 @@ FFMPEG_BUILD_DEPENDS_OFF= nasm:devel/nasm
FFMPEG_MAKE_ENV_OFF= V=1
FFMPEG_VARS_OFF+= NOPRECIOUSMAKEVARS=yes # ARCH
+.include <bsd.port.options.mk>
+
+.if empty(PORT_OPTIONS:MFFMPEG)
+LDFLAGS_aarch64= -Wl,-z,notext
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-Werror||g' \
${WRKSRC}/configure