aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-10-02 02:33:59 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-10-16 02:28:11 +0000
commit6343fc8a79d896a47a0133732f099e32d422c6aa (patch)
treec7c7e9595a5a8f7600a15584987f4b2aed1c001a /multimedia
parentf6a62a9b08f01fb2416d8706f0fe4261a66d215b (diff)
downloadports-6343fc8a79d896a47a0133732f099e32d422c6aa.tar.gz
ports-6343fc8a79d896a47a0133732f099e32d422c6aa.zip
multimedia/clapper: add new port
Clapper is a GNOME media player built using GJS with GTK4 toolkit. The media player is using GStreamer as a media backend and renders everything via OpenGL. Player works natively on both Xorg and Wayland. It also supports hardware acceleration through VA-API on AMD/Intel GPUs, NVDEC on Nvidia and V4L2 on mobile devices. The media player has an adaptive GUI. When viewing videos in "Windowed Mode", Clapper will use mostly unmodified GTK widgets to match your OS look nicely. When player enters "Fullscreen Mode" all GUI elements will become darker, bigger and semi-transparent for your viewing comfort. It also has a "Floating Mode" which displays only video on top of all other windows for a PiP-like viewing experience. Mobile friendly transitions are also supported. https://rafostar.github.io/clapper
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/clapper/Makefile30
-rw-r--r--multimedia/clapper/distinfo3
-rw-r--r--multimedia/clapper/pkg-descr12
-rw-r--r--multimedia/clapper/pkg-plist68
5 files changed, 114 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 44e88722e68f..ca1fb19333d3 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -31,6 +31,7 @@
SUBDIR += cheese
SUBDIR += chilitags
SUBDIR += cineencoder
+ SUBDIR += clapper
SUBDIR += clutter-gst
SUBDIR += clutter-gst3
SUBDIR += cmrt
diff --git a/multimedia/clapper/Makefile b/multimedia/clapper/Makefile
new file mode 100644
index 000000000000..aad6deded7ed
--- /dev/null
+++ b/multimedia/clapper/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= clapper
+DISTVERSION= 0.5.2
+CATEGORIES= multimedia # wayland: requires WAYLAND=on in gstreamer1-plugins-gl
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Simple and modern GNOME media player
+WWW= https://rafostar.github.io/clapper
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= gjs:lang/gjs
+RUN_DEPENDS= gjs:lang/gjs
+
+USES= desktop-file-utils gettext-tools gl gnome gstreamer meson \
+ pkgconfig python:build shared-mime-info shebangfix
+USE_GITHUB= yes
+USE_GL= glesv2
+USE_GNOME= gtk40 libadwaita
+USE_GSTREAMER= gl good libav
+USE_LDCONFIG= yes
+GH_ACCOUNT= Rafostar
+SHEBANG_FILES= build-aux/meson/postinstall.py
+GLIB_SCHEMAS= com.github.rafostar.Clapper.gschema.xml
+
+post-patch:
+# Derive Python version from Meson
+ @${REINPLACE_CMD} -e "s,'python3',," ${WRKSRC}/meson.build
+
+.include <bsd.port.mk>
diff --git a/multimedia/clapper/distinfo b/multimedia/clapper/distinfo
new file mode 100644
index 000000000000..00a9b64ad863
--- /dev/null
+++ b/multimedia/clapper/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1664678039
+SHA256 (Rafostar-clapper-0.5.2_GH0.tar.gz) = 30b78e0fc45346aee6513dc9fcd974d2cf9752cb9de5c9e352f5521aa640f284
+SIZE (Rafostar-clapper-0.5.2_GH0.tar.gz) = 207254
diff --git a/multimedia/clapper/pkg-descr b/multimedia/clapper/pkg-descr
new file mode 100644
index 000000000000..4f6c2faa97e4
--- /dev/null
+++ b/multimedia/clapper/pkg-descr
@@ -0,0 +1,12 @@
+Clapper is a GNOME media player built using GJS with GTK4 toolkit.
+The media player is using GStreamer as a media backend and renders
+everything via OpenGL. Player works natively on both Xorg and Wayland.
+It also supports hardware acceleration through VA-API on AMD/Intel GPUs,
+NVDEC on Nvidia and V4L2 on mobile devices.
+
+The media player has an adaptive GUI. When viewing videos in "Windowed Mode",
+Clapper will use mostly unmodified GTK widgets to match your OS look nicely.
+When player enters "Fullscreen Mode" all GUI elements will become darker,
+bigger and semi-transparent for your viewing comfort. It also has a
+"Floating Mode" which displays only video on top of all other windows for a
+PiP-like viewing experience. Mobile friendly transitions are also supported.
diff --git a/multimedia/clapper/pkg-plist b/multimedia/clapper/pkg-plist
new file mode 100644
index 000000000000..8846244365f7
--- /dev/null
+++ b/multimedia/clapper/pkg-plist
@@ -0,0 +1,68 @@
+bin/clapper
+bin/com.github.rafostar.Clapper
+lib/clapper-1.0/gst/plugin/importers/libgstclapperglimporter.so
+lib/clapper-1.0/gst/plugin/importers/libgstclappergluploader.so
+lib/com.github.rafostar.Clapper/girepository-1.0/GstClapper-1.0.typelib
+lib/com.github.rafostar.Clapper/libgstclapper-1.0.so
+lib/com.github.rafostar.Clapper/libgstclapper-1.0.so.0
+lib/com.github.rafostar.Clapper/libgstclapper-1.0.so.0.5.2
+lib/gstreamer-1.0/libgstclapper.so
+lib/libgstclapperglbaseimporter.so
+lib/libgstclapperglbaseimporter.so.0
+lib/libgstclapperglbaseimporter.so.0.5.2
+share/applications/com.github.rafostar.Clapper.desktop
+share/com.github.rafostar.Clapper/com.github.rafostar.Clapper.data.gresource
+share/com.github.rafostar.Clapper/css/styles.css
+share/com.github.rafostar.Clapper/extras/debug/Debug.js
+share/com.github.rafostar.Clapper/extras/ink/Ink.js
+share/com.github.rafostar.Clapper/src/actions.js
+share/com.github.rafostar.Clapper/src/app.js
+share/com.github.rafostar.Clapper/src/buttons.js
+share/com.github.rafostar.Clapper/src/controls.js
+share/com.github.rafostar.Clapper/src/dbus.js
+share/com.github.rafostar.Clapper/src/debug.js
+share/com.github.rafostar.Clapper/src/dialogs.js
+share/com.github.rafostar.Clapper/src/fileOps.js
+share/com.github.rafostar.Clapper/src/headerbar.js
+share/com.github.rafostar.Clapper/src/main.js
+share/com.github.rafostar.Clapper/src/misc.js
+share/com.github.rafostar.Clapper/src/player.js
+share/com.github.rafostar.Clapper/src/playlist.js
+share/com.github.rafostar.Clapper/src/prefs.js
+share/com.github.rafostar.Clapper/src/revealers.js
+share/com.github.rafostar.Clapper/src/webHelpers.js
+share/com.github.rafostar.Clapper/src/webServer.js
+share/com.github.rafostar.Clapper/src/widget.js
+share/com.github.rafostar.Clapper/ui/clapper.ui
+share/com.github.rafostar.Clapper/ui/elapsed-time-button.ui
+share/com.github.rafostar.Clapper/ui/help-overlay.ui
+share/com.github.rafostar.Clapper/ui/popover-separator.ui
+share/com.github.rafostar.Clapper/ui/preferences-plugin-ranking-subpage.ui
+share/com.github.rafostar.Clapper/ui/preferences-window.ui
+share/com.github.rafostar.Clapper/ui/track-select-button.ui
+share/com.github.rafostar.Clapper/ui/volume-button.ui
+share/dbus-1/services/com.github.rafostar.Clapper.service
+share/gir-1.0/GstClapper-1.0.gir
+share/icons/hicolor/scalable/apps/com.github.rafostar.Clapper.svg
+share/icons/hicolor/symbolic/apps/com.github.rafostar.Clapper-symbolic.svg
+share/locale/ar/LC_MESSAGES/com.github.rafostar.Clapper.mo
+share/locale/ca/LC_MESSAGES/com.github.rafostar.Clapper.mo
+share/locale/cs/LC_MESSAGES/com.github.rafostar.Clapper.mo
+share/locale/de/LC_MESSAGES/com.github.rafostar.Clapper.mo
+share/locale/es/LC_MESSAGES/com.github.rafostar.Clapper.mo
+share/locale/eu/LC_MESSAGES/com.github.rafostar.Clapper.mo
+share/locale/fr/LC_MESSAGES/com.github.rafostar.Clapper.mo
+share/locale/he/LC_MESSAGES/com.github.rafostar.Clapper.mo
+share/locale/hu/LC_MESSAGES/com.github.rafostar.Clapper.mo
+share/locale/it/LC_MESSAGES/com.github.rafostar.Clapper.mo
+share/locale/ja/LC_MESSAGES/com.github.rafostar.Clapper.mo
+share/locale/nl/LC_MESSAGES/com.github.rafostar.Clapper.mo
+share/locale/pl/LC_MESSAGES/com.github.rafostar.Clapper.mo
+share/locale/pt/LC_MESSAGES/com.github.rafostar.Clapper.mo
+share/locale/pt_BR/LC_MESSAGES/com.github.rafostar.Clapper.mo
+share/locale/ru/LC_MESSAGES/com.github.rafostar.Clapper.mo
+share/locale/sv/LC_MESSAGES/com.github.rafostar.Clapper.mo
+share/locale/tr/LC_MESSAGES/com.github.rafostar.Clapper.mo
+share/locale/zh_CN/LC_MESSAGES/com.github.rafostar.Clapper.mo
+share/metainfo/com.github.rafostar.Clapper.metainfo.xml
+share/mime/packages/com.github.rafostar.Clapper.xml