aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2009-03-15 21:18:29 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2009-03-15 21:18:29 +0000
commit749e74a92434c1b7b0998867852b477645483da4 (patch)
treea69c48e436721701496e9a9a81be68956dc60dba /multimedia
parent5e16114ca172d7f5e70aebc31dc9fadfe219e769 (diff)
downloadports-749e74a92434c1b7b0998867852b477645483da4.tar.gz
ports-749e74a92434c1b7b0998867852b477645483da4.zip
remove check for XCB, fix build without MOZILLA_PLUGIN
Notes
Notes: svn path=/head/; revision=230177
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gxine/Makefile20
1 files changed, 4 insertions, 16 deletions
diff --git a/multimedia/gxine/Makefile b/multimedia/gxine/Makefile
index 26029f8235f5..62b037d656db 100644
--- a/multimedia/gxine/Makefile
+++ b/multimedia/gxine/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gxine
PORTVERSION= 0.5.903
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia
MASTER_SITES= SF
MASTER_SITE_SUBDIR= xine
@@ -25,8 +25,7 @@ USE_GCC= 4.2+
USE_XORG= x11 xaw ice
MAKE_ARGS+= LDFLAGS=-shared-libgcc
CNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --without-hal
-CONFIGURE_ENV+= CFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS+=--without-hal --with-libintl-prefix=${LOCALBASE}
INSTALLS_ICONS= yes
MANLANG= "" de es
@@ -36,15 +35,10 @@ MANCOMPRESSED= no
OPTIONS= MOZILLA_PLUGIN "Install Mozilla plugin" on \
GNOME "Enable Gnome integration" off \
DBUS "Enable dbus support" on \
- LIRC "Enable lirc support" off \
- XCB "Enable XCB support" off
+ LIRC "Enable lirc support" off
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700000
-CFLAGS+= -O2
-.endif
-
.if defined(WITH_GNOME)
USE_GNOME+= gnomevfs2 libgnomeui
.else
@@ -75,7 +69,7 @@ CONFIGURE_ARGS+= --disable-lirc
.if defined(WITHOUT_MOZILLA_PLUGIN)
LIB_DEPENDS+= js.1:${PORTSDIR}/lang/spidermonkey
-CONFIGURE_ARGS+=--without-browser-plugin
+CONFIGURE_ARGS+=--without-browser-plugin --with-spidermonkey
PLIST_SUB+= MOZILLA_PLUGIN="@comment "
.else
USE_GECKO= firefox mozilla seamonkey xulrunner
@@ -90,12 +84,6 @@ CONFIGURE_ARGS+=--disable-libjs
PLIST_SUB+= MOZILLA_PLUGIN=""
.endif
-.if defined(WITH_XCB)
-LIB_DEPENDS+= xcb.2:${PORTSDIR}/x11/libxcb
-.else
-CONFIGURE_ARGS+=--without-xcb
-.endif
-
pre-configure:
@${REINPLACE_CMD} -e "/^mkdir_p/s:@mkdir_p@:${MKDIR}:" \
${WRKSRC}/po/Makefile.in.in