aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2016-08-11 15:13:34 +0000
committerKevin Lo <kevlo@FreeBSD.org>2016-08-11 15:13:34 +0000
commit7ae337bf48c31b61fef4aa667862b742ae4aba5d (patch)
treeb3fa7e11118fb896b59b43bf34aa4ea8df7882e5 /multimedia
parenteb4b5a41e14cdd1cc4fe10745a00986366577d09 (diff)
downloadports-7ae337bf48c31b61fef4aa667862b742ae4aba5d.tar.gz
ports-7ae337bf48c31b61fef4aa667862b742ae4aba5d.zip
Import py-cec 0.2.5
Python-cec allows you to control your TV, reciever and other CEC-compliant HDMI devices from a python script on a computer.
Notes
Notes: svn path=/head/; revision=420077
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/py-cec/Makefile21
-rw-r--r--multimedia/py-cec/distinfo3
-rw-r--r--multimedia/py-cec/pkg-descr4
4 files changed, 29 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 09890f8d9a51..283eb2e4b07a 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -310,6 +310,7 @@
SUBDIR += ptx-kmod
SUBDIR += pwcbsd
SUBDIR += pwcview
+ SUBDIR += py-cec
SUBDIR += py-enzyme
SUBDIR += py-ffmpeg
SUBDIR += py-gstreamer
diff --git a/multimedia/py-cec/Makefile b/multimedia/py-cec/Makefile
new file mode 100644
index 000000000000..f991c590671b
--- /dev/null
+++ b/multimedia/py-cec/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= cec
+PORTVERSION= 0.2.5
+CATEGORIES= multimedia python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= kevlo@FreeBSD.org
+COMMENT= Python bindings for libcec
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libcec.so:multimedia/libcec
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+CPPFLAGS+= -I${LOCALBASE}/include
+
+.include <bsd.port.mk>
diff --git a/multimedia/py-cec/distinfo b/multimedia/py-cec/distinfo
new file mode 100644
index 000000000000..caefaafc6994
--- /dev/null
+++ b/multimedia/py-cec/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1470924935
+SHA256 (cec-0.2.5.tar.gz) = 7de65012e54943013dbb193383a1904a9ade08f90eaa5c78c1ea5b23e8252162
+SIZE (cec-0.2.5.tar.gz) = 8513
diff --git a/multimedia/py-cec/pkg-descr b/multimedia/py-cec/pkg-descr
new file mode 100644
index 000000000000..48bcfa901b9d
--- /dev/null
+++ b/multimedia/py-cec/pkg-descr
@@ -0,0 +1,4 @@
+Python-cec allows you to control your TV, reciever and other CEC-compliant
+HDMI devices from a python script on a computer.
+
+WWW: https://github.com/trainman419/python-cec