aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorPierre Beyssac <pb@FreeBSD.org>2003-12-17 01:00:03 +0000
committerPierre Beyssac <pb@FreeBSD.org>2003-12-17 01:00:03 +0000
commitafed8f3d61a91ab053485d31e84afe0bf8b0a9ec (patch)
tree083ad99c0b0a8ceda138423334186b6c87e2304b /multimedia
parenta8152567b7fe2bde7878bfcb4bddf1c4657b9cf8 (diff)
downloadports-afed8f3d61a91ab053485d31e84afe0bf8b0a9ec.tar.gz
ports-afed8f3d61a91ab053485d31e84afe0bf8b0a9ec.zip
Update to 0.6.8.
Notes
Notes: svn path=/head/; revision=95990
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/dvdauthor/Makefile6
-rw-r--r--multimedia/dvdauthor/distinfo2
-rw-r--r--multimedia/dvdauthor/files/patch-Makefile.in10
-rw-r--r--multimedia/dvdauthor/files/patch-da-internal.h11
-rw-r--r--multimedia/dvdauthor/files/patch-dvdcompile.c12
-rw-r--r--multimedia/dvdauthor/files/patch-subfont.c10
-rw-r--r--multimedia/dvdauthor/files/patch-subrender.c16
-rw-r--r--multimedia/dvdauthor/files/patch-textsub.c10
-rw-r--r--multimedia/dvdauthor/pkg-plist5
9 files changed, 77 insertions, 5 deletions
diff --git a/multimedia/dvdauthor/Makefile b/multimedia/dvdauthor/Makefile
index 641f05ec83e9..c7868f030bdd 100644
--- a/multimedia/dvdauthor/Makefile
+++ b/multimedia/dvdauthor/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dvdauthor
-PORTVERSION= 0.6.6
+PORTVERSION= 0.6.8
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -30,9 +30,9 @@ post-install:
${MKDIR} ${PREFIX}/share/doc/dvdauthor
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/dvdauthor
${INSTALL_DATA} ${FILESDIR}/README.FreeBSD ${PREFIX}/share/doc/dvdauthor
- ${INSTALL_DATA} ${WRKSRC}/iso639.txt ${PREFIX}/share/doc/dvdauthor
+ ${INSTALL_DATA} ${WRKSRC}/lib.txt ${PREFIX}/share/doc/dvdauthor
${INSTALL_DATA} ${WRKSRC}/menu.txt ${PREFIX}/share/doc/dvdauthor
- for i in dvdauthor ex-title examples index manpages spumux; do \
+ for i in dvdauthor ex-title examples index languages manpages spumux; do \
${INSTALL_DATA} ${WRKSRC}/doc/$$i.html ${PREFIX}/share/doc/dvdauthor; \
done
.endif
diff --git a/multimedia/dvdauthor/distinfo b/multimedia/dvdauthor/distinfo
index 8ad5368a7df4..17c0ef23b6f6 100644
--- a/multimedia/dvdauthor/distinfo
+++ b/multimedia/dvdauthor/distinfo
@@ -1 +1 @@
-MD5 (dvdauthor-0.6.6.tar.gz) = 84a63dfab85ef9771e5b6afc984e6125
+MD5 (dvdauthor-0.6.8.tar.gz) = b4e591f28e5f7d10623104fba2d08ef3
diff --git a/multimedia/dvdauthor/files/patch-Makefile.in b/multimedia/dvdauthor/files/patch-Makefile.in
new file mode 100644
index 000000000000..c85398be3d0e
--- /dev/null
+++ b/multimedia/dvdauthor/files/patch-Makefile.in
@@ -0,0 +1,10 @@
+--- Makefile.in.orig Thu Dec 11 19:52:20 2003
++++ Makefile.in Wed Dec 17 00:58:53 2003
+@@ -13,6 +13,7 @@
+ FLEX=flex
+
+ CPPFLAGS = -DSYSCONFDIR="\"$(sysconfdir)\""
++LDFLAGS += -L@libdir@
+ LIBS = @LIBS@
+ XML_LIBS = @XML_LIBS@
+ MAGICK_LIBS = @MAGICK_LIBS@
diff --git a/multimedia/dvdauthor/files/patch-da-internal.h b/multimedia/dvdauthor/files/patch-da-internal.h
new file mode 100644
index 000000000000..3a6abc7b71d2
--- /dev/null
+++ b/multimedia/dvdauthor/files/patch-da-internal.h
@@ -0,0 +1,11 @@
+--- src/da-internal.h.orig Tue Dec 9 22:43:52 2003
++++ src/da-internal.h Wed Dec 17 00:28:03 2003
+@@ -20,6 +20,8 @@
+ #ifndef __DA_INTERNAL_H_
+ #define __DA_INTERNAL_H_
+
++#include <sys/types.h>
++
+ enum {VM_NONE=0,VM_MPEG1=1,VM_MPEG2=2};
+ enum {VS_NONE=0,VS_720H=1,VS_704H=2,VS_352H=3,VS_352L=4};
+ enum {VF_NONE=0,VF_NTSC=1,VF_PAL=2};
diff --git a/multimedia/dvdauthor/files/patch-dvdcompile.c b/multimedia/dvdauthor/files/patch-dvdcompile.c
new file mode 100644
index 000000000000..b7c77cde21f5
--- /dev/null
+++ b/multimedia/dvdauthor/files/patch-dvdcompile.c
@@ -0,0 +1,12 @@
+--- src/dvdcompile.c.orig Sat Dec 6 04:44:53 2003
++++ src/dvdcompile.c Wed Dec 17 01:51:22 2003
+@@ -20,7 +20,9 @@
+ #include "config.h"
+
+ #include <stdio.h>
++#ifdef HAVE_STDINT
+ #include <stdint.h>
++#endif
+
+ #include "dvdauthor.h"
+ #include "da-internal.h"
diff --git a/multimedia/dvdauthor/files/patch-subfont.c b/multimedia/dvdauthor/files/patch-subfont.c
new file mode 100644
index 000000000000..ee9ffd425566
--- /dev/null
+++ b/multimedia/dvdauthor/files/patch-subfont.c
@@ -0,0 +1,10 @@
+--- src/subfont.c.orig Sat Dec 6 06:01:08 2003
++++ src/subfont.c Wed Dec 17 01:44:32 2003
+@@ -41,6 +41,7 @@
+ #include <stdlib.h>
+ #include <math.h>
+ #include <string.h>
++#include <sys/types.h>
+
+ #include <iconv.h>
+
diff --git a/multimedia/dvdauthor/files/patch-subrender.c b/multimedia/dvdauthor/files/patch-subrender.c
new file mode 100644
index 000000000000..c0045bcb96ac
--- /dev/null
+++ b/multimedia/dvdauthor/files/patch-subrender.c
@@ -0,0 +1,16 @@
+--- src/subrender.c.orig Sun Dec 14 19:20:54 2003
++++ src/subrender.c Wed Dec 17 00:37:46 2003
+@@ -25,11 +25,12 @@
+
+ #include "config.h"
+
+-#include <malloc.h>
++/* #include <malloc.h> */
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+
++#include "compat.h"
+ #include "subconfig.h"
+
+ #include "subglobals.h"
diff --git a/multimedia/dvdauthor/files/patch-textsub.c b/multimedia/dvdauthor/files/patch-textsub.c
new file mode 100644
index 000000000000..469ce27d1b2e
--- /dev/null
+++ b/multimedia/dvdauthor/files/patch-textsub.c
@@ -0,0 +1,10 @@
+--- src/textsub.c.orig Sun Dec 14 19:20:55 2003
++++ src/textsub.c Wed Dec 17 00:28:39 2003
+@@ -34,6 +34,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <strings.h>
++#include <sys/types.h>
+
+ #undef TEXTSUB_DEBUG
+
diff --git a/multimedia/dvdauthor/pkg-plist b/multimedia/dvdauthor/pkg-plist
index 9927cc8a5814..9c8e86d9f1ca 100644
--- a/multimedia/dvdauthor/pkg-plist
+++ b/multimedia/dvdauthor/pkg-plist
@@ -1,14 +1,17 @@
bin/dvdauthor
bin/dvddirgen
+bin/dvdunauthor
bin/mpeg2desc
bin/spumux
+bin/spuunmux
%%PORTDOCS%%share/doc/dvdauthor/README
%%PORTDOCS%%share/doc/dvdauthor/README.FreeBSD
%%PORTDOCS%%share/doc/dvdauthor/dvdauthor.html
%%PORTDOCS%%share/doc/dvdauthor/ex-title.html
%%PORTDOCS%%share/doc/dvdauthor/examples.html
%%PORTDOCS%%share/doc/dvdauthor/index.html
-%%PORTDOCS%%share/doc/dvdauthor/iso639.txt
+%%PORTDOCS%%share/doc/dvdauthor/languages.html
+%%PORTDOCS%%share/doc/dvdauthor/lib.txt
%%PORTDOCS%%share/doc/dvdauthor/manpages.html
%%PORTDOCS%%share/doc/dvdauthor/menu.txt
%%PORTDOCS%%share/doc/dvdauthor/spumux.html