aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2005-01-09 19:12:20 +0000
committerKoop Mast <kwm@FreeBSD.org>2005-01-09 19:12:20 +0000
commitcd38be476bd5caa5871ad33302496148ce66c84a (patch)
tree09d0583e88bd6d244bd3beed5f3e96afc0019267 /multimedia
parent5c148c78ecc25e961571bba09ed2f3838fbad421 (diff)
downloadports-cd38be476bd5caa5871ad33302496148ce66c84a.tar.gz
ports-cd38be476bd5caa5871ad33302496148ce66c84a.zip
Update to 0.8.7.
Changelog: http://gstreamer.freedesktop.org/releases/gst-plugins/0.8.7.html Chase polypaudio lib bump. Approved by: maintainer (implicit)
Notes
Notes: svn path=/head/; revision=125992
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gstreamer-plugins/Makefile59
-rw-r--r--multimedia/gstreamer-plugins/distinfo4
-rw-r--r--multimedia/gstreamer-plugins/files/patch-ext_musepack_gstmusepackdec.cpp61
-rw-r--r--multimedia/gstreamer-plugins/files/patch-gst_tta_gstttaparse.c20
-rw-r--r--multimedia/gstreamer-plugins/pkg-plist6
-rw-r--r--multimedia/gstreamer-plugins80/Makefile59
-rw-r--r--multimedia/gstreamer-plugins80/distinfo4
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-ext_musepack_gstmusepackdec.cpp61
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-gst_tta_gstttaparse.c20
-rw-r--r--multimedia/gstreamer-plugins80/pkg-plist6
10 files changed, 146 insertions, 154 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index aeac41753f59..ce812136fcd4 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gstreamer
-PORTVERSION= 0.8.6
-PORTREVISION= 1
+PORTVERSION= 0.8.7
CATEGORIES= multimedia audio
MASTER_SITES= http://gstreamer.freedesktop.org/src/gst-plugins/ \
${MASTER_SITE_GNOME}
@@ -142,10 +141,6 @@ post-patch:
${WRKSRC}/sys/vcd/vcdsrc.c \
${WRKSRC}/sys/vcd/vcdsrc.h
-# tell configure where the musepack includes live
- @${REINPLACE_CMD} -e 's|/usr/include/musepack|${LOCALBASE}/include/musepack|g' \
- ${WRKSRC}/configure
-
# hermes is required for gstreamer-player to work
# since it is currently the only colorspace plugin available
# XXX However, it currently does not work on sparc64.
@@ -171,6 +166,11 @@ WITH_AALIB=yes
WITH_ARTS=yes
.endif
+# cairo
+.if exists(${LOCALBASE}/lib/libcairo.a)
+WITH_CAIRO=yes
+.endif
+
# cdparanoia
.if exists(${LOCALBASE}/lib/libcdda_paranoia.a)
WITH_CDPARANOIA=yes
@@ -236,6 +236,11 @@ WITH_LIBCACA=yes
WITH_MNG=yes
.endif
+# libmms
+.if exists(${LOCALBASE}/lib/libmms.a)
+WITH_MMS=yes
+.endif
+
# gsm
.if exists(${LOCALBASE}/lib/libgsm.a)
WITH_GSM=yes
@@ -367,7 +372,7 @@ WITH_PNG=yes
.endif
# polypaudio
-.if exists(${LOCALBASE}/lib/libpolyp-0.6.a)
+.if exists(${LOCALBASE}/lib/libpolyp-0.7.a)
WITH_POLYPAUDIO=yes
.endif
@@ -443,6 +448,16 @@ CONFIGURE_ARGS+= --with-arts-prefix=${LOCALBASE} \
PLIST_SUB+= ARTS=""
.endif
+# cairo
+.ifndef(WITH_CAIRO)
+CONFIGURE_ARGS+= --disable-cairo
+PLIST_SUB+= CAIRO="@comment "
+.else
+LIB_DEPENDS+= cairo.1:${PORTSDIR}/graphics/cairo
+
+PLIST_SUB+= CAIRO=""
+.endif
+
# cdparanoia
.ifndef(WITH_CDPARANOIA)
CONFIGURE_ARGS+= --disable-cdparanoia
@@ -858,6 +873,15 @@ LIB_DEPENDS+= mng.1:${PORTSDIR}/graphics/libmng
PLIST_SUB+= MNG=""
.endif
+# mms
+.ifndef(WITH_MMS)
+CONFIGURE_ARGS+= --disable-libmms
+PLIST_SUB+= MMS="@comment "
+.else
+LIB_DEPENDS+= mms.0:${PORTSDIR}/net/libmms
+PLIST_SUB+= MMS=""
+.endif
+
# png
.ifndef(WITH_PNG)
CONFIGURE_ARGS+= --disable-libpng
@@ -873,7 +897,7 @@ PLIST_SUB+= PNG=""
CONFIGURE_ARGS+= --disable-polyp
PLIST_SUB+= POLYPAUDIO="@comment "
.else
-LIB_DEPENDS+= polyp-0.6.0:${PORTSDIR}/audio/polypaudio
+LIB_DEPENDS+= polyp-0.7.0:${PORTSDIR}/audio/polypaudio
PLIST_SUB+= POLYPAUDIO=""
.endif
@@ -902,14 +926,13 @@ PLIST_SUB+= SMOOTHWAVE=""
.endif
# speex
-# !!!BROKEN RIGHT NOW!!! - need -devel speex
-#.ifndef(WITH_SPEEX)
+.ifndef(WITH_SPEEX)
CONFIGURE_ARGS+= --disable-speex
PLIST_SUB+= SPEEX="@comment "
-#.else
-#LIB_DEPENDS+= speex.3:${PORTSDIR}/audio/speex
-#PLIST_SUB+= SPEEX=""
-#.endif
+.else
+LIB_DEPENDS+= speex.3:${PORTSDIR}/audio/speex
+PLIST_SUB+= SPEEX=""
+.endif
# swfdec
.ifndef(WITH_SWFDEC)
@@ -1004,6 +1027,10 @@ pre-everything::
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_ARTS to enable aRts Audio plugin'
.endif
+.ifndef(WITH_CAIRO)
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> Define WITH_CDPARANOIA to enable cairo textoverlay plugin'
+.endif
.ifndef(WITH_CDPARANOIA)
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_CDPARANOIA to enable cdparanoia Audio plugin'
@@ -1148,6 +1175,10 @@ pre-everything::
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_MNG to enable libmng plugin'
.endif
+.ifndef(WITH_MMS)
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> Define WITH_MMS to enable libmms network plugin'
+.endif
.ifndef(WITH_MUSEPACK)
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_MUSEPACK to enable musepack Audio plugin'
diff --git a/multimedia/gstreamer-plugins/distinfo b/multimedia/gstreamer-plugins/distinfo
index 1c4d6a648cc2..c52424ac1d87 100644
--- a/multimedia/gstreamer-plugins/distinfo
+++ b/multimedia/gstreamer-plugins/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gst-plugins-0.8.6.tar.bz2) = e6b04215e7d928bd2fcce390ab406ffd
-SIZE (gnome2/gst-plugins-0.8.6.tar.bz2) = 2033762
+MD5 (gnome2/gst-plugins-0.8.7.tar.bz2) = 24030f8664b0e6f39bc31616f4953af5
+SIZE (gnome2/gst-plugins-0.8.7.tar.bz2) = 2134878
diff --git a/multimedia/gstreamer-plugins/files/patch-ext_musepack_gstmusepackdec.cpp b/multimedia/gstreamer-plugins/files/patch-ext_musepack_gstmusepackdec.cpp
deleted file mode 100644
index 1b1799ca9a98..000000000000
--- a/multimedia/gstreamer-plugins/files/patch-ext_musepack_gstmusepackdec.cpp
+++ /dev/null
@@ -1,61 +0,0 @@
---- ext/musepack/gstmusepackdec.cpp.orig Sun Nov 7 19:30:06 2004
-+++ ext/musepack/gstmusepackdec.cpp Thu Dec 16 16:31:42 2004
-@@ -30,14 +30,24 @@
- GST_STATIC_CAPS ("audio/x-musepack")
- );
-
-+#ifdef MPC_FIXED_POINT
-+#define BASE_CAPS \
-+ "audio/x-raw-int, " \
-+ "signed = (bool) TRUE, " \
-+ "width = (int) 32, " \
-+ "depth = (int) 32"
-+#else
-+#define BASE_CAPS \
-+ "audio/x-raw-float, " \
-+ "width = (int) 32, " \
-+ "buffer-frames = (int) 0"
-+#endif
-+
- static GstStaticPadTemplate src_template = GST_STATIC_PAD_TEMPLATE ("src",
- GST_PAD_SRC,
- GST_PAD_ALWAYS,
-- GST_STATIC_CAPS ("audio/x-raw-int, "
-+ GST_STATIC_CAPS (BASE_CAPS ", "
- "endianness = (int) BYTE_ORDER, "
-- "signed = (bool) TRUE, "
-- "width = (int) 32, "
-- "depth = (int) 32, "
- "rate = (int) [ 8000, 96000 ], "
- "channels = (int) [ 1, 2 ]")
- );
-@@ -352,6 +362,7 @@
- gst_musepack_stream_init (GstMusepackDec * musepackdec)
- {
- StreamInfo si = StreamInfo ();
-+ GstCaps *caps;
-
- if (musepackdec->dec)
- delete musepackdec->dec;
-@@ -379,15 +390,12 @@
- return FALSE;
- }
-
-- if (!gst_pad_set_explicit_caps (musepackdec->srcpad,
-- gst_caps_new_simple ("audio/x-raw-int",
-- "width", G_TYPE_INT, 32,
-- "depth", G_TYPE_INT, 32,
-- "endianness", G_TYPE_INT, G_BYTE_ORDER,
-- "channels", G_TYPE_INT, si.simple.Channels,
-- "rate", G_TYPE_INT, si.simple.SampleFreq,
-- "signed", G_TYPE_BOOLEAN, TRUE,
-- NULL))) {
-+ caps = gst_caps_from_string (BASE_CAPS);
-+ gst_caps_set_simple (caps,
-+ "endianness", G_TYPE_INT, G_BYTE_ORDER,
-+ "channels", G_TYPE_INT, si.simple.Channels,
-+ "rate", G_TYPE_INT, si.simple.SampleFreq, NULL);
-+ if (!gst_pad_set_explicit_caps (musepackdec->srcpad, caps)) {
- GST_ELEMENT_ERROR (musepackdec, CORE, NEGOTIATION, (NULL), (NULL));
- delete musepackdec->dec;
- musepackdec->dec = NULL;
diff --git a/multimedia/gstreamer-plugins/files/patch-gst_tta_gstttaparse.c b/multimedia/gstreamer-plugins/files/patch-gst_tta_gstttaparse.c
new file mode 100644
index 000000000000..d595b086bff5
--- /dev/null
+++ b/multimedia/gstreamer-plugins/files/patch-gst_tta_gstttaparse.c
@@ -0,0 +1,20 @@
+--- gst/tta/gstttaparse.c.orig Sun Jan 9 13:59:02 2005
++++ gst/tta/gstttaparse.c Sun Jan 9 14:02:25 2005
+@@ -162,11 +162,13 @@
+ case GST_EVENT_SEEK:
+ {
+ if (GST_EVENT_SEEK_FORMAT (event) == GST_FORMAT_TIME) {
+- GST_DEBUG_OBJECT (ttaparse, "got seek event");
+ GstEvent *seek_event;
+- guint64 time = GST_EVENT_SEEK_OFFSET (event);
+- guint64 seek_frame = time / (FRAME_TIME * 1000000000);
+- guint64 seekpos = ttaparse->index[seek_frame].pos;
++ guint64 time;
++ guint64 seek_frame;
++ guint64 seekpos;
++ time = GST_EVENT_SEEK_OFFSET (event);
++ seek_frame = time / (FRAME_TIME * 1000000000);
++ seekpos = ttaparse->index[seek_frame].pos;
+
+ GST_DEBUG_OBJECT (ttaparse, "seeking to %u", (guint) seekpos);
+ seek_event =
diff --git a/multimedia/gstreamer-plugins/pkg-plist b/multimedia/gstreamer-plugins/pkg-plist
index b258cd10acaf..f8ecfd06e69e 100644
--- a/multimedia/gstreamer-plugins/pkg-plist
+++ b/multimedia/gstreamer-plugins/pkg-plist
@@ -3,6 +3,8 @@ bin/gst-visualise-%%VERSION%%
include/gstreamer-%%VERSION%%/gst/audio/gstaudiofilter.h
include/gstreamer-%%VERSION%%/gst/audio/audioclock.h
include/gstreamer-%%VERSION%%/gst/audio/audio.h
+include/gstreamer-%%VERSION%%/gst/audio/multichannel-enumtypes.h
+include/gstreamer-%%VERSION%%/gst/audio/multichannel.h
include/gstreamer-%%VERSION%%/gst/colorbalance/colorbalance-enumtypes.h
include/gstreamer-%%VERSION%%/gst/colorbalance/colorbalance.h
include/gstreamer-%%VERSION%%/gst/colorbalance/colorbalancechannel.h
@@ -38,6 +40,7 @@ lib/gstreamer-%%VERSION%%/libgstadder.so
lib/gstreamer-%%VERSION%%/libgstalaw.so
lib/gstreamer-%%VERSION%%/libgstalpha.so
lib/gstreamer-%%VERSION%%/libgstalphacolor.so
+lib/gstreamer-%%VERSION%%/libgstapetag.so
%%ARTS%%lib/gstreamer-%%VERSION%%/libgstartsdsink.so
lib/gstreamer-%%VERSION%%/libgstasf.so
lib/gstreamer-%%VERSION%%/libgstaudioconvert.so
@@ -49,6 +52,7 @@ lib/gstreamer-%%VERSION%%/libgstaudioscale.so
lib/gstreamer-%%VERSION%%/libgstauparse.so
lib/gstreamer-%%VERSION%%/libgstavi.so
%%LIBCACA%%lib/gstreamer-%%VERSION%%/libgstcacasink.so
+%%CAIRO%%lib/gstreamer-%%VERSION%%/libgstcairo.so
%%LIBCDAUDIO%%lib/gstreamer-%%VERSION%%/libgstcdaudio.so
%%CDPARANOIA%%lib/gstreamer-%%VERSION%%/libgstcdparanoia.so
lib/gstreamer-%%VERSION%%/libgstcdplayer.so
@@ -107,6 +111,7 @@ lib/gstreamer-%%VERSION%%/libgstmpegaudio.so
lib/gstreamer-%%VERSION%%/libgstmpegaudioparse.so
lib/gstreamer-%%VERSION%%/libgstmpegstream.so
%%MNG%%lib/gstreamer-%%VERSION%%/libgstmng.so
+%%MMS%%lib/gstreamer-%%VERSION%%/libgstmms.so
%%MJPEGTOOLS%%lib/gstreamer-%%VERSION%%/libgstmplex.so
lib/gstreamer-%%VERSION%%/libgstmulaw.so
lib/gstreamer-%%VERSION%%/libgstmultifilesink.so
@@ -150,6 +155,7 @@ lib/gstreamer-%%VERSION%%/libgsttextoverlay.so
%%LIBTHEORA%%lib/gstreamer-%%VERSION%%/libgsttheora.so
lib/gstreamer-%%VERSION%%/libgsttimeoverlay.so
%%LIBMUSICBRAINZ%%lib/gstreamer-%%VERSION%%/libgsttrm.so
+lib/gstreamer-%%VERSION%%/libgsttta.so
lib/gstreamer-%%VERSION%%/libgsttypefindfunctions.so
lib/gstreamer-%%VERSION%%/libgstudp.so
lib/gstreamer-%%VERSION%%/libgstvbidec.so
diff --git a/multimedia/gstreamer-plugins80/Makefile b/multimedia/gstreamer-plugins80/Makefile
index aeac41753f59..ce812136fcd4 100644
--- a/multimedia/gstreamer-plugins80/Makefile
+++ b/multimedia/gstreamer-plugins80/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gstreamer
-PORTVERSION= 0.8.6
-PORTREVISION= 1
+PORTVERSION= 0.8.7
CATEGORIES= multimedia audio
MASTER_SITES= http://gstreamer.freedesktop.org/src/gst-plugins/ \
${MASTER_SITE_GNOME}
@@ -142,10 +141,6 @@ post-patch:
${WRKSRC}/sys/vcd/vcdsrc.c \
${WRKSRC}/sys/vcd/vcdsrc.h
-# tell configure where the musepack includes live
- @${REINPLACE_CMD} -e 's|/usr/include/musepack|${LOCALBASE}/include/musepack|g' \
- ${WRKSRC}/configure
-
# hermes is required for gstreamer-player to work
# since it is currently the only colorspace plugin available
# XXX However, it currently does not work on sparc64.
@@ -171,6 +166,11 @@ WITH_AALIB=yes
WITH_ARTS=yes
.endif
+# cairo
+.if exists(${LOCALBASE}/lib/libcairo.a)
+WITH_CAIRO=yes
+.endif
+
# cdparanoia
.if exists(${LOCALBASE}/lib/libcdda_paranoia.a)
WITH_CDPARANOIA=yes
@@ -236,6 +236,11 @@ WITH_LIBCACA=yes
WITH_MNG=yes
.endif
+# libmms
+.if exists(${LOCALBASE}/lib/libmms.a)
+WITH_MMS=yes
+.endif
+
# gsm
.if exists(${LOCALBASE}/lib/libgsm.a)
WITH_GSM=yes
@@ -367,7 +372,7 @@ WITH_PNG=yes
.endif
# polypaudio
-.if exists(${LOCALBASE}/lib/libpolyp-0.6.a)
+.if exists(${LOCALBASE}/lib/libpolyp-0.7.a)
WITH_POLYPAUDIO=yes
.endif
@@ -443,6 +448,16 @@ CONFIGURE_ARGS+= --with-arts-prefix=${LOCALBASE} \
PLIST_SUB+= ARTS=""
.endif
+# cairo
+.ifndef(WITH_CAIRO)
+CONFIGURE_ARGS+= --disable-cairo
+PLIST_SUB+= CAIRO="@comment "
+.else
+LIB_DEPENDS+= cairo.1:${PORTSDIR}/graphics/cairo
+
+PLIST_SUB+= CAIRO=""
+.endif
+
# cdparanoia
.ifndef(WITH_CDPARANOIA)
CONFIGURE_ARGS+= --disable-cdparanoia
@@ -858,6 +873,15 @@ LIB_DEPENDS+= mng.1:${PORTSDIR}/graphics/libmng
PLIST_SUB+= MNG=""
.endif
+# mms
+.ifndef(WITH_MMS)
+CONFIGURE_ARGS+= --disable-libmms
+PLIST_SUB+= MMS="@comment "
+.else
+LIB_DEPENDS+= mms.0:${PORTSDIR}/net/libmms
+PLIST_SUB+= MMS=""
+.endif
+
# png
.ifndef(WITH_PNG)
CONFIGURE_ARGS+= --disable-libpng
@@ -873,7 +897,7 @@ PLIST_SUB+= PNG=""
CONFIGURE_ARGS+= --disable-polyp
PLIST_SUB+= POLYPAUDIO="@comment "
.else
-LIB_DEPENDS+= polyp-0.6.0:${PORTSDIR}/audio/polypaudio
+LIB_DEPENDS+= polyp-0.7.0:${PORTSDIR}/audio/polypaudio
PLIST_SUB+= POLYPAUDIO=""
.endif
@@ -902,14 +926,13 @@ PLIST_SUB+= SMOOTHWAVE=""
.endif
# speex
-# !!!BROKEN RIGHT NOW!!! - need -devel speex
-#.ifndef(WITH_SPEEX)
+.ifndef(WITH_SPEEX)
CONFIGURE_ARGS+= --disable-speex
PLIST_SUB+= SPEEX="@comment "
-#.else
-#LIB_DEPENDS+= speex.3:${PORTSDIR}/audio/speex
-#PLIST_SUB+= SPEEX=""
-#.endif
+.else
+LIB_DEPENDS+= speex.3:${PORTSDIR}/audio/speex
+PLIST_SUB+= SPEEX=""
+.endif
# swfdec
.ifndef(WITH_SWFDEC)
@@ -1004,6 +1027,10 @@ pre-everything::
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_ARTS to enable aRts Audio plugin'
.endif
+.ifndef(WITH_CAIRO)
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> Define WITH_CDPARANOIA to enable cairo textoverlay plugin'
+.endif
.ifndef(WITH_CDPARANOIA)
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_CDPARANOIA to enable cdparanoia Audio plugin'
@@ -1148,6 +1175,10 @@ pre-everything::
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_MNG to enable libmng plugin'
.endif
+.ifndef(WITH_MMS)
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> Define WITH_MMS to enable libmms network plugin'
+.endif
.ifndef(WITH_MUSEPACK)
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_MUSEPACK to enable musepack Audio plugin'
diff --git a/multimedia/gstreamer-plugins80/distinfo b/multimedia/gstreamer-plugins80/distinfo
index 1c4d6a648cc2..c52424ac1d87 100644
--- a/multimedia/gstreamer-plugins80/distinfo
+++ b/multimedia/gstreamer-plugins80/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gst-plugins-0.8.6.tar.bz2) = e6b04215e7d928bd2fcce390ab406ffd
-SIZE (gnome2/gst-plugins-0.8.6.tar.bz2) = 2033762
+MD5 (gnome2/gst-plugins-0.8.7.tar.bz2) = 24030f8664b0e6f39bc31616f4953af5
+SIZE (gnome2/gst-plugins-0.8.7.tar.bz2) = 2134878
diff --git a/multimedia/gstreamer-plugins80/files/patch-ext_musepack_gstmusepackdec.cpp b/multimedia/gstreamer-plugins80/files/patch-ext_musepack_gstmusepackdec.cpp
deleted file mode 100644
index 1b1799ca9a98..000000000000
--- a/multimedia/gstreamer-plugins80/files/patch-ext_musepack_gstmusepackdec.cpp
+++ /dev/null
@@ -1,61 +0,0 @@
---- ext/musepack/gstmusepackdec.cpp.orig Sun Nov 7 19:30:06 2004
-+++ ext/musepack/gstmusepackdec.cpp Thu Dec 16 16:31:42 2004
-@@ -30,14 +30,24 @@
- GST_STATIC_CAPS ("audio/x-musepack")
- );
-
-+#ifdef MPC_FIXED_POINT
-+#define BASE_CAPS \
-+ "audio/x-raw-int, " \
-+ "signed = (bool) TRUE, " \
-+ "width = (int) 32, " \
-+ "depth = (int) 32"
-+#else
-+#define BASE_CAPS \
-+ "audio/x-raw-float, " \
-+ "width = (int) 32, " \
-+ "buffer-frames = (int) 0"
-+#endif
-+
- static GstStaticPadTemplate src_template = GST_STATIC_PAD_TEMPLATE ("src",
- GST_PAD_SRC,
- GST_PAD_ALWAYS,
-- GST_STATIC_CAPS ("audio/x-raw-int, "
-+ GST_STATIC_CAPS (BASE_CAPS ", "
- "endianness = (int) BYTE_ORDER, "
-- "signed = (bool) TRUE, "
-- "width = (int) 32, "
-- "depth = (int) 32, "
- "rate = (int) [ 8000, 96000 ], "
- "channels = (int) [ 1, 2 ]")
- );
-@@ -352,6 +362,7 @@
- gst_musepack_stream_init (GstMusepackDec * musepackdec)
- {
- StreamInfo si = StreamInfo ();
-+ GstCaps *caps;
-
- if (musepackdec->dec)
- delete musepackdec->dec;
-@@ -379,15 +390,12 @@
- return FALSE;
- }
-
-- if (!gst_pad_set_explicit_caps (musepackdec->srcpad,
-- gst_caps_new_simple ("audio/x-raw-int",
-- "width", G_TYPE_INT, 32,
-- "depth", G_TYPE_INT, 32,
-- "endianness", G_TYPE_INT, G_BYTE_ORDER,
-- "channels", G_TYPE_INT, si.simple.Channels,
-- "rate", G_TYPE_INT, si.simple.SampleFreq,
-- "signed", G_TYPE_BOOLEAN, TRUE,
-- NULL))) {
-+ caps = gst_caps_from_string (BASE_CAPS);
-+ gst_caps_set_simple (caps,
-+ "endianness", G_TYPE_INT, G_BYTE_ORDER,
-+ "channels", G_TYPE_INT, si.simple.Channels,
-+ "rate", G_TYPE_INT, si.simple.SampleFreq, NULL);
-+ if (!gst_pad_set_explicit_caps (musepackdec->srcpad, caps)) {
- GST_ELEMENT_ERROR (musepackdec, CORE, NEGOTIATION, (NULL), (NULL));
- delete musepackdec->dec;
- musepackdec->dec = NULL;
diff --git a/multimedia/gstreamer-plugins80/files/patch-gst_tta_gstttaparse.c b/multimedia/gstreamer-plugins80/files/patch-gst_tta_gstttaparse.c
new file mode 100644
index 000000000000..d595b086bff5
--- /dev/null
+++ b/multimedia/gstreamer-plugins80/files/patch-gst_tta_gstttaparse.c
@@ -0,0 +1,20 @@
+--- gst/tta/gstttaparse.c.orig Sun Jan 9 13:59:02 2005
++++ gst/tta/gstttaparse.c Sun Jan 9 14:02:25 2005
+@@ -162,11 +162,13 @@
+ case GST_EVENT_SEEK:
+ {
+ if (GST_EVENT_SEEK_FORMAT (event) == GST_FORMAT_TIME) {
+- GST_DEBUG_OBJECT (ttaparse, "got seek event");
+ GstEvent *seek_event;
+- guint64 time = GST_EVENT_SEEK_OFFSET (event);
+- guint64 seek_frame = time / (FRAME_TIME * 1000000000);
+- guint64 seekpos = ttaparse->index[seek_frame].pos;
++ guint64 time;
++ guint64 seek_frame;
++ guint64 seekpos;
++ time = GST_EVENT_SEEK_OFFSET (event);
++ seek_frame = time / (FRAME_TIME * 1000000000);
++ seekpos = ttaparse->index[seek_frame].pos;
+
+ GST_DEBUG_OBJECT (ttaparse, "seeking to %u", (guint) seekpos);
+ seek_event =
diff --git a/multimedia/gstreamer-plugins80/pkg-plist b/multimedia/gstreamer-plugins80/pkg-plist
index b258cd10acaf..f8ecfd06e69e 100644
--- a/multimedia/gstreamer-plugins80/pkg-plist
+++ b/multimedia/gstreamer-plugins80/pkg-plist
@@ -3,6 +3,8 @@ bin/gst-visualise-%%VERSION%%
include/gstreamer-%%VERSION%%/gst/audio/gstaudiofilter.h
include/gstreamer-%%VERSION%%/gst/audio/audioclock.h
include/gstreamer-%%VERSION%%/gst/audio/audio.h
+include/gstreamer-%%VERSION%%/gst/audio/multichannel-enumtypes.h
+include/gstreamer-%%VERSION%%/gst/audio/multichannel.h
include/gstreamer-%%VERSION%%/gst/colorbalance/colorbalance-enumtypes.h
include/gstreamer-%%VERSION%%/gst/colorbalance/colorbalance.h
include/gstreamer-%%VERSION%%/gst/colorbalance/colorbalancechannel.h
@@ -38,6 +40,7 @@ lib/gstreamer-%%VERSION%%/libgstadder.so
lib/gstreamer-%%VERSION%%/libgstalaw.so
lib/gstreamer-%%VERSION%%/libgstalpha.so
lib/gstreamer-%%VERSION%%/libgstalphacolor.so
+lib/gstreamer-%%VERSION%%/libgstapetag.so
%%ARTS%%lib/gstreamer-%%VERSION%%/libgstartsdsink.so
lib/gstreamer-%%VERSION%%/libgstasf.so
lib/gstreamer-%%VERSION%%/libgstaudioconvert.so
@@ -49,6 +52,7 @@ lib/gstreamer-%%VERSION%%/libgstaudioscale.so
lib/gstreamer-%%VERSION%%/libgstauparse.so
lib/gstreamer-%%VERSION%%/libgstavi.so
%%LIBCACA%%lib/gstreamer-%%VERSION%%/libgstcacasink.so
+%%CAIRO%%lib/gstreamer-%%VERSION%%/libgstcairo.so
%%LIBCDAUDIO%%lib/gstreamer-%%VERSION%%/libgstcdaudio.so
%%CDPARANOIA%%lib/gstreamer-%%VERSION%%/libgstcdparanoia.so
lib/gstreamer-%%VERSION%%/libgstcdplayer.so
@@ -107,6 +111,7 @@ lib/gstreamer-%%VERSION%%/libgstmpegaudio.so
lib/gstreamer-%%VERSION%%/libgstmpegaudioparse.so
lib/gstreamer-%%VERSION%%/libgstmpegstream.so
%%MNG%%lib/gstreamer-%%VERSION%%/libgstmng.so
+%%MMS%%lib/gstreamer-%%VERSION%%/libgstmms.so
%%MJPEGTOOLS%%lib/gstreamer-%%VERSION%%/libgstmplex.so
lib/gstreamer-%%VERSION%%/libgstmulaw.so
lib/gstreamer-%%VERSION%%/libgstmultifilesink.so
@@ -150,6 +155,7 @@ lib/gstreamer-%%VERSION%%/libgsttextoverlay.so
%%LIBTHEORA%%lib/gstreamer-%%VERSION%%/libgsttheora.so
lib/gstreamer-%%VERSION%%/libgsttimeoverlay.so
%%LIBMUSICBRAINZ%%lib/gstreamer-%%VERSION%%/libgsttrm.so
+lib/gstreamer-%%VERSION%%/libgsttta.so
lib/gstreamer-%%VERSION%%/libgsttypefindfunctions.so
lib/gstreamer-%%VERSION%%/libgstudp.so
lib/gstreamer-%%VERSION%%/libgstvbidec.so