aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2014-02-17 22:34:40 +0000
committerThomas Zander <riggs@FreeBSD.org>2014-02-17 22:34:40 +0000
commitd73825cf2cb3c1f10b7d119c40b5d9fbc4245de9 (patch)
tree145df39f4ad119a39ec06ba13d3a951c7d1a98bc /multimedia
parent278314702d1ed1dfd7c469a185cfbc5a4abfbadb (diff)
downloadports-d73825cf2cb3c1f10b7d119c40b5d9fbc4245de9.tar.gz
ports-d73825cf2cb3c1f10b7d119c40b5d9fbc4245de9.zip
- Drop support for pre-8.3 systems
- Convert old LIB_DEPENDS to new format - Fix staging breakage for PREFIX!=LOCALBASE - Fix bug passing wrong CONFIGURE_ARGS when using DEBUG (causes dangling dependencies in debug builds) - Bump PORTREVISION - Update maintainer e-mail address Approved by: thierry (mentor) MFH: 2014Q1
Notes
Notes: svn path=/head/; revision=344827
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mencoder/Makefile2
-rw-r--r--multimedia/mplayer/Makefile8
-rw-r--r--multimedia/mplayer/Makefile.options6
-rw-r--r--multimedia/mplayer/Makefile.shared2
-rw-r--r--multimedia/mplayer/files/extra-patch-base_system_log2f21
5 files changed, 6 insertions, 33 deletions
diff --git a/multimedia/mencoder/Makefile b/multimedia/mencoder/Makefile
index f3d7b4d727c4..60334d74781d 100644
--- a/multimedia/mencoder/Makefile
+++ b/multimedia/mencoder/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mencoder
PORTVERSION= ${MPLAYER_PORT_VERSION}
-PORTREVISION= 0
+PORTREVISION= 1
COMMENT= Convenient video file and movie encoder
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 1fe972e06b18..0e67dddde693 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mplayer
PORTVERSION= ${MPLAYER_PORT_VERSION}
-PORTREVISION= 0
+PORTREVISION= 1
COMMENT= High performance media player supporting many formats
@@ -37,8 +37,6 @@ WIN32_DESC?= Install win32 binary codecs
X11DGA_DESC?= X11 DGA video driver support
X11VM_DESC?= X11 VidMode support
-#MANCOMPRESSED= no
-
SUB_FILES= pkg-message
CONFFILES= example.conf input.conf menu.conf dvb-menu.conf
@@ -96,7 +94,7 @@ CONFIGURE_ARGS+=--disable-dga1 --disable-dga2
.endif
.if ${PORT_OPTIONS:MOPENGL}
USE_XORG+= glproto
-LIB_DEPENDS+= GL:${PORTSDIR}/graphics/libGL
+LIB_DEPENDS+= libGL.so:${PORTSDIR}/graphics/libGL
.else
CONFIGURE_ARGS+=--disable-gl
.endif
@@ -178,7 +176,7 @@ post-install:
.if ${PORT_OPTIONS:MGUI} && ${PORT_OPTIONS:MX11}
@${LN} -sf ${PREFIX}/bin/mplayer ${STAGEDIR}${PREFIX}/bin/gmplayer
@(cd ${STAGEDIR}${MAN1PREFIX}/man/man1 && ${LN} -sf mplayer.1.gz gmplayer.1.gz)
- ${CP} -f ${WRKSRC}/etc/mplayer256x256.png ${STAGEDIR}${LOCALBASE}/share/pixmaps/mplayer.png
+ ${CP} -f ${WRKSRC}/etc/mplayer256x256.png ${STAGEDIR}${PREFIX}/share/pixmaps/mplayer.png
.endif
.include <bsd.port.post.mk>
diff --git a/multimedia/mplayer/Makefile.options b/multimedia/mplayer/Makefile.options
index b1cbf25dbc2c..be8b8b06759f 100644
--- a/multimedia/mplayer/Makefile.options
+++ b/multimedia/mplayer/Makefile.options
@@ -99,15 +99,11 @@ CONFIGURE_ARGS+= --disable-tv-v4l1 \
# Build system handling (including OPTIONS)
# =========================================
-.if ${OSVERSION} < 802502
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-base_system_log2f
-.endif
-
#On i386, gcc runs out of general purpose registers when
#trying to compile a debug version with the default flags.
.if ${PORT_OPTIONS:MDEBUG}
WITH_DEBUG= yes
-CONFIGURE_ARGS=+ --enable-debug
+CONFIGURE_ARGS+= --enable-debug
.if ${ARCH} == "i386"
DEBUG_FLAGS= -g -fomit-frame-pointer
.endif
diff --git a/multimedia/mplayer/Makefile.shared b/multimedia/mplayer/Makefile.shared
index 24cf770ed69c..8edc0befa86e 100644
--- a/multimedia/mplayer/Makefile.shared
+++ b/multimedia/mplayer/Makefile.shared
@@ -13,7 +13,7 @@ WRKSRC= ${WRKDIR}/mplayer-export-${MPLAYER_SNAPSHOT_DATE}
PROJECTHOST= bsdistfiles
-MAINTAINER?= thomas.e.zander@googlemail.com
+MAINTAINER?= riggs@FreeBSD.org
LICENSE= GPLv2
diff --git a/multimedia/mplayer/files/extra-patch-base_system_log2f b/multimedia/mplayer/files/extra-patch-base_system_log2f
deleted file mode 100644
index bbdab50dc75c..000000000000
--- a/multimedia/mplayer/files/extra-patch-base_system_log2f
+++ /dev/null
@@ -1,21 +0,0 @@
---- configure.orig 2013-03-03 11:29:18.000000000 +0100
-+++ configure 2013-03-08 19:04:01.903917043 +0100
-@@ -3265,7 +3265,7 @@
- echores "$_kstat"
-
-
--for func in atanf cbrt cbrtf cosf expf exp2 exp2f isnan isinf llrint llrintf log2 log2f log10f lrint lrintf rint round roundf sinf trunc truncf; do
-+for func in atanf cbrt cbrtf cosf expf exp2 exp2f isnan isinf llrint llrintf lrint lrintf rint round roundf sinf trunc truncf; do
- echocheck $func
- eval _$func=no
- statement_check math.h "${func}(2.0)" -D_ISOC99_SOURCE && eval _$func=yes
-@@ -3278,6 +3278,9 @@
- fi
- done
-
-+for func in log2 log2f log10f; do
-+ eval def_$func="\"#define HAVE_$(echo $func | tr '[a-z]' '[A-Z]') 0\""
-+done
-
- for func in atan2f ldexpf powf; do
- echocheck $func