aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-01-12 04:57:18 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-01-12 04:57:18 +0000
commitd98d8457f1ee7523a703f4c926f0d468ec73d535 (patch)
treeb9f246884207f914dae90b03b6a9c1562df7c09a /multimedia
parent4114f4b7dbaa9b7945b61de19737f12227d85c0a (diff)
downloadports-d98d8457f1ee7523a703f4c926f0d468ec73d535.tar.gz
ports-d98d8457f1ee7523a703f4c926f0d468ec73d535.zip
Add x264
x264 is a free library for encoding H.264/AVC video streams. Encoder features * CAVLC/CABAC * Multi-references * Intra: all modes (4x4 and 16x16 with all predictions) * Inter P: all partitions (from 16x16 down to 4x4) * Inter B: partitions from 16x16 down to 8x8 (including SKIP/DIRECT) * Ratecontrol: constant quantizer, constant bitrate, or multipass ABR * Scene cut detection
Notes
Notes: svn path=/head/; revision=126189
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/x264-devel/Makefile62
-rw-r--r--multimedia/x264-devel/distinfo2
-rw-r--r--multimedia/x264-devel/files/patch-Makefile12
-rw-r--r--multimedia/x264-devel/pkg-descr12
-rw-r--r--multimedia/x264/Makefile62
-rw-r--r--multimedia/x264/distinfo2
-rw-r--r--multimedia/x264/files/patch-Makefile12
-rw-r--r--multimedia/x264/pkg-descr12
9 files changed, 177 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 65fb858fbb97..565de5513149 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -141,6 +141,7 @@
SUBDIR += vcdtools
SUBDIR += vlc
SUBDIR += win32-codecs
+ SUBDIR += x264
SUBDIR += xanim
SUBDIR += xawtv
SUBDIR += xdvshow
diff --git a/multimedia/x264-devel/Makefile b/multimedia/x264-devel/Makefile
new file mode 100644
index 000000000000..e4d52ada9f1c
--- /dev/null
+++ b/multimedia/x264-devel/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: x264
+# Date created: 2005-01-11
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= x264
+PORTVERSION= 0.0.20041029
+CATEGORIES= multimedia
+MASTER_SITES= http://download.videolan.org/pub/videolan/contrib/ \
+ http://ftp.snt.utwente.nl/pub/software/videolan/contrib/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/0.0.//}
+
+MAINTAINER= ahze@FreeBSD.org
+COMMENT= Multimedia library for encoding H.264/AVC video streams
+
+BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
+
+USE_GETOPT_LONG=yes
+USE_BZIP2= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}
+USE_REINPLACE= yes
+USE_GMAKE= yes
+ALL_TARGET= default
+CFLAGS+= -DSYS_FREEBSD
+
+PLIST_FILES= bin/x264 \
+ lib/libx264.a
+
+OPTIONS= DEBUG "Enable Debugging" Off \
+ OPTIMIZED_CFLAGS "Enable Optimized CFLAGS" Off
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH}=="i386" || ${ARCH}=="amd64"
+CFLAGS+=-DARCH_X86
+.if ${MACHINE_CPU:Mmmx}
+CFLAGS+=-DHAVE_MMXEXT
+.endif
+.if ${MACHINE_CPU:Msse}
+CFLAGS+=-DHAVE_SSE2
+.endif
+.endif
+
+.if defined(WITH_DEBUG)
+CFLAGS+= -g -DDEBUG
+.endif
+
+.if defined(WITH_OPTIMIZED_CFLAGS)
+CFLAGS+= -O2 -funroll-loops
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%CFLAGS%%|${CFLAGS} ${CPPFLAGS}|; \
+ s|-lm|${LDFLAGS} -lm|' ${WRKSRC}/${MAKEFILE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/x264 ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/libx264.a ${PREFIX}/lib
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/x264-devel/distinfo b/multimedia/x264-devel/distinfo
new file mode 100644
index 000000000000..00bacf3bd281
--- /dev/null
+++ b/multimedia/x264-devel/distinfo
@@ -0,0 +1,2 @@
+MD5 (x264-20041029.tar.bz2) = 42a34fc79ba7d615db5a990110ce8e51
+SIZE (x264-20041029.tar.bz2) = 230695
diff --git a/multimedia/x264-devel/files/patch-Makefile b/multimedia/x264-devel/files/patch-Makefile
new file mode 100644
index 000000000000..5fd25a3f222d
--- /dev/null
+++ b/multimedia/x264-devel/files/patch-Makefile
@@ -0,0 +1,12 @@
+--- Makefile.orig Tue Jan 11 23:32:24 2005
++++ Makefile Tue Jan 11 23:33:05 2005
+@@ -22,8 +22,7 @@
+ OBJASM= $(ASMSRC:%.asm=%.o)
+ endif
+
+-CC=gcc
+-CFLAGS=-g -Wall -I. -DDEBUG -O4 -funroll-loops -D__X264__ $(PFLAGS)
++CFLAGS=-I. -D__X264__ %%CFLAGS%%
+
+ AS= nasm
+ # for linux
diff --git a/multimedia/x264-devel/pkg-descr b/multimedia/x264-devel/pkg-descr
new file mode 100644
index 000000000000..3e1bf1a0a3e2
--- /dev/null
+++ b/multimedia/x264-devel/pkg-descr
@@ -0,0 +1,12 @@
+x264 is a free library for encoding H.264/AVC video streams.
+
+Encoder features
+ * CAVLC/CABAC
+ * Multi-references
+ * Intra: all modes (4x4 and 16x16 with all predictions)
+ * Inter P: all partitions (from 16x16 down to 4x4)
+ * Inter B: partitions from 16x16 down to 8x8 (including SKIP/DIRECT)
+ * Ratecontrol: constant quantizer, constant bitrate, or multipass ABR
+ * Scene cut detection
+
+WWW: http://www.videolan.org/x264.html
diff --git a/multimedia/x264/Makefile b/multimedia/x264/Makefile
new file mode 100644
index 000000000000..e4d52ada9f1c
--- /dev/null
+++ b/multimedia/x264/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: x264
+# Date created: 2005-01-11
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= x264
+PORTVERSION= 0.0.20041029
+CATEGORIES= multimedia
+MASTER_SITES= http://download.videolan.org/pub/videolan/contrib/ \
+ http://ftp.snt.utwente.nl/pub/software/videolan/contrib/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/0.0.//}
+
+MAINTAINER= ahze@FreeBSD.org
+COMMENT= Multimedia library for encoding H.264/AVC video streams
+
+BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
+
+USE_GETOPT_LONG=yes
+USE_BZIP2= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}
+USE_REINPLACE= yes
+USE_GMAKE= yes
+ALL_TARGET= default
+CFLAGS+= -DSYS_FREEBSD
+
+PLIST_FILES= bin/x264 \
+ lib/libx264.a
+
+OPTIONS= DEBUG "Enable Debugging" Off \
+ OPTIMIZED_CFLAGS "Enable Optimized CFLAGS" Off
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH}=="i386" || ${ARCH}=="amd64"
+CFLAGS+=-DARCH_X86
+.if ${MACHINE_CPU:Mmmx}
+CFLAGS+=-DHAVE_MMXEXT
+.endif
+.if ${MACHINE_CPU:Msse}
+CFLAGS+=-DHAVE_SSE2
+.endif
+.endif
+
+.if defined(WITH_DEBUG)
+CFLAGS+= -g -DDEBUG
+.endif
+
+.if defined(WITH_OPTIMIZED_CFLAGS)
+CFLAGS+= -O2 -funroll-loops
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%CFLAGS%%|${CFLAGS} ${CPPFLAGS}|; \
+ s|-lm|${LDFLAGS} -lm|' ${WRKSRC}/${MAKEFILE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/x264 ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/libx264.a ${PREFIX}/lib
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/x264/distinfo b/multimedia/x264/distinfo
new file mode 100644
index 000000000000..00bacf3bd281
--- /dev/null
+++ b/multimedia/x264/distinfo
@@ -0,0 +1,2 @@
+MD5 (x264-20041029.tar.bz2) = 42a34fc79ba7d615db5a990110ce8e51
+SIZE (x264-20041029.tar.bz2) = 230695
diff --git a/multimedia/x264/files/patch-Makefile b/multimedia/x264/files/patch-Makefile
new file mode 100644
index 000000000000..5fd25a3f222d
--- /dev/null
+++ b/multimedia/x264/files/patch-Makefile
@@ -0,0 +1,12 @@
+--- Makefile.orig Tue Jan 11 23:32:24 2005
++++ Makefile Tue Jan 11 23:33:05 2005
+@@ -22,8 +22,7 @@
+ OBJASM= $(ASMSRC:%.asm=%.o)
+ endif
+
+-CC=gcc
+-CFLAGS=-g -Wall -I. -DDEBUG -O4 -funroll-loops -D__X264__ $(PFLAGS)
++CFLAGS=-I. -D__X264__ %%CFLAGS%%
+
+ AS= nasm
+ # for linux
diff --git a/multimedia/x264/pkg-descr b/multimedia/x264/pkg-descr
new file mode 100644
index 000000000000..3e1bf1a0a3e2
--- /dev/null
+++ b/multimedia/x264/pkg-descr
@@ -0,0 +1,12 @@
+x264 is a free library for encoding H.264/AVC video streams.
+
+Encoder features
+ * CAVLC/CABAC
+ * Multi-references
+ * Intra: all modes (4x4 and 16x16 with all predictions)
+ * Inter P: all partitions (from 16x16 down to 4x4)
+ * Inter B: partitions from 16x16 down to 8x8 (including SKIP/DIRECT)
+ * Ratecontrol: constant quantizer, constant bitrate, or multipass ABR
+ * Scene cut detection
+
+WWW: http://www.videolan.org/x264.html